Jump to content

SmoothText 1.1.8


WildBill
 Share

Recommended Posts

I'm using IE6, my system is fully patched.

Are you using the newest DLL? (see my last post). It should cause your FastMM logs to be complete (no blank entries).

I suspect that the problem might be in my hash code. I'm redesigning it so it will be much simpler and easier to debug. I don't have the redesign completed yet, but I'll keep you posted.

Link to comment
Share on other sites


SmoothText should be able to use just about any skin, though you have to configure the skin .INI files by hand at this point.

Just a little update: it looks like the cause of all the exceptions was in my hashing code. I completely redesigned it from top to bottom and I think I might have finally beaten the exceptions. I need to do some more testing, but I think that I might be able to release version 0.9.2 very shortly.

Link to comment
Share on other sites

Hey just an interesting discovery.

I was retrying some of the older 0.7.x versions. (0.7.6 specifically)

I found out how to get it mostly working...

I ran SmoothText and did things until Explorer did an 0x0eedfade exception. Then I would close SmoothText, open Taskman and restart the explorer process.

Now all other processes that were open at the time are smoothed (beautiful after not having it for so long), except explorer. Now there's no crashes!

What if it was possible for the hook to exempt explorer if necessary?

Link to comment
Share on other sites

I've posted 0.9.2, which should work a lot better. I haven't updated the NT4 version, that will come later after I've gotten the Win2k version nailed down. I still see occasional weirdness, but it's a lot better than before. Any bug reports are always greatly appreciated, of course ;)

Link to comment
Share on other sites

Here's the verdict:

[ 48.078] [796, 288] - Caught exception in PostObjectMessage: assembling named object list, Message = BehaviorMsg, SendCount = 10755

[ 2.531] [824, 304] - Caught exception in PostSingleObjectMessage: finding named object Behavior,DrawRedirectBehavior, Message = DrawRedirectAllowDrawing, SendCount = 2996
[ 2.531] [824, 304] - Could not send message DrawRedirectAllowDrawing to named object Behavior,DrawRedirectBehavior, SendCount = 3520, NamedObject = $00000000, Active = False, AcceptsMessages = False
[ 3.688] [824, 920] - Caught exception in PostSingleObjectMessage: finding named object Behavior,DrawRedirectBehavior, Message = DrawRedirectAllowDrawing, SendCount = 3522
[ 3.688] [824, 920] - Could not send message DrawRedirectAllowDrawing to named object Behavior,DrawRedirectBehavior, SendCount = 3549, NamedObject = $00000000, Active = False, AcceptsMessages = False
[ 3.703] [824, 920] - Caught exception in PostSingleObjectMessage: finding named object Behavior,DrawRedirectBehavior, Message = DrawRedirectAllowDrawing, SendCount = 3646
[ 3.703] [824, 920] - Could not send message DrawRedirectAllowDrawing to named object Behavior,DrawRedirectBehavior, SendCount = 3663, NamedObject = $00000000, Active = False, AcceptsMessages = False
[ 4.719] [824, 920] - Caught exception in PostSingleObjectMessage: finding named object Behavior,StandardBehavior, Message = StdBehaviorDefWindowProcW, SendCount = 3677
[ 4.719] [824, 920] - Could not send message StdBehaviorDefWindowProcW to named object Behavior,StandardBehavior, SendCount = 3992, NamedObject = $00000000, Active = False, AcceptsMessages = False

It runs in my VM (smoothes text) but crashes explorer. In my real system, smoothtext uses 50% cpu without any effects at all.

Only logs from VM.

Link to comment
Share on other sites

Heya fellas!

First, Wildbill, I want you to know how much I appreciate your work on this one. I've always wanted to keep using windows 2000, but the ugly fonts on LCD screens prevented me from doing so. Then I found this program!

But..

I can't get it to work on win2000 sp4. Whenever I start it, my desktop icons disappear and the desktop itself stops responding to clicks. However, I can click the start button, but it just stays pressed and nothing happens. The explorer.exe keeps running though.

There's an error message saying something about a memory leak in hook.dll I think. I can't tell exactly, must check tomorrow.

//edit:

Here's some error messages I found in the log files:

[ 0,031] [116, 980] - Caught exception in PostObjectMessage: assembling named object list, Message = BehaviorWndProcRet, SendCount = 82

[ 0,188] [768, 904] - Caught exception in PostSingleObjectMessage: finding named object Behavior,DrawRedirectBehavior, Message = DrawRedirectReleaseDC, SendCount = 1905

[ 0,188] [768, 904] - Could not send message DrawRedirectReleaseDC to named object Behavior,DrawRedirectBehavior, SendCount = 1944, NamedObject = $00000000, Active = False, AcceptsMessages = False

I've attached the errog log file concering the memory leaks.

Hope that helps!

cya

TextHook_MemoryManager_EventLog.txt

Edited by chillneo
Link to comment
Share on other sites

The DLL has all the debugging information in it so I can see where a memory leak takes place. The problem, though, is if there is an exception there is always a memory leak, so it's of limited benefit.

I occasionally see Firefox crash, but it never seems to leave a log when it does. I've also seen some weirdness when Override Standard Controls is enabled.

In the interest of narrowing it down, would you mind trying it with everything except text smoothing turned off? That is, turn off skinning, overriding standard controls, translucent taskbar, etc. Basically I need to know what subsystem is causing the problems so I can start looking closely at it. In the meantime I've expanded skinning in 0.9.3 to include status bar controls, but until we narrow down the remaining source of instability I've been sitting on it.

Link to comment
Share on other sites

but until we narrow down the remaining source of instability I've been sitting on it.

That sounds great don´t release it until you feel it good enough for testing.

and also could you try release an simple Skin for it with some pictures to test the skin engine with.

So the 0.93 has one simple skin to test with.

Because I can´t get it to work and it would be nice to have one working skin just for testing.

Link to comment
Share on other sites

Hey WildBill!

I redownloaded 0.9.2 and this time around it worked on my main install.

No options were set, (default, deleted the SmoothText registry folder beforehand), except for smoothing factor = 3.

There are absolutely problems with any other programs, except explorer which continually crashes.

FastMM throws memory leaks and the large error messages when I try to start explorer from task manager.

There is a humongous memory manager log, which is attached below.

I did notice some absolute paths which does not exist on my system, but only in referring to source files.

(Smoothing back in Firefox! :thumbup )

Maybe an option to exclude explorer from being hooked as a stop-gap measure?

EDIT: Font Substitutions work. Override Standard Control causes hard lock needing power button reset.

Edited by Colonel O'Neill
Link to comment
Share on other sites

  • 2 weeks later...

It took a while, but I've managed to track down several problems for version 0.9.3, and I hope fixing them will make the program more stable (please see the top post for the link, as usual). I'm certainly seeing less problems so far, but if you wouldn't mind testing it I'd appreciate it.

Enjoy...

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...