Jump to content

DMI BIOS year


Swami
 Share

Recommended Posts

A year ago I customized my Windows XP Professional installation using nLite. In Options under the tab General I enabled the option Remove old BIOS information and then installed those customized Windows. No problem here.

Now using Ubuntu 7.10 (Linux) I have a problem with ACPI not being enabled because my DMI BIOS year was removed with that option Remove old BIOS information and the Linux kernel needs that info in order to check if the motherboard was made pre-2000 or post-2000; if made pre-2000, it disables ACPI - and if made post-2000, it enables ACPI. I need ACPI enabled to be able to use the suspend and hibernate mode in Ubuntu 7.10.

Nuhi or anyone, please tell me how can I restore or get back the DMI BIOS year of my motherboard. My motherboard is NVIDIA nForce2 Ultra 400 + MCP.

Thanks.

Edited by Swami
Link to comment
Share on other sites


I don't think this is related to nlite. nlite can't act the bios level : all it can do is remove a check windows and only windows performs.

Anyway this tweak does not even remove this in windows : it simply removes informations windows has about bioses, just like you could remove drivers. Removing sound card drivers won't make your sound card fly away. This is the same.

About linux, I have acpi and while this is mandatory to get suspend and hibernate, this is not sufficient.

What you can do is recompile your linux kernel with the same configuration as your ubuntu but without the pre-2000 check. But it will not necessarily solve your problems as power management is tricky under linux (acpi used to be tricky, now this is ok but resume and suspend are big deals).

If you need help on this I can help you (and don't be scared with the kernel recompile).

Link to comment
Share on other sites

Camarade_Tux, thanks for posting.

My motherboard was made in the year 2001. If I could add the value 2001 to DMI BIOS year, this would enable ACPI at booting time and eliminate the message ACPI: no DMI BIOS year, acpi=force is required to enable ACPI.

I added the acpi=force in the GRUB configuration file (menu.lst) at the end of the kernel line, but that still doesn't remove the message ACPI: no DMI BIOS year, acpi=force is required to enable ACPI before booting Ubuntu 7.10, and ACPI is still not enabled.

Please help me to flash my BIOS or update it, or help me to add the value 2001 to DMI BIOS year, or something.

Thanks.

Link to comment
Share on other sites

You can't change DMI informations that way. Really.

I really think you should get the ubuntu kernel sources, use a console, cd into the expanded sources, make gconfig, wait a bit and use the search to find the string "2000", disable the proper option, close and save the window, in the console, type "make all install modules_install".

But you should know you may have problems with acpi on your computer : I wouldn't bet your computer will properly boot with acpi enabled. You should find a recent livecd with acpi enabled and try first.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...