Jump to content
MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. ×

How do install Wingroove on Vista?


nensondubois
 Share

Recommended Posts

  • 1 year later...

what version of WinGroove are you trying to install under Vista? Version 0.A4 Beta 2? Forget about v0.9E and earlier as those won't work under Vista for sure.

Try setting the setup program's compatibility mode to XP SP2 and then try running Wingroove setup in Vista again.

Update: I've just installed WinGroove 0.A4 Beta 2 English on Vista Home Basic, running the WG0A4_E.EXE file in Windows XP SP2 Compatibility mode, rebooted Vista and Wingroove worked great. However, there are no options in Vista to configure MIDI devices, so if you want to set Wingroove as your default MIDI device, create the following registry entries, save them as REG files and import the REG files in Vista.

Save the file below as wingroove-midimap.reg (without the dashed lines)

---

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Multimedia\MIDIMap]

"szPname"="WinGroove (NT)"

"RelativeIndex"=dword:00000000

"DeviceInterface"=""

"SetupPreferredAudioDevicesCount"=dword:00000000

"UseScheme"=dword:00000000

"AutoScheme"=dword:00000000

"CurrentInstrument"="WGDRVR32.DLL<0000>"

---

Save the file below as midimap1.reg (without the dashed lines)

---

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Midimap]

"Mapping Name"="Sound System"

---

Update II: I have also tested the Japanese edition of Wingroove 0.A5 by setting the WG0A5.EXE file to XP SP2 compatibility mode in Vista, ran that file and installed it on Vista. Worked great.

Edited by erpdude8
Link to comment
Share on other sites

  • 4 weeks later...

Even if everything is going fine for you, the installation teminates for me.

No problem in unpacking the file, but when the installation tries to start, the following error appears:

"Unable to read C:\WG0A4.TMP\. The Installation terminated."

Doesn't matter if I change the path, the drive or set the compatibility settings to any Windows, it does not install.

I also tried to start the installation manually, by starting Wginstlr.exe in the chosen directory, same error.

Wgsta4.exe seems to start the installation, but then some files are missing, like the Wingroove.drv.

I tried it with the Beta 0.A4 Beta 2 as well as the newest Japanese one. Although I don't understand it, it seems to be the same error.

Maybe you have changed anything else...?

Edited by GandalfderGraue
Link to comment
Share on other sites

Ah sorry, solved this myself, so I'll let others know who have the same problem...

Just download the package you want and start, causing the error, now go to the directory you unpacked to and rename a few files...

- Wgadra4.drv --> Wingroov.drv

- Wgmfa4.dll --> Wgmfp.dll

- Wgsta4.exe --> Wgsetup.exe

- Wgtsa4.exe --> Wgtsk16.exe

Start the installation with the freshly renamed Wgsetup.exe, no error should come up.

Link to comment
Share on other sites

  • 5 months later...

Is there any chance to get Wingroove working under Windows x64? I know it is a partial 16 bit and partial 32 bit program. The WGPlayer.exe is 16 bit so it won't start under Vista64. However, the WGDRVR32.DLL seems to be 32 bit. Can it be used without the player?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...