Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Brabant

Member
  • Content Count

    99
  • Donations

    $0.00 
  • Joined

  • Last visited

Everything posted by Brabant

  1. Brabant

    FDV fileset for XP

    I see HKLM,"SYSTEM\CurrentControlSet\Control\Session Manager\Environment","Path",0x00020002,"%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem" in HIVESYS.INF. And HKLM,"SYSTEM\CurrentControlSet\Control\Session Manager\Environment","Path",,"%SystemRoot%;%SystemRoot%\system;%SystemRoot%\system32;%SystemRoot%\system32\WBEM" in AXANT5.IN_. The code above is for including "%SystemRoot%\system" so I'll add 0x00020002 between the commas after Path, maybe they cause the wrong type REG_SZ. >> Yes, that seems to have done it.
  2. Brabant

    FDV fileset for XP

    The Path variable in HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Environment must be a REG_EXPAND_SZ and not a REG_SZ like it is in the file set. Now the command Path gives PATH=C:\WINDOWS;C:\WINDOWS\System; ..etc.. But the command %Path% gives 'C:\WINDOWS' is not recognized as an internal..etc.. Is that OK? I thought %Path% should just print the paths without the "PATH=" part. (And Path to be for setting paths or querying if you want)
  3. Brabant

    FDV fileset for XP

    Those three greyed out settings get enabled by changing HKEY_CURRENT_USER\Control Panel\Desktop\UserPreferencesMask from "00 00 00 00" to "b0 12 01 80", a value I borrowed from a non-fdv-xp install. I don't know yet if it breaks anything but these things can now be accessed. Now what's wrong with me %systemroot%\system and other paths? Edit: starting a cmd box and giving PATH gives PATH=C:\WINDOWS; ..etc.. in the non-fdv-xp box but gives PATH=%SystemRoot%; ..etc.. in fdv-xp Any ideas about this please?
  4. Brabant

    FDV fileset for XP

    So I've got to use XP anyway... Chapa9ai Thanks for pointing to sfc_os.dll. It now installs faster and without this nonsense about things being unsigned. And the mofcomp error is not in the latest file set. A few things: I have bmp2png in the windows/system dir. But if I do c:\bmp2png it is an "unrecognized internal or external etc..." , so it can't find the path I'd say. In the environment variables there is %systemroot%/system and system32 and system32/wbem, all separated by colons. What's going on? The Effects (under Display Properties -> Appearance) are unavailable. See attached pic if it's unclear what I mean. Having ClearType is essential. Not sure if the following are sources of these problems but I ran this HFSLIP without any HFs to speed things up and I'm running XP in VPC2007.
  5. Brabant

    Slipstreaming NT4 SP6a

    So I'd unpack sp6a to a directory, the same for q299444i.exe roll-up and also for later fixes (those in the first post). Keep the hotfix.inf that comes with each fix, and "run assorted supplied scripts" ? Do you have (test versions of) these scripts?
  6. Removing ms_1_exc_disableIfOS="w2k" from [V] gives a corrupted viamraid.sys. I guess I need to remove stuff from the HardwareIdsDatabase and/or other sections. Or maybe make the mass storage zip only contain the Via dirs. Do you have any suggestions?
  7. Oh look! What a coincidence, I had noticed the line: ms_1_exc_disableIfOS="w2k" for PCI\VEN_1106&DEV_0571. So it wasn't a surprise that should install (and has installed) without extra files. I don't like to add 10000 files just for the few that are (possibly) useful. So I'm gonna try editing the ini in the Mass Storage 7z. Maybe delete unused directories as well. If that doesn't work I'll have to add ms_1_exc_disableIfOS="w2k" lines. Edit: I just found the nightlies (since they're mentioned in one thread you linked to) http://driverpacks.sytes.net/driverpacks/Nightlies/NT5/
  8. [HardwareIdsDatabase] PCI\VEN_1106&DEV_4149 = "viapdsk", "VIA ATA/ATAPI Host Controller" Yes that line came free with storage.ini. It doesn't do anything. (I do have PCI\VEN_1106&DEV_0571 (ata controller) in the registry. But that has installed correctly from IDE cd, without adding any files or ini entries.) I read your post and thought that trying Mass Storage would be best. Install fails with a corrupted ahcix86.sys. There seems to be one in AM2 and one in AM3. The one that ends up in i386 can be copied and expanded manually.
  9. It's a bit more complicated than that. viapdsk must also appear in [sourcedisksfiles]. It's like the 'single-file driver that you want to integrate and have installed at boot time' near the bottom of that page. I already have done that method for viamraid.sys (meaning I had it both uncompressed in i386 and also compressed for storage.ini method) that did not work.
  10. Yes, on this computer an IDE CD-ROM is also attached. And also the last thing I see is in text mode after loading drivers it says 'Setup is starting Windows 2000'. The screen goes black for a second and then BSOD. Edit: Just disconnecting the IDE CD drive does not do it. I'll add viapdsk (that's for IDE and was in early Hyperions and older, right?) and try that now.
  11. It's even smaller only 335KB. Anyway... TXTSETUP-from-SSource.zip
  12. No that's not it. Txtsetup.sif went down from 391KB to 343KB though.
  13. I must say I do use an UNmodified storage.ini which is 48KB, the VIA stuff is near the end. Should I take the rest out? But for actual files only the viamraid.sys, .cat and .inf are in the HFEXPERT/STORAGE dir. So no sound, video or any other drivers are there.
  14. It's a desktop with an Asus A8V motherboard with 2GB of RAM. It has no "IDE compatibility mode". The iso is 217 MB (I have included post-SP4 hotfixes in HFSLIPs HF directory). I use two Sata drives as separate drives. No RAID has been configured. I'm happy the other installs are "normal" I just mentioned them as "this still works, has not been f*cked up".
  15. Sorry I forgot to mention that. I already have tried, it gives the same result.
  16. I'm using HFSLIP with an SP4 integrated 2000 as source. The VIA driver for Sata disks is integrated using Oleg IIs storage.ini method. The result can install 2000 from an IDE cd-rom to an Sata drive and it can install 2000 from an USB cd-rom to a Pata (IDE) drive. But what I was aiming for is from USB cd-rom to Sata HD. And that gives the 0x7B error after loading all the storage drivers. I thought it could not find the HD but I read 0x7B is about the source, not the target disk. I don't know how to fix this so if anyone has ideas....
  17. Brabant

    Fileset 9, all done

    No, you can get the latest fileset 3111KB. Like fdv said 'Probably HIVESFT'. That's the one that changed and it installs without problem.
  18. Brabant

    Fileset 9, all done

    What you guys are talking about? Even my old VIA (KT400 and KT600) boards have "usb cd-rom" as a boot option (press F11 for boot menu). So I have received the usb burner now and when I choose to boot from usb it installs perfectly! At least on the KT400 i.e. on a Pata (IDE) disk. On the KT600 things are much slower ('setup detects hardware' takes 10 mins) and when the setup screen appears it shows the F6 message (which then disappears) and just seems to sit there. This is a pity because this board has Pata and Sata connectors I could experiment with. Anyway the board seems to fall back to usb 1.x speeds. On another board, Asus A8V, I get an INACCESSIBLE_BOOT_DEVICE error after all files have been copied to disk. And that is using an Sata disk (!) on yet another VIA chipset. Maybe MS knows about this: 883114 so I'll make an iso including that fix. (although that article talks about 'may not start after you install the OS') Last thing: the 'immediate reconnect of usb devices on VIA a board' is back. Which got fixed at some point. But (for now) I'll use KB827675 as suggested in post #37 of this thread.
  19. Brabant

    Fileset 9, all done

    I've got a computer that has no cd-rom anymore and I think I want to keep it that way. The board can boot from usb devices and also fdv-2000 installs to sata from an IDE cd without problem. So the last potential hurdle: Is there any reason why fdv-2000 would NOT be able to install off an USB cd to an (Sata) disk?
  20. Kankerzooi. [oemboottroep] vergeten.
  21. Did anyone have error 0x7B INACCESSIBLE_BOOT_DEVICE and get it solved? I use viamraid.sys to get 2k to install on an SATA drive with the 'single file driver' method (PCI\VEN_1106&DEV_3149 = "mySATAdevice"). The uniata stuff is left commented out because there's also a PCI\VEN_1106&DEV_3149 in that section. Four different file versions of viamraid.sys all get through the txtmode of the setup and none of them any further. (I read about setting the drive in 'compatibility mode' but can't find that in the BIOS.) Edit: The board does not have the 'compatibility' setting. What to do?
  22. Brabant

    Fileset 9, all done

    That wasn't it. But the new set with the old CLS does install. The file with differences and linenumbers is attached. I don't think anything got removed from the old CLS, only stuff (MSI) has been added. hiveCLS.txt
  23. Brabant

    Fileset 9, all done

    Some time ago in some other thread you posted a file with new timezones. That file was 83KB and after fixing it was 64KB. The new hivesft is 251KB vs 179KB for the older one. Also the fixed TZ file has lines commented out like the old hivesft, not like the new one. Like: lines 1248-1250 in the new file: HKLM,"SOFTWARE\Microsoft\Windows NT\CurrentVersion\Time Zones","TZVersion",0x00010001,00,01,da,07 HKLM,"SOFTWARE\Microsoft\Windows NT\CurrentVersion\Time Zones","TZBaseYear",0x00010001,da,07,00,00 HKLM,"SOFTWARE\Microsoft\Windows NT\CurrentVersion\Time Zones","KBLast",0x00010001,00,01,da,07 these three are at the end of the TZ section both in the old set and in the fix you posted earlier. I could only find these two lines added to hivesft: line 114 HKLM,"SOFTWARE\Classes\Msi.Patch\shell\Open\command",,,"""%11%\msiexec.exe"" /p ""%1"" %*" line 438 HKLM,"Software\Microsoft\Windows\CurrentVersion\Installer","InstallerLocation",0x00000000,"%10%\system32\" I've replaced the TZ stuff with that from the fix and will run that. But not now because it's 00:40 in ze night.
  24. Brabant

    Fileset 9, all done

    No it doesn't. I've only just now needed a (new) 2k and decided to use the fileset that is currently linked to (last changed is shell.in_ at 10-06-2010). That gives this error in vpc2007. What issue(s) should this fileset solve?
  25. Brabant

    Fileset 9, all done

    With set 8k things are as in install 2 (so with "add to" and "organize") but without the Media dir. "4 rearrange the shortcuts I want if that is possible (only by renaming?)" - I hadn't tried drag&drop then. A bit too advanced you know.
×
×
  • Create New...