Jump to content

run once ex error message

Recommended Posts

good evening all, and a very happy thursday to you!

Slight problem, when my unattended installation finishes, and i log on, the computer starts RunOnceEx, it seems to install .netframework 1.1, but then it gives the error message "command line option syntax error" and so does not work!

Does anyone have a clue as to what can be wrong with this!? most annoying!

cheers, jonny

Link to comment
Share on other sites

Sorry guys, major oversight on my part, heres my runonceex file, its extremely small as i'm just trying to get it to work for one application before going the whole hog!

@Echo Off

SET PP=%SystemDrive%\Install\

SET KEY=HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnceEx

REG ADD %KEY% /V TITLE /D "Installing Programs" /f

REG ADD %KEY /VE /D "Microsoft .Net 1.1" /f
REG ADD %KEY /V 1 /D "%PP%dotnetfx.exe /qb" /f


Thanks again for looking guys!


Link to comment
Share on other sites

hello again!

I've changed the switch in the config.txt to /s and changed the switch in the RunOnceEx.cmd to /s aswell, and still i'm getting the same error message! Is this only a switch problem or is there something else that im doing wrong?

Jonny :wacko:

Sorry... as it turns out, when i run my RunOnceEx file on my machine, it doesnt write to the registry either! thought that might be of use to someone!

thanks again

Edited by tech_boy
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...