Jump to content

Network packet analyzer on WinPE 2.0 - recvfrom hangs


Recommended Posts

Im trying to run my simple UDP time server on WinPE 2.0

It calls recvfrom to receive any time-requests from clients.

But whenever I send time-request to this server, it never comes out of recvfrom.

If I run same UDP server on Win2k3 it responds fine.

I want to see whether UDP packet from client is actually reaching to WinPE machine.

I tried installing etheral on Winpe but it gives me error (unable to write to X:\windows\temp\nsrDE40.tmp\system.dll)

I also tried installing WinPCAP setup on WinPE - it also gives me "illegal instruction error"

Can anyone suggest me solution of my original problem? or any network trace tool which can run on WinPE?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...