Jump to content

Language files not being installed during Setup


m0rpheus
 Share

Recommended Posts

So it has probably been said a million times, but I'll say it again, "nLite is GREAT... I absolutely love it..." Many thanks to Nuhi and the folks involved! Now that that's out of the way, here's my problem ...

I have used nLite to remove useless Windows components many times; the only thing that remains "untouched" are the Language/IME related components. I do not remove these since multi-language support is required on most computers I work with. The strange thing is, everytime I install Windows XP, the language files I need (in this case, Thai) aren't being installed during Windows Setup. Please note, this does NOT occur if I do a regular "non-nLited" unattended installation of Windows XP!

This really isn't an "issue", but more of an minor annoyance in that I have to manually install the Thai language files after setup (via Control Panel >> Regional Settings). Maybe it's something I accidently selected for removal or perhaps a bug?? I've tried to search for answers, but have not found any... I'm using nLite 1.0.1 "Final" btw.

As for my UNATTEND.TXT file, my regional options are set as follows:

[RegionalSettings]
LanguageGroup=11,1

One more thing, is it common to get Windows File Protection popups from running an nLited Windows? For example, when I insert a USB flashdisk (for the first time), I get at least 2-3 WFP popups; or when installing the multi-language files (from CD) I also experience WFP popups. Again, just a minor annoyance... Is this normal or is it not? Yes, I could turn off WFP, eliminating this issue altogether -- but prefer to leave it on...

Thanks in advance for your feedback!

Link to comment
Share on other sites


Hi man.

1.it is common to get WFP errors when you install drivers. The only thing you can do about it is disable it with Nlite.

2.I use English and Hebrew in windows. so my regional settings look like this -

[RegionalSettings]
LanguageGroup = 12,1
SystemLocale = "040d"
UserLocale = "040d"
UserLocale_DefaultUser = "040d"
InputLocale = "040d:0000040d"
InputLocale_DefaultUser = "0409:00000409"

I always edit myself the winnt.sif file because Nlite doesn't create the setting I want. these settings add support for hebrew and keep English as the default language.

"040d" = hebrew.

"0409"=english.

I suggest that you use my setting and just replace hebrew ("040d") with Thai (?) and your language group (11).

Edited by shoeman
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...