Jump to content

MUI - Hebrew Fonts Problem


Gantlett
 Share

Recommended Posts

Hi everyone

I have created an nLite WinXP Pro Corporate edition CD and it works beautifully, except for one problem:

After installing Hebrew MUI, Hebrew, in some programs, is displayed as total gibberish (question marks).

The source CD was WinXP Pro Corp. SP1. I used nLite to integrate the following updates:

-SP2-ENG

-RyanVM's Post-SP2 Update Pack v2.1.5a

-RyanVM's DirectX 9.0c Addon v1.1

-RyanVM's WGA Addon v1.5.723.1

-RyanVM's WMP10 Addon v3.0

-Internet Explorer 7 ENG

In the menus, in some places, Hebrew is displayed correctly, in some it is displayed as gibberish, and in other places the languaege is English instead of Hebrew.

For example, WinRAR in Hebrew displays all the Hebrew text as question marks.

Now I know how WinXP Pro in Hebrew should look like - I have a localized version of WinXP Pro installed on another computer and everything is perfectly fine there.

I have also tried copying the entire fonts folder from the localized computer to the nLite computer but it didn't do anything at all (for good or worse...).

Have the MUI CD's changed at all since the last five years? Because the MUI CD I have is about that age, but I've used it in many computers (not with nLite) and I haven't encountered any problems like these at all. I guess that if there have been changes/updates, MS would update the MUI files through MS Update, wouldn't they?

Any help will be greatly appreciated - I don't want to reinstall the computer, really...

Thanks a lot,

Gant.

Edited by Gantlett
Link to comment
Share on other sites


Hi man,

1.in the 'control panel' go to Regional and Language Options' and make sure that al the settings are correct.

2.did you remove any languages with Nlite? you should not remove - Arabic, armenian, Georgian, Hebrew, Indic, Thai, vietnamese.

3.I also had problems in Nlite with hebrew. so after I'm done with Nlite I edit the WINNT.SIF (in the I386) and change the settign manually. it should look like this:

[RegionalSettings]

LanguageGroup = 12,1

SystemLocale = "040d"

UserLocale = "040d"

UserLocale_DefaultUser = "040d"

InputLocale = "040d:0000040d"

InputLocale_DefaultUser = "0409:00000409"

Hope it helps.

Link to comment
Share on other sites

Thanks for the tip, but I have a feeling the problem lies deeper.

Could anyone else help me with this? I'll reinstall everything if I know it'll work!

What if I create an nLite CD with no updates at all (except for IE7 :)), install the MUI and then update it with AutoPatcher? Could that solve the problem?

Thanks again,

Gant.

Link to comment
Share on other sites

OK

After reading for several hours on the internet and mainly doing a WinXP installation test, I came to the conclusion that the MUI pack should be installed to a clean SP2 (preferably SP1 in the Hebrew case because it hasn't been updated since SP1). Ideally, it's best to run Windows Update after that, go to sleep, and wake up after all the updates have been downloaded and installed.

This sucks. :no:

I've also found this page which explains how to automate the installation of MUI during or after installation, but not how to integrate it.

It appears that installing MUI onto an already fully updated SP2 XP screws things up...

Is there a way to integrate MUI into the XPCD just like WMP, IE7 and other WinXP features can be?

Also, is it safe to use AutoPatcher instead of using Windows Update?

Thanks everyone...

Edited by Gantlett
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...