Jump to content
MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. ×

Directx 9.0c December not installed at T-13

Recommended Posts

All my searches so far revealed that using

dxsetup.exe /silent

will result in a silent installtion of DirectX 9.0c after extracting the original redistribution archive. This works fine for me after the installation, but if I execute this statement atT-13, DX9 is not installed.

Not appearing as an installed program anyway I use dxdiag.exe to determine the state of the installation. After a successful installation, there are a whole lot of new files listed in the files tab of dxdiag, all bearing the current date. When I try to do this a T-13, these files are simply not there. With the first release of DirectX 9.0c this worked perfectly - only it became unnecessary after SP2 for a short while since DX9 is included.

As mentioned above, searching for this in connection with problems at T-13 didn't bring up anything in this forum, otherwise I wouldn't have posted. I only find the same answer over and over. So maybe somebody has any idea what the problem could be.

Link to post
Share on other sites

it works if you change Exe. You have to replace dxsetup from DirectX 9 (size : 473kb) with the one from DirectX 8 (size : 47Kb).

After, launch it with (it's the commandline I use in a BAT/CMD file scripted in "CMDLINES.TXT") : %systemdrive%\winapps\directx\dxsetup.exe /install /silent

Link to post
Share on other sites

dont use other files. just open the dxsetup.exe with winrar and extract its contents. to install it silently use the extracted file dxsetup.exe /silent

not the original dxsetup.exe (wich you extracted the setup files from) downloaded from microsoft.

works fine and i have installed this thousand times now.

Link to post
Share on other sites
  • 2 weeks later...
Nope still doesnt work

what exactly didnt work?

if you extract the files and use the file dxsetup along with /silent it will work.

my runonceex entry (i have installed this tons of times)

REG ADD %KEY%03 /VE /D "Microsoft DirectX 9.0c Dec 2006" /f
REG ADD %KEY%03 /V 1 /D "%systemdrive%\Install\directx\dxsetup.exe /silent" /f

by the way, run it from your hard disk just in case. some setups dont like to be ran from read-only media.

Link to post
Share on other sites

Yes i did that, cause when i use the same installer from wpi/runonce it works.

And how i know it doesnt work?, cause when i try to install 3dmark 06 it says it needs DirectX to install.

When i run the DirectX before 3dmark 06 in wpi/runonce it doesnt ask for DirectX.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

  • Create New...