Jump to content

nLite & Apple iTune 7x


the0ry
 Share

Recommended Posts

10/23/06: well, seems that i have come to the point at which i have broken itunes. ive come to realize that itunes is dependant on windows media play, atleast 9x, well more like a dll or 2. ive run into a little bit of another problem. seems that on the most recent nlite installation of windows xp sp2 vl 32bit, the only way the ipod is detected in itunes is when i start the computer with it already plugged in. if i plug it in after the computer starts, itunes does not detect it, weather it is plugged in while itunes is running or not... normally id say this is weird, but not i. i beleive this is due to removing "Shell Services" under Components > Services... i could be wrong tho, but untill i can test it out again, id like some intel. from anyone else whom has toyed with itunes and nlite. anyways, thanks in advance... heres some code for you :P

10/27/06: well, it is not "Shell Services" which is causing this... but anyways, any1 else with this problem, please post their session files

Apple iTunes 7x depends on the following (...so far):

Windows Media Player 9x (Actually just 1 "dll" file, but I forget which one)

ATTACHMENTS!!!

Last_Session.ini - nLite 1.2 RC

gateway_large.ini - nLite 1.01 this is the latest nlite I've done which did not effect the iPod

Last_Session.ini

gateway_large.ini

Edited by the0ry
Link to comment
Share on other sites


I just installed an nlited 2003 Server Standard yesterday and I have the same problem. I didn't remove shell services, however. I haven't tried rebooting with the ipod nano plugged in so I'll try that next.

Edit: Yeah, mine will detect if I leave it plugged in at bootup. Post your session file again so I can compare.

//removed by mod, attach your preset don't copy paste it, it's too much to scroll

Oops... sorry bout that. I haven't been here in a while. :angel

LAST_SESSION.INI

Edited by Grope For Luna
Link to comment
Share on other sites

The only components I can possibly see having an effect is Portable Audio or Firewire 1394 support.

I turned on Regmon and filemon, plugged in the ipod and the ipod service doesn't make a peep. iTunes checks info on all of the drives except the ipod but that's about it.

Link to comment
Share on other sites

hrm... its not USB audio support.... and itunes 7.1.0.8 didnt seem to work without a WMP 9x dll on windows xp sp2 vlk installation... im gonna check through all my old presets, figure out when this actually started... keep ya posted

Link to comment
Share on other sites

actually, i am using RyanVM's Windows XP Post-SP2 Update Pack 2.1.3 which is integrated with RVM Integrator 1.4.2... so no hotfixes/servicepacks/updates are added during the nlite process... ive come to test to many things today, and i dont have that many more cd-r's to spare... anyway, im going to compair differences between my last working nlite and the most recent... and once again...

IF YOU ARE EXPERIENCING SIMILAR PROBLEMS WITH NLITE AND APPLE ITUNES, PLEASE POST REPLY, AS WELL AS SESSION FILES

Link to comment
Share on other sites

Just tried another install with a few other things enabled - no go.

I have a mini 2003 install from Experience on another drive and the ipod can't be detected on that system either. I'm not sure what version of nlite he used. Likely 1.2RC. I think I'll try with version 1.01.

Link to comment
Share on other sites

In conclusion to some recent tests, I have no idea what is causing this problem. I do not think it is nLite along. I believe it is a combination of nLite and recent versions of iTunes. I plan on reverting back to previous versions of iTunes in hope that it solves the issue. In the mean time, I have managed to figure a workaround with this issue.

1. Ensue iTunes is completely shutdown.

2. Ensure that the iPod is properly plugged in via USB 2.0.

3. Navigate you way to the Windows Services. (Control Panel < Administrative Tools < Services)

4. Right click on the Service named "iPod Service" & from the drop-down menu, click "Restart".

5. Launch iTunes.

Note: Repeat this process whenever reconnecting iPod for purposes other then charging.

Link to comment
Share on other sites

Another test completed. It is offical. nLite 1.2x & Apple iTunes 7.0.x do not work together. I have done testing on all versions of iTunes dating back to 6.0.5. Everything later then iTunes 6.0.5, which all belong to the iTunes 7.0.x series, do not work together on a versions of nLite later then 1.0.1, which at this time is 1.2 Beta, 1.2 RC, 1.2 Final. I have not tested the recently released nLite v1.2.1. Being that iTunes 6.0.5 works with nLite, probably provides better system performance, and the latest version of iTunes 7.0.1.8 does not have anything different other then colors, I am sticking with iTunes 6.0.5 for the time being.

Download iTunes 6.0.5.20 via FileHippo.com iTunes Archive

Edited by the0ry
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...