Jump to content

Starting Vista Winpe Image from Linux PXE Server

Recommended Posts

Anyone know how to start a Vista 64 bit WinPE image from a Linux server via PXE. I see that the the

WinPE image I created has some boot related files in Windows\Boot\PXE, but I am not usre which files I need.

I tried using pxeboot.n12 and bootmgr.exe. It looks for \boot.ini and \Boot\BCD and cannot fid them,then the Windows boot manager prints a failed start message.

An help with launching the WinPE boot.wim from PXE on a Linux server would be appreciated. Thanks.


Link to comment
Share on other sites

OK, made some progress. Now, when the wdsnbp.com is downloaded, I get a message

stating that a tftp error occurred. I see no errors in the message log. tcpdump shows that all the bytes

of the wdsnbp.com are downloaded. This is on

Redhat 4.0 with the ISC 3.0 DHCP server. Anyone have any clues.


Edited by kennedto
Link to comment
Share on other sites

  • 2 weeks later...

You dont need to load wdsndp.com if you dont use WDS, you can point your DHCP options to pxeboot.com or n12 instead and skip the WDS check (will save you around 30 sec in startup time)

What does your boot folder contain and have your created a BCD fil according to the instructions in the WAIK help file, section "Deploy an Image by using PXE" ? The most common error you'll see during boot is that your BCD is missing required information.

Edited by ubernerd
Link to comment
Share on other sites

  • 3 weeks later...
  • 3 weeks later...

My problem seems similar, so I'm wondering if anyone can provide some tips.

I'm trying to install Vista on my Toshiba m200 tablet that has no optical drive. I'm trying to use the instructions provided here for setting up a PXE server:


I've successfully followed those instructions, and can PXE boot my Toshiba using a DOS boot disk image, verifying my PXE setup works.

I now want to try booting WinPE 2.0. I've followed the instructions in the WAIK "Deploy an Image by using PXE", so I now have a Boot folder containing all necessary files, under my tftpboot folder.

I modified the "default" file in the pxelinux.cfg folder so the last line says:

append initrd=boot\pxeboot.com

I run the tftpd32 application, start my tablet, and choose to boot from the network. I see it download memboot, pxeboot.com. I then see the message "Press F12 for network service boot" (as the WAIK suggests I should).

Pressing F12 does nothing. Everything in the 2 guides worked fine up until this point (once I switched from wdsndp.com to pxeboot.com, as mentioned in this thread).

Unfortunately, I have to plead ignorance to the inner workings of tftpd and PXE, so my troubleshooting can't go very far.

This is what my "default" file in pxelinux.cfg looks like:

default boot

prompt 0

say booting...

label boot

kernel memdisk

append initrd=boot\pxeboot.com

This is what my Tftpd32 app folder and subfolders contain:


















Any suggestions on other things to try, where to look for more guidance, etc, would be greatly appreciated.

Link to comment
Share on other sites

Please disregard my last post. After thinking about my setup some more and reading the syslinux documentation, it finally occurred to me that I didn't need to use pxelinux or memboot at all. I had tftpd32 configured to boot pxelinux, and had pxelinux configured to send memboot and pxeboot.com. I eventually realized that I just had to configure tftpd32 to boot boot\pxeboot.com (on the DHCP Server tab) and ignore the pxelinux configuration.

(Believe me, I spent hours on this before posting for help, and just by dumb luck figured it out immediately after posting).

Hopefully this information can help someone else.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...