Jump to content

windows unable to set proper dhcp ip address


Recommended Posts

is there a bug w/ the latest windows update? i just have reformatted my computer and this starting to happen. the DHCP address being place in my comp s different from the one being assigned by the router.

Edited by hmaster10
Link to comment
Share on other sites

no specific address, i set it to accept auto DHCP ip from the router.

the thing i found out is that it keeps on setting the ip as which is not even in DHCP ip range/list of the router.

Edited by hmaster10
Link to comment
Share on other sites

That address is in a range which XP allocates when it cannot find one from your DHCP, it will say something like Private Adressing if memory serves me right.

It sounds as if your system is not talking to the router at all.

Can you....


Type CMD

Press [enter]


Press [enter]

and post the results of the above text file here? It would help greatly. :thumbup

NB: The text file is located @ C:\IPLOG.TXT

Link to comment
Share on other sites

the output contains the following:

Windows IP Configuration

Host Name . . . . . . . . . . . . : organiza-5630cb

Primary Dns Suffix . . . . . . . :

Node Type . . . . . . . . . . . . : Unknown

IP Routing Enabled. . . . . . . . : No

WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix . :

Description . . . . . . . . . . . : Realtek RTL8139/810x Family Fast Ethernet NIC

Physical Address. . . . . . . . . : 00-E0-4C-00-36-43

Dhcp Enabled. . . . . . . . . . . : Yes

Autoconfiguration Enabled . . . . : Yes

Autoconfiguration IP Address. . . :

Subnet Mask . . . . . . . . . . . :

Default Gateway . . . . . . . . . :


Edited by hmaster10
Link to comment
Share on other sites

This is a so-called APIPA (Automatic Private IP Addressing) address, which is configured automatically when no DHCP server is available. Check if the DHCP server is running and configured correctly, and check network connectivity between the client and the DHCP server.

Link to comment
Share on other sites

how do i check if the dhcp server configured correctly?

That depends on what type of DHCP server you have...

if its about the router, it is working fine coz 2 of 3 comp is still working fine w/ their network connection

They might still have valid IP address leases, so you wouldn't notice if they had DHCP problems as well. Open a command prompt on one of the other clients and type "IPCONFIG /RENEW" to check if it can renew its IP address lease. If it can't, there's definitely something wrong with the DHCP server.

Link to comment
Share on other sites

yes, after the ipconfig /renew, it still doesn't put in the proper address. i even tried giving the comp a static ip but with no luck.

That's even stranger; a static IP address should always work, as long as it's in the correct subnet and physical network connectivity is OK... Are you absolutely sure you gave it a valid address and subnet mask? Have you tried replacing the network cable of the failing client?

where can i check the type of DHCP server the comp has?

DHCP is a service running on one of the systems in the network... If you didn't install and configure it yourself, the router is probably acting as DHCP server. Usually it can be managed through a web interface.

Link to comment
Share on other sites

Could you please state the INTERNAL IP address of your router?

Once we have that, we could try to assign the client a static IP on the same range and try it then..

EDIT: Actually,,,,,,, how exactly are you configuring the router? I'm guessing from another machine via web admin???

Edited by SilverBulletUK
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...