Jump to content

USB Mass Storage Driver for DOS


Recommended Posts

I've searched MSFN and Googled for drivers but I can't seem to find the driver that recognizes my USB Mass Storage Device.

I've tried Panasonics usbaspi.sys, Iomega's aspiehci.sys, and something called duse???.sys.

I've tried a lot of switches.

The thing is, I've gotten it to work before, but I forgot what driver I used. When my HDD crashed, I lost that driver.

Anyone know of any good DOS driver for USB Mass Storage Device other than usbaspi.sys, aspiehci.sys.

(Oh, I just recalled, it may have been like an older version of these or an updated version than what I have or something like that???)

Link to comment
Share on other sites

It seems like you have tried almost everything known, so it is possible that something is wrong in your particular setup.

Here are a few examples of CONFIG.SYS settings for the various utilities, including some that are not commonly used:



The one that I use is this one:


get also the Magic Boot Disk here:


there are both a floppy and an .ISO image of it

The above did never failed me.


Link to comment
Share on other sites

  • 15 years later...

I have tested several alternate drivers on my old Windows 98 SE system, running in plain DOS mode.  I am using a Sandisk 4GB Cruzer for testing.  The only drivers that work reasonably well are Panasonic's (or Novac's) USBASPI.SYS and Novac DI1000DD.SYS.  Both are required.  I've tested five different versions of USBASPI.SYS.  Four of them work about equally well.  One (version 2.01; 37,090 bytes by Medialogic) does not work.  The Novac version (version 1.07; 43,528 bytes, dated 2001) works OK but consumes 10K more memory than the Panasonic versions.  The Panasonic versions I have tested are 2.06, 2.20, and 2.27.  The one USB port on my old W98SE system is a UHCI port.

I also tested Cypress Semiconductor DUSE.EXE version 4.4.  I could not get it to work, and it occupied 150,000 bytes of conventional memory, so I gave up on it.  Maybe it would work with the right command line switches, but it takes up too much memory.

I also tested Bret Johnson's USBDOS.  It worked, once I figured out the right command line switches, but it was painfully slow.  A filename search (dir filename /s) took more than 30 minutes.  With USBASPI/DI1000DD, the same search took 33 seconds.

I also tried Georg Potthast's DOSUSB.  I never got it to work.  It is time-limited, so I gave up on it also.



Link to comment
Share on other sites

I have now done some testing of USBASPI.EXE v. 2.28, USBASPI.SYS v. 2.27x, and USBEXFAT.COM.  I found no reason to prefer 2.28 over other versions.  However, 2.27x loads much faster than any version I have tested previously, so I definitely prefer it over other versions.  USBEXFAT.COM works about equally as well as DI1000DD.SYS, except for file name searches.  A search that takes 35 seconds with DI1000DD takes over 5 minutes with USBEXFAT.COM.  For large file copying, USBEXFAT may be a little faster than DI1000DD.  USBEXFAT gives some flaky behavior.  If it is loaded before Smartdrv, searches of the USB drive are much faster, but searches of the hard disk are slower and noisier.

My Win98se system is 22 years old, so the hardware technology is not up to date.  The USB port supports only UHCI, and is substantially slower than USB 2.0.  USB 2.0 supposedly can transfer 480 Mbps.  On my Win98 USB, I see rates of 1.6 M Bytes/sec.  I'm not sure of the definition of Mbps.  If it means M bits/sec, rather than M Bytes/sec, then 480 Mbps is really 60 M bytes/sec.

I have also tested ASPIDISK.SYS, version 4.01 by Adaptec.  It works about equally well as DI1000DD.SYS.  It is dated in 1997, so it may not be as up-to-date on FAT32 as DI1000DD.SYS.

Incidentally, I have tried loading the drivers after bootup by using DEVLOAD.COM.  It appears to work, but something goes wrong shortly after that causes a reboot.  I can use internal DOS commands without causing a reboot, but running external programs causes out-of-memory errors.  So, it is much better to load the drivers from config.sys.  This does not apply to USBEXFAT.COM, possibly because it is never loaded by config.sys

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...