Jump to content

Can't install Boot Loader


Recommended Posts

I'm Dual booting using GRUB into my Windows 98/XP Professional & RH FC-1 installation, while installing GRUB i enabled LBA option.Since, then i couldn't boot into my Windows installations.I tried to enter rescue mode & give Fixmbr & fixboot but they didn't worked.

I even tried to reinstall Windows XP Professional so that it restores Windows Boot Loader.But after text mode setup instead of Windows Boot Loader appearing i got invalid disk message. What's wrong here,why couldn't windows bootloader install Grub is working & i'm able to use Linux. Please help me out :unsure:

Link to comment
Share on other sites

1st it's not Linux or grub forums as you can see and I do not think that these guys can help you.

2nd the problem is that you must remove grub from MBR using command fdisk /mbr from windows98 boot disk for example

3. In case if you instal grub on Linux partition not on mbr run Linux CD or resque boot floppy for restore grub. For more info look your distro webpage. RH schould have that option something like linux rescue from CD1.

Hope it helps.

Edited by moo
Link to comment
Share on other sites

And by the way if you can boot into Linux you can also manualy edit grub.conf file to add Windows partition something like this:

titile Windows

root (hd0,1)

kernel /boot/vmlinuz-2.4.20 ro root=/dev/hda2

initrd /boot/initrd-2.4.20.gz

Link to comment
Share on other sites

Thanks a lot for the support & suggestion

Well it's not the Linux Boot Loader Grub that's posing a problem,i'm having problem installing Windows Boot Loader back.What Grub does is to handle control to Windows Boot Loader.From the past experience i know that when u run setup of Windows XP it restores Windows Bootloader on the MBR & detects other Windows OS e.g. Win-98,the problem is, that isn't working either

I just can't understand why even after running Windows XP Setup after the text mode setup the Bootloader of Windows can't start,it of course has overwritten the MBR because Grub is gone but somehow NTLDR can't just kickoff & get the windows boot.

Instead it gives an

invalid disk

I hope this helps to understand the problem,

Thanks in advance

Link to comment
Share on other sites

@ prodigy_cts

Did you tried to run as I said fdisk /mbr or not from DOS using Win98 boot disk or something similar?

If not just run it and we're see after what you got!


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...