Jump to content

nero7 install


cyril_for_ever
 Share

Recommended Posts

Hello,

I tried to install nero7.

my Runonceex is:

REG ADD %KEY%\085 /VE /D "nero7" /f

REG ADD %KEY%\085 /V 1 /D "REGEDIT /S %PP%nero_7\nero7.reg " /f

REG ADD %KEY%\085 /V 2 /D "%PP%nero_7\SetupX.exe /quiet" /f

but nero7 doesn't install.

However before I tried it in a .bat :

ECHO Enregistrement de Nero 7

REGEDIT /S .\nero7\nero7.reg

ECHO.

ECHO Installation nis 2005

start /wait .\Nero_7\setupX.exe /quiet

and that's successfull.

what doesn't it run with my runonceex?? %PP% is the way to the application's folder.(it's a good way, i can install other programms with the %PP%)

Link to comment
Share on other sites


REG ADD %KEY%\085 /V 2 /D "\"%PP%nero_7\SetupX.exe\" /quiet" /f

Because paths with spaces doesn't understand arguments, you must force to separate app & arguments

edit: hmm, I have read your other topic ... if the solution above doesn't work, it's perhaps you should run the setup in a current session already opened ...

Salute !

Edited by sonic
Link to comment
Share on other sites

Sorry but even ths correction , I have the same results.

My runonce.cmd is:

@echo off

FOR %%i IN (D E F G H I J K L M N O P Q R S T U V W X Y Z) DO IF EXIST %%i:\CD.txt SET CDROM=%%i:

SET KEY=HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnceEx

SET PP=%cdrom%\applications\

REG ADD %KEY% /V TITLE /D "Installation de mes programmes :P" /f

REG ADD %KEY%\078 /VE /D "windvd 7" /f

REG ADD %KEY%\078 /V 1 /D "REGEDIT /S %PP%WinDVD7\windvd7.reg " /f

REG ADD %KEY%\078 /V 2 /D "\"%PP%\WinDVD7\Setup.exe\" /s" /f

REG ADD %KEY%\085 /VE /D "nero7" /f

REG ADD %KEY%\085 /V 1 /D "REGEDIT /S %PP%nero_7\nero7.reg " /f

REG ADD %KEY%\085 /V 2 /D "\"%PP%nero_7\SetupX.exe\" /quiet" /f

REG ADD %KEY%\095 /VE /D "norton internet security 2005 & system works" /f

REG ADD %KEY%\095 /V 1 /D "REGEDIT /S %PP%nortonI2005.reg " /f

REG ADD %KEY%\095 /V 2 /D "\"%PP%Norton_Internet_Security_2005\SYMSETUP.EXE\" /O REBOOT=ReallySuppress /QB" /f

REG ADD %KEY%\095 /V 3 /D "REGEDIT /S %PP%nortonW2005.reg" /f

REG ADD %KEY%\095 /V 4 /D "\"%PP%Norton_System_Works_Premier_2005\cd_1\nswsetup.exe\" /qn Reboot=Suppress" /f

I've launched the .iso with vmware and this doesn't install neither nero , neither windvd.

Internet security is installed but when the computer launches norton system works , i've the result: (see the file attachment: copy f screen)

I've already put another programms with this runonceex but for theses programs i've some difficult..... :S

Nouveau_Document_Microsoft_Word.doc

Link to comment
Share on other sites

  • 1 month later...

Well i might be entirely wrong here, so take my apologies if i am....

with my nero7 experiments i came to the conclusion that none of the usual "quiet" msi-switches work but one, which is: "/passive"

i think this, because my (german) nero.msi did not react to any of the quiet switches in the usual manner, it only did a silent job on the "passive" switch.

of course i might just have applied the switches in the wrong manner, but maybe it is just so that nero msi only takes passive...

hope i was helpfull here, even though its an old thread...

sneaky

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...