Jump to content

Help with setting Location


_chris_
 Share

Recommended Posts

Hi,

I'm having trouble setting the "Location" setting in "Regional and Language Options".

I've done some digging around on the net and I can't seem to find any information on it.

I wish to set all of the regional options to English (Australia) and Australia for the Location; I have entered the following settings in my ristndrd.sif file:

[RegionalSettings]

InputLocale=0c09:00000409

LanguageGroup=1

SystemLocale=0c09

UserLocale=0c09

This results in the correct settings except for Location, which remains on United States.

Does anyone know if it is possible to automate the Location setting?

thanks for your help in advance.

Chris

Link to comment
Share on other sites


Sorry, chris, but what do you mean by

Does anyone know if it is possible to automate the Location setting?

if it is in your .sif file it will be applied when the PC is built.

If you mean to add to pre-built machines, could you not apply a domain or group policy to the pc's with the lacation details?

hope it helps

Link to comment
Share on other sites

oioldman, nah, we are trying to deploy desktops using RIS with this setting already set.

Fencer128, I changed the value as you suggested but still the same result, everything else except for Location is correctly set.

Link to comment
Share on other sites

You could always just replace the "Locale" values in:

HKU\.DEFAULT\Control Panel\International

and

HKCU\Control Panel\International

with the correct values. The change should take place after a reboot, so if you've got a runonce script you could run it there and have the machine reboot to make it work.

Link to comment
Share on other sites

Hi,

This is the code I use to set English (UK) for everyone. We also have many IMEs as well as east asian and r-l packs installed, which may explain the extra entries under "LanguageGroup".

[RegionalSettings]
Language=00000809
LanguageGroup=1,7,8,9,10,11
SystemLocale=00000809
UserLocale=00000809
InputLocale=0809:00000809

I note that there are differences between the keys in your code and mine. Maybe you need the "Language" key? I know that you shouldn't need any kind of registry hack to accomplish this - it should be possible from the sif file.

Cheers,

Andy

Edited by Fencer128
Link to comment
Share on other sites

@ _chris_; if trying to set as station is built, it will take from .sif

I use settings similar to Fencer128 and works a charm

i vaguely recall the ref.chm has a list of all keys used for the regions, so may be worth checking the .sif file is containing the correct number of chars for each request

Link to comment
Share on other sites

  • 2 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...