Jump to content

Xplode4 Setup Question


Recommended Posts

I'll have another go at it... :}

I'll give you as much info as I can and hopefully one of you can see where I'm going wrong.

I've read through the pdf and several posts over and over, there must be something I'm missing.

I launch xplode4 from cmdlines.txt, the syntax is as follows..

”%SYSTEMDRIVE%\Install\XPlode\XPlode.exe /xml:#XPLODE#\XPlode.xml /log:#XPLODE#\XPlode.log”

My folder structure is as follows..


->$OEM$->$1 ---------------->Drivers

My $1 directory also contains -->Install ---->{All Apps folders plus XPlode Folder}





My xml resides in the XPlode folder.

My winnt.sif file is as follows..













And finally, this is my xml...

 Block containing all settings for the current display plugin.
 This will be dependent on which plugin used, so check
   documentation for that specific plug.
 <display plugin='#XPLODE#\XPlodeGFXInstall.x4d'>
 <hidewindow>Windows Update</hidewindow>
 <show total='18' after='10' subcount='true' />
 <font face='Tahoma' antialias='true' small='9' large='14' />
 <!-- note the position attribute - it is listed in 'x,y' positions. -->
 <!-- 0..8 still may be used. -->
 <window width='461' position='2' fixmain='0' />
   <header back='#003399' fore='#FFFFFFAA' image='' />
   <footer back='#003399' fore='#FFFFFFAA' image='' />
   <progress border='#FFFFFFAA' back='#00000000' fore='#FFFFFFAA' />
   <main back='#4A6FD6' fore='#FFFFFFAA' current='#FF8000' description='#FFFFFF' image='' overlay='#FFFFFF22'/>
 <title>Installation and Configuration</title>
 <!-- adduser plugin strings -->
 <adduser>Adding User #1#</adduser>
 <addusertogroup>Adding user #1# to group #2#</addusertogroup>
 <addgroup>Adding group #1#</addgroup>
 <!-- file/dir ops plugin strings -->
 <copy>Copying #1# (#2#/#3# - #4#)</copy>
 <move>Moving #1# (#2#/#3# - #4#)</move>
 <delete>Deleting #1# (#3#)</delete>
 <item display='Installing Applications'>
 <execute display='Installing .NET Framework v1.1 ...'>
 <execute display='Installing Alcohol 120 ...'>
 <arguments>/qn /norestart</arguments>
 <execute display='Installing Winrar 3.30 ...'>
 <execute display='Installing Nero Burning ROM v6.6.0.6 ...'>
 <arguments>/SN=xxxx-xxxx-xxxx-xxxx-xxxx-xxxx /WRITE_SN /SILENT /NO_UI /NOCANCEL /NOREBOOT</arguments>

During install, I do see a cmd box pop up very quickly but nothing is installed and also there is no log file generated. I was going to return to my previous method of UA Install but this has got me losing sleep :} so I'm determined to solve it.

Thanks again to everyone, I do appreciate your help.

Link to comment
Share on other sites

Haaaaaaaa, now we gotcha!

I too had this same deal and fixed it like this;

1. create a simple command file like this to actually launch XPlode


cmdow @ /HID
@echo off

start /wait %systemdrive%\Install\XPlode\XPlode.exe


and place it in $OEM$ with cmdlines.txt

2. call it from cmdlines.txt like this



I don't know how the whizzkidz do it - but this worked for me.

Link to comment
Share on other sites

Excellent! Thanks heaps SparTacuS, it worked.

I'm sure this isn't what most people do to get it running, but if it works for me then that's enough.

I searched the forums for cmdlines.txt with the 'unattended CD/DVD guide' option checked but I only get 4 results. With the 'forums' optioned checked I get about 580 results, I've read quite a few and tried many different variations in my cmdlines.txt file but nothing worked.

I also tried the way the pdf document suggested which was included in the xplode download without success.

Unfortunately I was away from the pc when I ran it so I must run again to see if I'm happy with the display.

I would like to have mine looking like the one in this thread... http://www.msfn.org/board/lofiversion/index.php/t25615.html

Do I need to edit my winntbbu.dll file? I've already downloaded ResourceTuner but I haven't installed it yet.

One more thing, previously I had OfficeXP installed silently via runonceex.cmd, the syntax for this was

REG ADD %KEY%\003 /VE /D "Microsoft Office XP" /f
REG ADD %KEY%\003 /V 1 /D "%systemdrive%\install\OfficeXP\setup.exe TRANSFORMS=Unattended.MST /qn /norestart" /f

So for my xml would this be

<execute display="Installing Office XP ...">
  <arguments>TRANSFORMS=Unattended.MST /qn /norestart</arguments>

I just wasn't sure about the TRANSFORMS bit.

Thanks again. :)

Link to comment
Share on other sites

No probs,

Your Office install looks OK, but I have used a different method for some time (search for Astalavista's tutorial - you can get a 35Mb office with a switchless install!) - so I've never tried a "normal" Office install via XPlode.

Yea, I'm sure that the *.cmd file is not the best way - it ain't the most elegant - but it was the only way I could get it to work.

Link to comment
Share on other sites

I have my xplode installing from cmdlines.txt now. I can't believe it was so simple.


For this code to work, you must have your xplode files in $oem$/xplode/

Oh, this also assuming the xml file that you use is called XPlode.xml

Hope this helps anyone else who had my problem.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...