Jump to content

WindowBlinds 4.5


C0deBreaker
 Share

Recommended Posts

I am a registered owner of WindowBlinds 4.5 and I would like to have this automatically installed during my UA process. I have only found one reference on this site and it has to do with an AutoIt install. It uses the WISE installer and so I have looked at the site for those switches.

Using either the /s or /silent switch actually does run it in the background....forever. It goes up to 300+ percent and then starts again and does not finish until i kill the process manually (which does NOT install the application).

Has anyone had success getting WindowBlinds to install in their UA build? Thanks a LOT for your help guys!

Link to comment
Share on other sites


Here is the old AutoIt script....its one of many that I need to update and repost in the AutoIt thread.

If it doesn't work for you...well your kind of on your own till I get the newer version posted.

Well good luck.

file removed

Link to comment
Share on other sites

My hat is off to you. The script needed minor tweaking both because the name had changed and I "simplified" the executable name to WindowBlinds.exe - suffice it to say that this last little pest has been put to rest. It runs quick too. Is it possible to minimize or hide the install when you use AutoIt? Thank you again for your help. :thumbup

Link to comment
Share on other sites

Well I personally haven't messed with hiding windows or keeping things minimized tho there are commands available to do so....how well the script works while in that state is unknown to me.

Personally I prefer to see the installation taking place even more so when it comes to AutoIt handled installations....some times a script will fail if written incorrectly...with the installation shown...if need be you can abort it...where hidden...it could be difficult to exit the application and recover.

Heh how ever you do have the source code so by all means dig in and see what you can make happen with it.

Link to comment
Share on other sites

  • 4 weeks later...

My first post to MSFN... Been glued to this site for days.

Anyways, I've been playing with the AutoIt script for WindowBlinds v4.5 and I'm stuck... Don't see how you manage to send keys or control clicks on the last dialog box (WindowsBlinds Advanced Configuration). When I manually install WindowBlinds, I can not use the keyboard to do anything on the last dialog box - no tab, no arrows, no funtion keys... Therefore, how can you script this?

Here is the main part of my script...

; Enter Serial Number

WinWaitActive ( "Enter WindowBlinds Serial Number" )

ControlSetText ( "Enter WindowBlinds Serial Number", "", "Edit1", $SN_1 )

ControlClick ( "Enter WindowBlinds Serial Number", "OK", "Button2" )

; License

WinWait ( "License Agreement", "", 1 )

If WinExists ( "License Agreement" ) Then

WinActivate ( "License Agreement" )

ControlClick ( "License Agreement", "I Agree", "Button4" )

ControlClick ( "License Agreement", "&Next >", "Button1" )

EndIf

; Unload Application

WinWaitActive ( "Unloading WindowBlinds" )

ControlClick ( "Unloading WindowBlinds", "&Yes, I Have Unloaded WindowBlinds >", "Button1" )

; Welcome

WinWaitActive ( "Welcome" )

ControlClick ( "Welcome", "&Next >", "Button1" )

; Destination Location

WinWaitActive ( "Choose Destination Location" )

ControlClick ( "Choose Destination Location", "&Next >", "Button1" )

; Finish + Check And Extract Self Extracting Skin Archive

WinWaitActive ( "Installation Complete" )

ControlClick ( "Installation Complete", "&Finish >", "Button3" )

; Configuration

WinWaitActive ( "WindowBlinds Advanced Configuration" )

**** This is last dialog box to choose and set skin... Got any ideas on what control click to send? Some code goes here.

WinClose ( "WindowBlinds Advanced Configuration" )

;Install

WinWaitActive ( "Install" )

ControlClick ( "Install", "Cancel", "Button2" )

Link to comment
Share on other sites

rcc1968 -

Well the installer for WindowBlinds blows goats. ;)

One has to do a LOT of hunting around with the AutoIt Window Spy....since the name of the buttons are all over the place and not where they should be....and some I don't even think show at all....hence why I don't have it completely configurable....just way to much work for little to nothing in return...heh might be different if there was money involved...but when its for free...p*** on it. ;)

Any ways I've attached a more recent build....that should solve some issues for others. Namely if they wish to install one of the default skins rather than a 3rd party one....3rd party skins are still supported as before....just look through the user var's and set things correctly.

Basically if you choose to apply one of the default skins....it will prevent you from applying a 3rd party....this doesn't mean that you can not add 3rd party skins via the skins sfx file....you can still do that.

Any ways take a peak and see if things are better for you or not...if your looking to tweak every thing possible....your compltely on your own...since I have no disire to do that much hunting.

Link to comment
Share on other sites

I eventually found my problem in the script and got in working - in a rather crude way. So for that I'm rather proud of myself... However, your script is much much nicer. I like how you can delete out your choice of skins from the original install.

Thank you! :thumbup

Link to comment
Share on other sites

  • 4 months later...
rcc1968 -

Well the installer for WindowBlinds blows goats. ;)

One has to do a LOT of hunting around with the AutoIt Window Spy....since the name of the buttons are all over the place and not where they should be....and some I don't even think show at all....hence why I don't have it completely configurable....just way to much work for little to nothing in return...heh might be different if there was money involved...but when its for free...p*** on it. ;)

Any ways I've attached a more recent build....that should solve some issues for others. Namely if they wish to install one of the default skins rather than a 3rd party one....3rd party skins are still supported as before....just look through the user var's and set things correctly.

Basically if you choose to apply one of the default skins....it will prevent you from applying a 3rd party....this doesn't mean that you can not add 3rd party skins via the skins sfx file....you can still do that.

Any ways take a peak and see if things are better for you or not...if your looking to tweak every thing possible....your compltely on your own...since I have no disire to do that much hunting.

*sigh* No matter what I do I can't get this to work. I am a programmer so I picked up on the syntax right away, but for the life of me I can't get the script to click on the OK button after the serial is put in. It puts the serial in just fine, but the script just won't click "Button2" for some reason. Anyone have any ideas why this might be?

Link to comment
Share on other sites

Well I've been away from the scene for a bit...but its my understanding that most recommend using the control id rather than the name of the control....if that still doesn't fly...maybe just send the mouse over to click the control.

Also in newer builds of the installer different controler names may have been used.

Keep in mind that windowblinds should be the last autoit item to be installed since its skinning of controls breaks autoits ablity to read and manipulate them.

Link to comment
Share on other sites

Well I've been away from the scene for a bit...but its my understanding that most recommend using the control id rather than the name of the control....if that still doesn't fly...maybe just send the mouse over to click the control.

Also in newer builds of the installer different controler names may have been used.

Keep in mind that windowblinds should be the last autoit item to be installed since its skinning of controls breaks autoits ablity to read and manipulate them.

I should've mentioned that I did use the au3info program and confirmed that was indeed still "Button2". I also tried changing it to "8" which is the actual id. No luck on any of that. I don't understand what the problem is.

Link to comment
Share on other sites

hmm not sure if there is suppose to be quotes around the 8 when using id's...well use ?mouseclick? to move the mouse where it needs to be to click the button.

All right, well, we're moving soon but once I get settled I'll try to figure it out and I'll release it. Thanks for the tips.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...