Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Sign in to follow this  
jeffk2121

Pls help with Serv pk 1.6.2

Recommended Posts

Downloaded and installed Service Pack 1 v 1.6.2, rebooted as requested. When windows started got error "smi.exe performed an illegal function...closed. Explorer has performed an illegal function....closed and rebooted. Upon restart...blue screen...MS registry checker ran.....backed up files and restored files...info box popped up "Windows found an error in your system files and restored a recent backup of the files to fix the problem. Enter to restart" Restarted 4 times and got same message.

Inserted my startup disk and booted....got to DOS....but didn't know what to do.

Inserted McAfee rescue disk and booted.....

"Starting Magic Bullet"

BIOS read error X00

Booted in safe mode and got warning

"system file warning-following files have been replaced with an older version by a program you recently ran. Some windows functionality may not run correctly.. Please run these files by running Windows setup located on your original Windows disk to verify your current install C:\windows\system\winaspl.dll" was indicated in the message box.

OK or Ignore...chose ignore

tried to get to internet to post last night....but apparently can't access internet in safe mode

Have orginal win 98 SE CD

Do you have any suggestions how to fix this?

Can it be uninstalled? Only likely suspect in Add/Remove is "system files update"

I appreciate any help you can give me

Share this post


Link to post
Share on other sites

Hi Jeff: I hope you haven't tried any other fixes yet... better that a day or two pass, than if you have to re-install: you could be there many more days updating, re-installing, losing some data forever........

OK: this is what happened--

you likely had this adaptec aspi layer(for cd's): http://www.adaptec.com/worldwide/support/d...1a2.exe&sess=no

what you need & had is the last two here: install May's & update it w. November's: http://www.adaptec.com/worldwide/support/d...odkey=ASPI-4.70

Gape gave us an earlier version because it's much more stable-- the latest one has caused problems for lots of folks-- in your case it looks like the opposite :)

What i don't know is why your system is so complaining-- are you running a backround PC Health, Real Time System File Protector, etc. whether from MS, Norton, your AV, etc.?

What you can/should do: go into control panel / add remove programs / uninstall Unofficial Windows SE Service Pack...... this should restore your system-- but before that!!!! disable preotected recycle bin, any norton utilities, firewall, AV, Spy Protector(SpywareGuard in particular can get in the way), Innoculators like Spybot, Spywareblaster....... even if you have to unplug your modem, do this first please.

Then, you can re-install the Pack, but leave Adaptec Aspi Layer unchecked......

If you still have problems, then install from first link provided.

Good luck.......

let us know if you have additional questions.......

Share this post


Link to post
Share on other sites

and i would install the 2.0 beta 3 instead of the 1.6.2

Share this post


Link to post
Share on other sites

I've done nothing else to fix this....learned long ago to rely on knowledge than luck!

I am not running PC Health or Real time...that I know of. I'm running McAfee Viruscan 9.0 only. I do have Spybot....AdAware.... Spywareblaster...and Sygate firewall. I've never seen this registry checker run before...is it part of the service pack?

A few questions (bear in mind I can only operate in Safe mode)

1 Do I install Mays 2002 aspi then November 2002 in safe mode, then reboot to see if problem is fixed?

2 if the new files do not correct the problem...in safe mode.....in Add/Remove programs...there is no Unofficial Windows SE Service pack listed.....only thing close is "system files update"...is this it....or what would it be named?

3 should i install the 2.0 beta....instead of / over the tp of 1.62?

Share this post


Link to post
Share on other sites

I installed aspi_471.exe and ran.....then ran aspi_471a2. rebooted and received all the same errors. Looked in the c:\adaptec\aspi folder created by the install and found a number of files...aspi46.vx_....aspi2k.sy_...aspi32sy_.....as though another .exe needed to be run?????

Installed both rebootted and had same results

What now?

Share this post


Link to post
Share on other sites

Sorry, Jeffk2121-- what i meant about fixing was something i do a lot: get all worked up & anxious to quickly get rid of the problem, then the next day i wish i hadn't tried a couple of the fixes....

1. Please make sure all the security apps & settings are disabled-- AntiVirus, firewall, etc. can have a system file protection, or real-time scan & protect... in extreme cases i've seen where the firewall / AV has to be uninstalled & reinstalled afterwards-- disabling some doesn't auto-stop all their process: in startup you can confirm all their subprocesses are disabled w/ an app like this one: PC Forrest StartMan 1.03.9.6 Pls give the link a few seconds' time to appear.

2. This is likely not your cause, but if it is, it's a quick fix: do a Find for ext2.vxd located in windows\system and rename it-- this is a file left behind when partitioning sometimes-- it will conflict with cd system files & lock you out of windows.

3. So-- in add/remove there HAS to be an unistall entry for sesp1.6-- i have v2 which may be named differently.... this would be the safest bet, to undo the changes... If that doesn't work:

4. Also in add/remove you would uninstall Adaptec UDF Reader-- though this may not totally work, reasons below...

5. I assumed you tried already to rollback the registry to the last saved state: (boot to dos, type scanreg /restore)-- just asking: let's not do this yet.

6. btw for future reference, this progam comes in very handy: InstallRite home: http://www.epsilonsquared.com/

7. so does running scanreg just prior-- or this program that also backsup registry & system files: Cop2.2 info: http://www.bootdisk.com/cop.htm

8. Ok-- on to Adaptec: the earlier of the two files you downloaded, should've given you a utility called aspichk.exe, which can also be downloaded standalone here: AspiChk

It will show you the installed version, and whether you have both versions still in there(your likely problem)-- their install procedure can be buggy, not remove previous version...... When this is the case, folks use this to fix it: FixAspi

When that doesn't work, they run a file called KillAspi.bat included in these two apps:

ForceAspi1.17 which installs aspi layer 4.6x and ForceAspi1.18 which installs aspi layer 4.7x this last one courtesy of: Neo Hacker

The problem(s) w/ Adaptec are that some versions are incompatible with other components, they may not install right(sometimes refuse to install when not detecting/finding cd hardware and/or a previous aspi layer in place), may not totally remove a previous version-- additionally windows likes to protect system files, not allow version downgrades, etc. Hence, other folks developed these useful apps. Btw, below is the official adaptec app that auto updates your layer, but the above third-party apps are more certain to work & eliminate problems. Aspi32

9. One thing that occurs to me-- you may not even need the Adaptec layer: your system may perhaps be using the Nero layer-- so you may not even need to re-install Adaptec-- just excise it. One way to tell for sure: do a Find for Adaptec-- if those folders show a creation date of just recently, then you know your cdplay has not been utilizing/needing it.

10. You will need all these utilities & both driver versions both now, and just in case, in the future if your cd play has issues from all this fixing.

11. Speaking of future: if after this fixing you have issues with your cd play, it may help to reinstall your cd software AND remove from device manager your cd components & reboot: upon startup, as windows re-installs them, it will help them detect the newly-installed aspi layer.

12. As you re-install the aspi layer with the appropriate apps, one trick i use to help make sure windows detects everything right, is i also right-click install all .inf files & register all .dll files... this app from the makers of X-Setup Pro can help to easily just right-click them & select Register: XQ Com Register EX 2.1

13. Here's the manual way & most of what all those apps do:

Firstly, you're in safe mode now, but in the future you could use this app that allows you to get around windows not letting one handle files in use / system files: CopyLock

Uninstall cd software, Find, backup & delete all Adaptec folders and any of the following files:

cdr4vsd.vxd, cdr4dll.dll, cdrtc.dll, cdral.dll, cdralvsd.vxd, scsi1hlp.vxd, iomega.vxd, cd_read.vxd

windows\system\iosubsys\apix.vxd

windows\system\aspienum.vxd

windows\system\winaspi.dll

windows\system\wnaspi32.dll

in the Registry, Find, backup & delete(again we have a useful app for this-- it auto tracks all your edits, and can undo any w/ just one click-- no extra steps needed on your part: Vilma Registry Explorer

any adaptec entries-- though if any also contain the brand name of your cd equipment within their contents, you may also need to re-flash their firmware & re-install them in windows system/device manager. Then install cleanly your aspi layer version of choice and/or cd software if necessary-- this latter would likely install correctly the needed aspi layer.

Hope this if of use to you.... sorry it took so long.....

Share this post


Link to post
Share on other sites

OK...I'm going to take this kinda slow...not really a puter expert

1 checked task mgr and only thing running is explorer...nothing else (safe mode) tried link to pc forrest and errored out (the puter I have hooked up to the net is ooolllddd win 95.

2 No ext2.vxd

3 Absolutely nothing remotely resembling sesp1.6...what about J2SE runtime environment 5.0 update 1? should i try reinstalling the service pack?? although I don't have use of my cd...or jumpdrive in safe mode apparently

4 add/remove shows no adaptec udf reader

5 did not roll back registry

6

7

8

Aspichk showed components apix.vxd v 4.71.2

wnaspi32.dll v 4.71.2

I checked \windows\system and winaspi.dll is 9/10/99, but app aspi_v471 this dll is dated 4/19/01 and app aspi_471a2 is dated 7/17/02...appears \system wasn't updated

9 I do use Nero to burn cd's and I believe it controls my separate internal cd/dvd player

did a find on adaptec and found the following

adaptec (folder) c\ 1/28/05

adaptec.inf c:\windows\inf 5/9/01

adaptec (folder) c\program files 3/14/04

adaptec shared c\program files\common files 7/11/04

thought I would give you this info before I proceeded...may point out the problem...is there a way to recognize my jumpdrive or are any files I need to download small enough to fit on a disc?

thanks for your help

Share this post


Link to post
Share on other sites

edit: folks, please feel free to add a faster solution / critique any procedure...

Hi.

Re checking startup, you can also do it by: clicking start / run / typing "msconfig" then clicking enter or OK / select: startup / hit the maximize button on upper right....

I would just run KillAspi if you can-- then make sure these files are gone: windows\system\iosubsys\apix.vxd

windows\system\aspienum.vxd

windows\system\winaspi.dll

windows\system\wnaspi32.dll

And do not reinstall any adaptec, at least for now. If so, did that help?

Next, i would run scanreg /restore (space after first word, no space before second word) and select the closest registry before you installed service pack.

edit: before proceeding with install, you could run this app and export results to another location, so you don't lose any web,ie, oe, etc. passwords/loginsautofills: PSPV tiny 28KB! Another good app: RoboForm last free version or Robo Latest shareware free trial & home page

If that doesn't work, then i would just re-install windows over the top-- being careful to select the same exact windows directory if/when it prompts you. If you have 98lite installed or have burned the install cd to hard drive, clicking 98lite or setup can also work.

If windows doesn't allow this, all you'd need is one boot floppy, then you could install any way you wanted to-- i'd use one of these, they're more intuitive / contain more tools than the MS one: http://www.startdisk.com/Web1/ubd/98UBD.exe or this one: TechWorm for Win98SE when prompted for if you want cd-rom support, answer yes.

Afterwards i'd install any of the unofficial service packs: http://exuberant.ms11.net/98sesp.html 1.5 might be the safest for you, though i'd have no problem using the others as long as you deselect the Aspi option during install. Afterwards you can hit windows update or this app: BigFix1.7.6.0 to see if you're missing any patches.

This would be the fastest way to get you up and running(assuming KillAspi & restore reg didn't fix the problem)-- and safe. You will not lose data-- though to be extra safe, not practically necessary(& to help check for something that needs reinstalling) you could pre-copy to other location: Program Files, windows\application data(contains email, quick launch bar, some ie plugins, etc.) windows\desktop(also contains my briefcase) windows \start menu(has shortcuts, program folders, windows startup apps), windows\sendto, windows\downloaded program files & downloaded installations, windows\ favorites, history, cookies-- IF you want to keep your auto web logins(i've forgotten so many passwords) & past web research links, start my documents & any other folder you wish. Btw if it comes to this in the future-- you need to replace w/ one of the backed-up fave/history/cookie folders-- it may require an extra step or two, just begin another thread.

Re jump drive / floppy diskette: does this mean--

1. you cannot reinstall win98 using the install cd?

2. you wish to boot from jump drive and/or connect it to win95 machine--

i have no experience with those drives-- i'm sure i could find how, but it would take longer than just over-installing windows with worst-case a bootable floppy...

So at the risk of lengthening this process needlessly-- here would be some options:

I would look for drivers in the freedos site-- they have done some great things with this dos os-- including support for modern things / peripherels like/dealing with UDMA, USB, flash drives, advanced network, etc. http://www.freedos.org/

But by using your jumpdrive, there's really nothing you can do than without the boot floppy.....

It coud also work w/ a usb to parallel cable, or using a cable to connect your win95 machine to the win98 and booting it 'remotely'--this line is needed in your c:\msdos.sys file: Network=1

as well other entries help during troubleshooting-- first right-click it / select properties / uncheck read-only / apply-- then right-click / select 'open with notepad'(or similar app) & insert all this: over-writing all contents:

[Paths]

WinDir=C:\WINDOWS

WinBootDir=C:\WINDOWS

HostWinBootDrv=C

[Options]

BootDelay=2

BootMulti=1

BootGUI=1

DoubleBuffer=1

AutoScan=1

SystemReg=1

WinVer=4.10.2222

BootMenu=1

Logo=0

BootMenuDefault=1

BootMenuDelay=10

BootKeys=1

BootWarn=0

Network=1

DisableLog=0

;

;The following lines are required for compatibility with other programs.

;Do not remove them (MSDOS.SYS needs to be >1024 bytes).

;xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxa

;xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxb

;xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxc

;xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxd

;xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxe

;xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxf

;xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxg

;xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxh

;xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxi

;xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxj

;xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxk

;xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxl

;xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxm

;xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxn

;xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxo

;xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxp

;xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxq

;xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxr

;xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxs

save & repeat right-click / properties process to enable read-only again. Note: after you're done troubleshooting, you can go in there again and change BootDelay to 0, and BootMenuDelay to a lower number--say, 4.....

Note: if this file does not appear, do this: click Start / settings / folder options / view / scroll down to Hidden Files / put a check in Show All Types.

HTH.....

Share this post


Link to post
Share on other sites

Dos drivers for booting from the jumpdrive: http://www.theinquirer.net/?article=10215

more resources: http://newdos.yginfo.net/usbdos.htm

oh, and run sfc after you're done: start/run/ type sfc & click enter or ok. So the next time you need to troubleshoot, you'll probably see the likely cause, such as a deleted/changed/corrupted system file. If you don't do it now, windows won't know all what's changed later on.

good luck.

Share this post


Link to post
Share on other sites

Thanks for your help....ran KillAspi...tried reboot and had same problem with registry checker. Just reinstalled Windows and now I'm back and running. Still no windows update.....but oh well

Share this post


Link to post
Share on other sites

install 2.0 RC1

that fixes the wu bug found in 1.6.2 and it has other useful fixes.

Share this post


Link to post
Share on other sites

I Definitely second Soldier1st-- that you won't have any more problems. btw I also had no windows update after some re-install eons ago-- i believe that was solved after applying a bunch of updates(which I had stored in computer--you double-checked add/remove windows components for any needed stuff?)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...