Jump to content

netsh problem

Recommended Posts

I read about netsh in different places and decided to use it. I tried it on my normal Windows XP SP1 and had no problems, then I proceeded to test it on my customized (using nlite - meaning lots of services, components are removed) Windows XP SP2 and I keep getting: "the following command was not found". The command I'm trying to execute is nothing out of the ordinary "netsh interface ip set address name="Local Area Connection" static 1" . So this got me wondering is the netsh.exe the only file needed for this great utility to work? Does netsh.exe rely on any service which needs to be up and running so it does work? BTW netsh.exe is in my system32 folder.

I know I removed lots of things from that Windows XP SP2 but I thought that netsh.exe is a standalone utility and would work as such. Was I wrong?

Any information whatsoever (even hunches count) will be greatly appreciated.

Link to comment
Share on other sites

Thank you both for your replies, was so happy because I was certain this is it. But it doesn't seem that way. All the libraries soulin pointed out are in my system32 folder but I'm still getting that same error.

If I go to cmd I can execute netsh and even look up help on all the commands available so it might be that netsh actually has all the required files. Why it fails to execute that simple command is beyond me...hopefully someone else knows.

I doubt that netsh depends on any service but that might be the case...I would test that myself but quite a few services are removed.

Link to comment
Share on other sites

When I said it works from cmd I meant if I just do "netsh" I get switched over to netsh> I can type help and so forth there but I cannon execute that command (I never execute it anywhere else...there was a small misunderstanding here).

These services are started (most of the others are either disabled or removed):

Automatic Updates

COM+ Event System

Cryptographic Services

DCOM Server Process Launcher

DHCP Client

Event Log

Kerio Personal Firewall 4

Network Connections

Plug and Play

Print Spooler

Remote Procedure Call (RPC)

Security Accounts Manager


Shell Hardware Detection

Windows Audio

Windows Management Instrumentation


Really don't know if any service is needed but since I have all those .dlls in my system32 I don't know what else could be causing this.

Once (hope that day comes) I can get netsh to execute that command I'll disable DHCP Client service as well.

Link to comment
Share on other sites

C:\Documents and Settings\CypherBit>netsh

netsh>interface ip set address name="Local Area Connection" static 1

The following command was not found: interface ip set address name="Local Area Connection" static 1.

I wasted at least an hour googling going through MS KB and haven't found anything.

Link to comment
Share on other sites

Thank you soulin we sure are making progress now ;)

When I list all available netsh commands the "interface" one is missing.

After looking at the link you posted it seems quite clear that I'm missing the "Network Command Shell Interface Context and IP Monitor Routing" component which is needed for the "interface" command.

Now the problem is I have no idea what I need to do to install this component (include it in my next uA install) or what I mustn't remove using nLite so that this particular component will remain.

Link to comment
Share on other sites

Could someone please move this to the nLite forum because I think the chances of fixing this problem of mine will increase there. It's obvious that I removed a component using nLite that netsh needs to execute the "interface" command.

I just need to find out what that is.

Thank you in advance.

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...