Jump to content

T-bird and firefox not installing


 Share

Recommended Posts

so I'm using the silent thunderbird EXE found here

and the silent firefox MSI totoymola made here

in my runonce, both come up with an error saying that an install is already running, please wait and run after it has finished.

I checked and rechecked my numbering scheme to make sure I wasn't calling 2 MSI's simultaneously and I'm not. If I run the files off the CD while in Windows, I don't have any problems... I have other MSI's that run back to back in the CD, and I only get the error when firefox and thunderbird are attempting to be installed.

Any thoughts?

Link to comment
Share on other sites


As promised, here's my runonce code:

I removed some stuff like the CDROM detection, plus the cleanup stuff at the end.

SET I=%cdrom%\Install


SET KEY=HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnceEx

REG ADD %KEY% /V TITLE /D "Setting up Programs" /f

REG ADD %KEY%\000 /VE /D "Acrobat Reader 7" /f
REG ADD %KEY%\000 /V 1 /D "%I%\ar7\acroread7.exe" /f

REG ADD %KEY%\005 /VE /D "Ad-Aware Pro SE 1.05" /f
REG ADD %KEY%\005 /V 1 /D "%I%\lavasoft\aawsepro105.exe /S" /f
REG ADD %KEY%\005 /V 2 /D "%I%\lavasoft\pskill hh.exe" /f
REG ADD %KEY%\005 /V 3 /D "%I%\lavasoft\pskill Ad-Aware.exe" /f

REG ADD %KEY%\010 /VE /D "Daemon Tools 3.47" /f
REG ADD %KEY%\010 /V 1 /D "%I%\daemon\daemon.msi /qb-! /norestart" /f
REG ADD %KEY%\010 /V 2 /D "%I%\daemon\copy.cmd" /f
REG ADD %KEY%\010 /V 3 /D "%I%\daemon\awxinstall.cmd" /f

REG ADD %KEY%\015 /VE /D "Diskkeeper Profressional Edition v9.0.509" /f
REG ADD %KEY%\015 /V 1 /D "%I%\diskkeeper\diskkeeper.exe" /f

REG ADD %KEY%\020 /VE /D "Firefox 1.0" /f
REG ADD %KEY%\020 /V 1 /D "%I%\firefox\firefox.msi /qb" /f

REG ADD %KEY%\025 /VE /D "Gaim 1.1.1" /f
REG ADD %KEY%\025 /V 1 /D "%I%\gaim\gaim.exe /L=1033 /S" /f

REG ADD %KEY%\027 /VE /D "Java Virtual Machine 1.4.2_06" /f
REG ADD %KEY%\027 /V 1 /D "%I%\java\java14206.exe /s /v/qn addlocal=jrecore iexplorer=1 mozilla=1 reboot=supress webstarticon=0" /f

REG ADD %KEY%\030 /VE /D ".NET Framework v1.1 SP1" /f
REG ADD %KEY%\030 /V 1 /D "%I%\dotnet\netfxsp1.exe" /f

REG ADD %KEY%\040 /VE /D "Nero Burning ROM v6.6.0.1" /f
REG ADD %KEY%\040 /V 1 /D "%I%\nero\nero6601s.exe" /f

REG ADD %KEY%\045 /VE /D "Office 2003 Pro - Excel, PowerPoint and Word" /f
REG ADD %KEY%\045 /V 1 /D "%I%\office2003\office2k3.exe" /f

REG ADD %KEY%\050 /VE /D "PowerDVD 6" /f
REG ADD %KEY%\050 /V 1 /D "%I%\powerdvd6\powerdvd6.exe" /f

REG ADD %KEY%\055 /VE /D "Powertoys for Windows XP v2.10" /f
REG ADD %KEY%\055 /V 1 /D "%I%\powertoys\powertoys.msi /qb" /f

REG ADD %KEY%\060 /VE /D "QuickTime Viewer" /f
REG ADD %KEY%\060 /V 1 /D "%I%\quicktime\quicktimealt139.exe /VERYSILENT /SP-" /f

REG ADD %KEY%\062 /VE /D "Shockwave Installer 10.1" /f
REG ADD %KEY%\062 /V 1 /D "%I%\shockwave\shockwave.msi /qb" /f

REG ADD %KEY%\065 /VE /D "Symantec Antivirus Corporate 9.0" /f
REG ADD %KEY%\065 /V 1 /D "%I%\sav\sav.exe" /f

REG ADD %KEY%\067 /VE /D "Thunderbird 1.0" /f
REG ADD %KEY%\067 /V 1 /D "%I%\thunderbird\thunderbird.exe" /f

REG ADD %KEY%\070 /VE /D "UltraISO 7.2.5.923" /f
REG ADD %KEY%\070 /V 1 /D "%I%\ultraiso\ultraisosetup.exe /VERYSILENT /SP-" /f
REG ADD %KEY%\070 /V 2 /D "%I%\ultraiso\uiso.cmd" /f

REG ADD %KEY%\075 /VE /D "Winamp 5.08 and skins" /f
REG ADD %KEY%\075 /V 1 /D "%I%\winamp\winamp.msi ini=%I%\winamp\setup.ini /qb" /f
REG ADD %KEY%\075 /V 2 /D "%I%\winamp\copy.cmd" /f

REG ADD %KEY%\080 /VE /D "WinRAR 3.4.1" /f
REG ADD %KEY%\080 /V 1 /D "%I%\winrar\winrar341.exe /s" /f
REG ADD %KEY%\080 /V 2 /D "%I%\winrar\copy.cmd" /f

REG ADD %KEY%\085 /VE /D "Zone Alarm Pro 5.1.033" /f
REG ADD %KEY%\085 /V 1 /D "%I%\zonealarm\zalarm.exe /s /i /noreboot /lickey XXXXXXXXXXXXXXXXX" /f
REG ADD %KEY%\085 /V 2 /D "%I%\lavasoft\pskill za.exe" /f

EXIT

I have to be blind because I can't tell where I'm screwing this up.

Thanks for the help

Link to comment
Share on other sites

if I doubleclick on the MSI for firefox within windows, it just runs like any attended install would. It asks what type of install etc.. and it installs correctly.

The thunderbird.exe is just an SFX, and the comment is correct. When I extract that and run, it also runs as an attended installation.

I just can't figure out why it would say an install is currently running, when nothing is.

I guess my next step would be to either use the different methods that prathapml suggested, or maybe move around the firefox and thunderbird files, maybe put them as the last thing to install.

Any other thoughts or ideas?

Link to comment
Share on other sites

If you are having problems installing Thunderbird or Firefox, you can always use the zip version. The only problem with that is you cannot uninstall it completely because it has no uninstaller. So the you will have to remove the registry entries that it makes one by one.

Link to comment
Share on other sites

i don't really care too much about total removal... i don't plan on uninstalling firefox anytime soon anyway. The only way I would remove it is if I had to do a clean install of windows, so it wouldn't matter at that point.

I'll mess around with it a little more and see what I come up with. I hate having to burn CDs to test this... stinks not having something like vmware or virtual PC... oh well, blanks don't cost that much anyway

Link to comment
Share on other sites

I posted something about this on the forums yesterday, but i'm doing things differently than you, I was using cmdlines.txt and installing everything that way, i created my own WinRAR sfx FF and TB with the correct comments to silently install, but what i was having problems with was TB was supposed to execute right after FF well because of the way i packaged the 2 files TB never installed unless i put a sleep.exe 10 between the two. (This is because the SFX signals the Start /Wait command that it's done it's bit without waiting for the child process, TB or FF in this case, to complete)

I had a PM Discussion with another member who said this shouldn't be happening once i explained that i was using cmdlines.txt they pointed this out as the probable cause, so i switched to RunOnceEx today as a test, apart from my winzip install not happening (missing file not sure why yet) TB didn't install again, so i'm back to square one unless there is something i need to put into the comment section of my SFX files for each, my TB SFX is:

;The comment below contains SFX script commands

Setup=setup.exe -ira
TempMode
Silent=1

As for wasting CD's get yourself rewritables dude, they may be slower to burn but dang they save you in the long run. A pack of 5 is only like $10 or about 15 UK pounds.

I'll post back if i come up with anything to help you.

Link to comment
Share on other sites

» Installing Installshield Applications from RunOnceEx CD

Installshield applications will fail to install when executed from RunOnceEx on CD, unless a log file location is specified. An example of this is shown below, adapt this example for your InstallShield applications (shown in bold):

REG ADD %KEY%\045 /VE /D "Kerio Personal Firewall 2.1.5" /f

REG ADD %KEY%\045 /V 1 /D "%CDROM%\apps\KPF\Setup.exe -s -f2\"%systemdrive%\kerio.log\"" /f

Is your diskkeeper installing properly? have you looked? the last version of Diskkeeper i saw used InstallSheild, maybe this is part of the issue? just an idea.

Also just as a test i'd try putting your TB at the beggining of the RunonceEx just to see if it executes.

P388l3s

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...