Jump to content

another sql problem


Recommended Posts

it seems that when i reload the only thin i really ever have problems with is something to do with sql...here it is this time

Fatal error: Call to undefined function: mysql_connect() in /var/www/html/ibf/sm_install.php on line 249

thats when settin up invisionboard...any ideas?

Link to comment
Share on other sites


well no matter what i have it as it doesnt do anything but ive that error..i tried using localhost and its ip address. i loaded up phpmyadmin and it gave me an error about not being able to connect to the sqlserver too so i think it might be someting to do with the mysql option when compiling php..so im gonna try recompiling that and see what happens

Link to comment
Share on other sites

ok..i tried recompiling php and made sure i used --with-mysql and in the the output you see on the screen it says "mysql support...yes" or something like that... but i still get

Fatal error: Call to undefined function: mysql_connect() in /var/www/html/ibf/sm_install.php on line 249
from invisionboard and
cannot load MySQL extension,

please check PHP Configuration.

Documentation

from phpmyadmin
Link to comment
Share on other sites

To connect to a MySQL server, PHP needs a set of MySQL functions called

"MySQL extension". This extension may be part of the PHP server

(compiled-in), otherwise it needs to be loaded dynamically. Its name is

probably mysql.so or mysql.dll. phpMyAdmin tried to load the extension but

failed.

Usually, the problem is solved by installing a software package called

"PHP-MySQL" or something similar.

If you want download newer PHP - extension-less.

Link to comment
Share on other sites

well im using the latest version (php-4.2.3.tar.gz) compiled myself and i used the rpm of the latest mysql. and the preinstalled apache 2.0... I may just format and reload and compile everything myself if i cant fix this.

Link to comment
Share on other sites

Here is what I use to configure php(this is in no way standard, but it works :) )

First make sure to delete the old directory:

rm -rf /wwroot/php

or wherever it is

./configure --prefix=/wwwroot/php --with-config-file-path=/wwwroot/php  --with-apxs=/wwwroot/bin/apxs --with-xml --enable-bcmath --enable-calender --enable-ftp --with-gd  --enable-magic-quotes --with-mysql --with-pear --enable-track-vars --with-ttf --with-zlib --with-mod_charset --with-iconv --enable-trans-sid --enable-sockets

Of course you may need to change some paths, install libs, etc.

Btw, if you use Debian I would sugest you install it this way:

apt-get install apache

apt-get install php4

apt-get install mysql

apt-get install php4-mysql

You can see other modules here

Link to comment
Share on other sites

I wanna setup a forum, using InvisionBoard, but I dunno how to setup the SQL-PHP crap...

akafree: feel like doin' a free job for me?

:)

Link to comment
Share on other sites

ide recommend serving yourself that way downtime is only your own fault..its rather simple once you figure it out.. just download redhat 8 install everything from the cd (apache, php, mysql) and install this: ftp://ftp.rpmfind.net/linux/redhat/8.0/en...-8.0.5.i386.rpm by downloading and double clicking on it.. then set your passwords for the mysql server (mysqladmin -u root password passwordyouwant) you can go into the server configuration menu and choose services and have apache and mysql run on startup too.. and if you want to do remote login ide use pure-ftpd. i can help you with that too

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...