Jump to content

Windows XP on Surface Pro 1

GD 2W10

Recommended Posts

I have managed to install Windows XP on a UEFI Class 3 Surface Pro 1. I believe I am the first to do this. The Surface Pro 1 only officially supports Windows 8-10, but I have gotten 7 and Vista to work, and now XP.

I’ve gotten WiFi to work with an adapter. I haven’t gotten graphics or audio working yet.

Here is the showcase video:  

Special thanks to George King, as I used his XP2ESD tool to install Windows XP on this laptop. Also thanks to UsefulAGKHelper for his method of installing XP on UEFI Class 3.

1. Boot the USB. This ISO uses a Windows 10 PE, but has a Windows XP x64 install.wim.
2. Open command prompt by pressing "Shift+F10"
3. On the command prompt, type in the following commands:
sel dis 0
conv gpt
cre par efi size=100
form quick fs=fat32
assign letter w
cre par pri
form quick
assign letter c
D:\ (where your USB is)
cd sources
dism /apply-image /imagefile:install.wim /index:1 /applydir:C:\
 - If DISM doesn't work, go to D:\support\tools\gimagex and deploy the image with gimagex.exe in the x64 folder
4. Open up Notepad, and click "Open" or "Save As". Enable all files to be viewed. Go to "D:\EFI partition". Copy the EFI folder onto W:\ (the boot partition)
5. Go back to Command Prompt. Type in "D:\support\tools\Bootice\BOOTICEx64.exe"
6. On Bootice, go to the BCD tab. Click on "Other BCD file". Click on the "...". Go to the BCD file (you can find this in W:\EFI\Microsoft\Boot). Click on "Professional Mode".
7. Click on "Windows XP" under "Application Objects"
8. Under "ApplicationDevice" and "OSDevice", set the boot disk to wherever your XP installation is (most likely disk 0) and the boot part to C:\ (your Windows XP partition).
**Every time XP boots, it will always show the boot manager. You can turn it off on Bootice by going to the BCD tab and opening the XP BCD and clicking "Easy Mode", then uncheck "Display boot menu".
9. Reboot.  You should be logged in to the Administrator account. If the screen is not displaying anything, you need to reset the resolution. Hit Windows Key + R, and type in desk.cpl. Hit "tab" four times, hit the right arrow four times, hit "tab" once, hit the right arrow once. Then press enter. The screen should now display.

USB works on Windows XP. There are no WiFi drivers. You will need to purchase a seperate USB wireless adapter. Also, I have not been able to get sound working on the machine. Getting a USB sound card might fix that.

Edited by GD 2W10
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...