Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Sign in to follow this  
cov3rt

intel pro 100 ve network connection on windows 95 osr2

Recommended Posts

i was wondering which driver version / package can you guys confirm working for the intel pro 100 ve network connection ( mobile adapter ) on windows 95. is it for the hardware id "PCI\VEN_8086&DEV_2449". i do not have the entire subsys portion at the moment but i can possibly get it later. i tried the 6.1.3.0 driver, but i was not able to get it working at the time. complaining on dhcp related errors in winipcfg when i tried to release / renew ip addresses. in device manager, it was listed as "working". i think i tried the 5.x family of drivers, i think it was the one ending in .34, but i also couldn't get it to work with that either, but i suspect it's possible my windows installation was somehow missing components / corrupt, as i was working with a very poor condition hard drive that's basically gonna fail soon, it has about 109,000 hours of operation on it. 

there is this 1.0.0.1 driver that is ndis4 based, which i suspect could work, although it carries different files in the package, and i don't see the wol558.vxd for example, that is included in the other packages. now according to one site, windows 95 osr2 can use ndis4, and i checked my files and some of the ethernet adapters do indeed have ndis4 system files in their inf packages, such as the realtek 8139. according to another source, i think it mentioned that windows 95 osr2 or newer requires ndis4 or that windows 95 version A only required them, but i don't know for sure. i posted the links for the sources below. i would rather use a older driver for ethernet so i can just use that for all systems i test on, but at the same time, i would want to have a better idea of why i couldn't get these drivers to work. all i need is a inf package, no setup or utilities needed. would be nice if someone can upload the inf package for me to test. 

Share this post


Link to post
Share on other sites

Here is the latest version of Intel's Ethernet Drivers for Windows 95.

I have confirmed that this works with the desktop PRO/100 VE and Windows 95 OSR2.

Share this post


Link to post
Share on other sites
On 7/27/2020 at 5:01 AM, Ximonite said:

Here is the latest version of Intel's Ethernet Drivers for Windows 95.

I have confirmed that this works with the desktop PRO/100 VE and Windows 95 OSR2.

thanks for the info, i was able to confirm the issue, it wasn't the drivers to begin with as 6.1.3.0 did work properly, i simply didn't have the ethernet cable plugged all the way on the modem end, so it was just a loose cable problem, which can happen if your network cable doesn't have the lock clip design and / or is missing from damage. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...