Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Sign in to follow this  
mufunyo

1909 dark mode and custom glass colours

Recommended Posts

I recently decided to reinstall Windows and enable dark mode, and AeroGlass doesn't really seem to cater to this use case at all.

Right after installing, title bars are translucent white, which looks awful combined with dark mode, as well as mismatched title bar text colours on ribbons (white on white) and everything else (black on white). So I research a bit and apparently you have to turn on "Show the accent colour on title bars and window borders". This turns title bars red (my accent colour). So I dig up AeroGlassGUI as I've been able to tweak colours with that in the past. Eureka! I now have translucent black title bars with white text, that properly match dark mode. There is a weird bug/glitch though where for inactive title bars, specifying true black (RGB 0,0,0) causes the value to be ignored and light grey to be used instead (which looks awful). Using RGB 1,1,1 is an okay workaround, as nobody will be able to tell the difference.

This is what it looks like with a dark title bar and red accent border (just the way I like it, although I'd still prefer it if the accent border wasn't affected by the glass opacity setting):
bw1vlNa.png

But uh-oh, here comes trouble. Whenever I restart or the DWM crashes/restarts, the custom settings are lost and I'm stuck with red title bars:
42zrSmp.png

I verify this with regedit; apparently AccentColor in HKCU\Software\Microsoft\Windows\DWM is being reset to red, while going into AeroGlassGUI and setting it to black sets the value to 0 (black). I've had problems like this before, with overzealous apps and system components randomly re-setting an already set value, and usually I fix it by locking the access permissions of the offending registry key with a Deny permission for "Set value", which allows everyone to still read the value, but nobody can alter it.

Imagine my surprise when I reboot, and am instead greeted by this:
08ATjcN.png

Apparently not being able to reset the value causes DWM or AeroGlass or whatever thing is constantly resetting the value to throw its toys out of the pram and completely revert to defaults. Even flicking the "Show the accent colour on title bars and window borders" setting on and off has no effect. So I remove my modified permission on the registry key and kill the DWM, and now title bars are red again.

Can this be fixed in a future version, or is there some kind of known workaround for this? The first thing that springs to mind is a constantly running script that resets the correct parameters in the registry every x minutes in a loop, but I'd like to avoid such stupid solutions if possible.

Thanks in advance.

Edited by mufunyo

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...