Jump to content

windows 10 anniversary update unattend xml file


Tufail Shah
 Share

Recommended Posts

Dear all, 

I need unattend xml file for windows 10 anniversary update which must have capablity to join pc on domain, with computer name etc. i have one for windows 7 which is perfectly working with WDS 2012.

But this is not working for windows 10 build 3607 Anniversary Update. Can anybody fix this for windows 10 or provide new one for windows 10 anniversary update. It is not joining on domain and not naming pc properly for windows 10.

This file is for windows 7.

<?xml version="1.0" encoding="utf-8"?>
<unattend xmlns="urn:schemas-microsoft-com:unattend">
    <settings pass="specialize">
        <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="NonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
            <ProductKey>xxxxx-xxxxx-xxxxx-xxxxx-xxxxx</ProductKey>
            <ComputerName>*</ComputerName>
            <TimeZone>%TIMEZONE%</TimeZone>
            <RegisteredOrganization>atco</RegisteredOrganization>
            <RegisteredOwner>ATCOVDI</RegisteredOwner>
        </component>
        <component name="Microsoft-Windows-UnattendedJoin" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="NonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
            <Identification>
                <Credentials>
                    <Domain>mydomain.com</Domain>
                    <Password>password</Password>
                    <Username>username</Username>
                </Credentials>
                <JoinDomain>domain.com</JoinDomain>
                <MachineObjectOU>OU=Windows 7,OU=ThinClients,OU=ouname Desktops,OU=ouname,DC=domain,DC=com</MachineObjectOU>
            </Identification>
        </component>
    </settings>
    <settings pass="oobeSystem">
        <component name="Microsoft-Windows-International-Core" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
            <InputLocale>en-us</InputLocale>
            <SystemLocale>en-us</SystemLocale>
            <UILanguage>en-us</UILanguage>
            <UILanguageFallback>en-us</UILanguageFallback>
            <UserLocale>en-us</UserLocale>
        </component>
        <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="NonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
        <AutoLogon>
    <Password>
    <Value></Value>
    <PlainText>true</PlainText>
    </Password>
    <Enabled>true</Enabled>
    <Username>localthinuser</Username>
    </AutoLogon>
    <UserAccounts>
    <LocalAccounts>
    <LocalAccount wcm:action="add">
    <Password>
    <Value></Value>
    <PlainText>true</PlainText>
    </Password>
    <Description>Local thin client user </Description>
    <DisplayName>localthinuser</DisplayName>
    <Group>Guests</Group>
    <Name>localthinuser</Name>
    </LocalAccount>
    </LocalAccounts>
    </UserAccounts>

            <TimeZone>%TIMEZONE%</TimeZone>
            <RegisteredOrganization>Al Tamimi &amp; Co</RegisteredOrganization>
            <RegisteredOwner>ATCO</RegisteredOwner>
            <OOBE>
                <HideEULAPage>true</HideEULAPage>
                <NetworkLocation>Work</NetworkLocation>
                <HideWirelessSetupInOOBE>true</HideWirelessSetupInOOBE>
                <ProtectYourPC>1</ProtectYourPC>
            </OOBE>
        </component>
    </settings>
    <cpi:offlineImage cpi:source="wim://servername/reminst/install.wim#Win7 Ent Basic (x64)" xmlns:cpi="urn:schemas-microsoft-com:cpi" />
</unattend>

Edited by Tufail Shah
mistake in spelling
Link to comment
Share on other sites


  • 3 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...