Jump to content

2TB WD My Passport Ultra failure


Recommended Posts


A 2TB USB WD hard drive was working as charm. After 3 months of not using it, it began to show some slow performance. Now, it takes like 20 minutes to show all of the partitions. However, the first partition (the only one with important data) became inaccessible.

I tried to scan the desk using chkdisk in windows but it says that it cannot do a scan on it. Then tried MiniTool Partition, it can see the files in the corrupted partition but has no option to restore them, I tried to fix the partition or surface scan it, after waiting a while the software hangs.

I bought a new 2TB USB WD (yes I have a twin now) hoping I can clone the corrupted one, retrieve the important data and then return it back to WD (Still in warranty).


Still no luck with HDD Raw copy tool, it says that it cannot lock the 'source' drive. I tried a bunch of software for recovery of partition/data but none worked...they either hang or do not work.


Any suggestions? 

Note: The corrupted drive has WD locker; i.e. when you plug the USB it works fine (not slow) showing only one partition to unlock the desk. Once you unlock it takes 20 min. or so for the partitions to be recognized (except the important corrupted one).


Thanks in advance,


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...