Jump to content

Is there any way to run the latest Firefox on Win2k SP4?


 Share

Recommended Posts

This question has probably been asked a million times before, but I would like to know if there is some way of running the latest version of Firefox, or at least some alternate build of it, on Windows 2000 SP4. I use XP SP3 as my main OS on two of my machines, but I prefer using Win2k SP4 on lower-end boxes because it's more lightweight and efficient than XP. I understand as well that I could just switch to Opera, but I use a lot of addons on Firefox that aren't available for Opera, such as DownThemAll.

Thanks in advance. :D

Link to comment
Share on other sites


  • 2 weeks later...

I was able to get SeaMonkey v2.9 running as supported under Windows 2000 (so no KernelEx or anything like that). I can't remember offhand what Gecko revision that is, so I don't know what the comparable version of Firefox is.

Edited by JodyThornton
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...