Jump to content

Creative Audigy SE


khkramer
 Share

Recommended Posts

Did anyone manage to get this sound card working in 98SE?

For me it showed up as multimedia pci device in the device manager and I managed to install a driver with P17.inf from the official XP driver.

However it doesn't show up in sound settings etc.. and I'm still not getting any sound.

Link to comment
Share on other sites


Provided the driver you are using actually works you may want to try this:

Uninstall the drivers completely using Driver Cleaner Pro.

In addition, delete the HKEY_LOCAL_MACHINE\Enum\SW key in the registry.

Reboot and reinstall your drivers (using the add new hardware cpl if you aren't automatically prompted for them)

If it doesn't work repeat the procedure with another version (older) of those drivers until you find one that works.

I used an Audigy 2 ZS with 2K/XP drivers in the past so I am pretty confident there are working drivers for Audigy too.

Link to comment
Share on other sites

As far as I remember, Creative Audigy SE will not install without installing the Creative Audigy drivers. That is of course, if you are using the old 96 kHz/24-bit version. Even with the newer versions of Windows (2000, XP, Vista, & 7), the Creative Audigy SE soundcard will not install without the Creative Audigy drivers.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...