Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


bigred

"Always ask before opening this file" during install

Recommended Posts

After using and continuously updating my XP unattended installer for years, I'm now working on one for Windows 7. I'm just getting back into this, so it's possible I'm missing something fairly simple...

When my apps install via RunOnce, (I have about 7-8 apps in total) Java and both Flash installers pop up with the "Open file - security warning" page, with the checkmark at the bottom where it says "Always ask before opening this file". This is obviously not the way I want my unattended installation to go. Does anyone have any ideas as to why this is happening, and what I can do to stop it?

Just so you know, it doesn't seem to be a switch issue, as those three installers all work as soon as I bypass the security warning page (unless there's a switch I need to activate that will help me bypass this?).

Any info/advice would be appreciated, thanks. :)

Share this post


Link to post
Share on other sites

Ok, figured this one out myself and thought I'd post back in case anyone else is looking for an answer.

I ended up right-clicking on the installers, and going to the General tab, where I could choose to enable or disable the "Block" feature. Disabling it solved my problem. Hope this helps someone else.

This is weird..kind of like talking to myself! :unsure:

Share this post


Link to post
Share on other sites

This is the correct, and at the same time, a well-known and documented solution. Downloading from a server in a different timezone prompts for that screen during install, but you can remove it permanently by clicking Unblock on the Properties->General tab page.

Cheers

Share this post


Link to post
Share on other sites

or apply this to affect the global.



; Disable the "Open file - Security Warning"
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Associations]
"LowRiskFileTypes"=".bat;.cmd;.exe;.msi;.reg;.vbs;"

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...