Jump to content

Winpe boot problem when using HP ilo


bjorne78
 Share

Recommended Posts

Hi,

I run into problems 9 of 10 times when booting a HP server via ILO (iso boot). The iso is a Windows PE image created using sccm 2007 SP2. I get the message: Unable to read task sequence configuration disk.

When looking into smsts.log it seems like it won´t search the virtual CD for the files needed and just crasches. When pressing F8 and going into the command prompt there is no problems to access the virtual CD drive. It also works if I manually start %SYSTEMDRIVE%\sms\bin\x64\TsBootShell.exe

It seems like it is some kind of timing issue. Maybe it loads the virtual CD driver to late/slow.

Any ideas?

Link to comment
Share on other sites


Hi,

I have the same problem with some ProLiant DL380 G6. It concerns only a few machines, so I guess there must be some difference.

I have tried various os/java combinations to connect to the iLO board. Also it makes no difference if I use the Boot ISO ore the Standalone ISO from SCCM. Updating the firmware on the target server did not help as well.

Did you find a solution?

Frank

Link to comment
Share on other sites

  • 2 weeks later...

Hi.

I worked around the problem by creating a WIM from the ISO and booting this from a WDS server. Works like a charm... A short guide on how to create the WIM can be found here:

http://www.deployvista.com/Default.aspx?tabid=70&EntryID=54

Frank

We have multiple guides stickied in this forum too, including this one:

Link to comment
Share on other sites

  • 2 weeks later...

I've been running into the same issue, and here's what worked for me.

After some research and testing, it looks like the root cause is due a delay for the iLo mounted ISO to show up as a drive letter in WinPE. In my smsts.log, it showed the SCCM build app check for BOOT.WIM only on D drive (physical), but the mounted ISO was actually on E drive. By the time the ISO was properly mounted on E, the SCCM build app had already stopped.

I modified the \windows\system32\winpeshl.ini file in BOOT.WIM to add a 10 second delay before it attempts to launch the SCCM build app, so the file now looks like this:

[LaunchApps]

%SYSTEMDRIVE%\sleep.exe, "10"

%SYSTEMDRIVE%\sms\bin\i386\TsBootShell.exe

sleep.exe is not normally on the build disc, it was something I added myself. Instead of sleep, you also simulate a delay with ping -n, or create a batch file that loops through checks for the existence of BOOT.WIM before TsBootShell is launched.

Hope this helps!

Edit - winpeshl.ini is picky when used with parameters, see this post here for more info.

Edited by PeaSoup
Link to comment
Share on other sites

Hi,

Yes, I have tried the same thing too and it seems to work. The only problem with this that winpeshl.ini will be overwritten if you do "update dp:s" so you have to keep this in mind everytime you should create a new iso.

Regards

Link to comment
Share on other sites

Oh if this is the only problem (needing a delay) I've encountered situations where I need a delay as well. For examle, the onboard NIC on the Intel DG33BU motherboard does not enumerate by the point of WinPE finished the start of networking. So basically, in my scripts I was mapping a drive letter before the NIC took its IP and it would fail. I use this command after init networking and any other commands:

ping 127.0.0.1 -n 16 -w 1000>null

So now you don't have to worry about any extra programs being present, at least if you turn on networking.

Link to comment
Share on other sites

I understand what you mean, but when you create the bootimage in SCCM you can´t edit winpeshl.ini bacause it will be overwritten by SCCM and you can´t use startnet.cmd because it is not used. I have tried to add a modified winpeshl.ini via extra files to Winpe but SCCM still overwrite the file. I think it will behave the same way if you create the bootimage "outside" SCCM and import it.

Regards B

Link to comment
Share on other sites

For me, I had to...

1. create the SCCM boot ISO first

2. extract the BOOT.WIM

3. mount BOOT.WIM with imageX

4. modify the winpeshl.ini and commit to BOOT.WIM

5. Inject the modifed BOOT.WIM back into the boot ISO using a program like PowerISO

Yes, it is a pain to do especially if you make frequent changes or have multiple boot ISOs for different environments, but once you have a finalized boot ISO, you'll only need to do this once.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...