Jump to content
MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. ×

Unattended domain join without sysprep


 Share

Recommended Posts

Is it possible do do a domain join without a SysPrep/audit stage? All the guides I've found mention sysprepping, and I don't want to do that if I can avoid it (it's a steep-looking learning curve and does far more than I need)

All I want to do is: Stick the install disk in, select the partitioning options, and watch it get to a domain logon screen by the end. Is this possible?

It looks like it's trying and failing to find the domain during the Specialise stage, but when I get to the desktop (and it creates a superfluous user account), I can join the domain as normal.

The setuperr.log file is as follows:

2010-10-08 17:35:47, Error [MUIUNATTEND.EXE] Failed to set UILanguage value to en-GB. Error 2

2010-10-08 17:36:23, Error [shell Unattend] TakeOwnerAndDeleteKey failed (0x80070002)

2010-10-08 17:43:25, Error [DJOIN.EXE] Unattended Join: NetJoinDomain failed error code is [1355]

2010-10-08 17:43:25, Error [DJOIN.EXE] Unattended Join: Unable to join; gdwError = 0x54b

2010-10-08 17:45:58, Error [msoobe.exe] Failed to install product key


I'm not too worried about the language or product key errors, it's the domain ones I'm looking at.

If it makes any difference, I'm testing this on a Dell OptiPlex 780 (which is what the finished disks will be deployed to) and also (for minor changes to the XML) an Oracle VM VirtualBox machine.

I've attached my AutoUnattend.xml - if someone can have a look at it, I'd appreciate it.

Thanks in advance folks :)

Link to comment
Share on other sites


Try this:

        	<identification>
<credentials>
<domain>{Domain (not fully qualified)}</domain>
<password>{redacted}</password>
<username>{Domain User with rights to create computer objects in OU}</username>
</credentials>
<joindomain>{Domain (not fully qualified)}</joindomain>
<machineobjectou>ou=Dekstops,ou=Windows 7 x86,ou=Workstations,ou=Office,dc=domain,dc=local</machineobjectou></identification>

Link to comment
Share on other sites

Ok, I've corrected the spelling mistake in the FQDN (and tried it without the fully qualified bit) and the spelling mistake in the OU name :blushing:

The account I'm using is a domain admin, but is not the domain admin.

            <Identification>
<Credentials>
<Domain>domain</Domain>
<Password>{redacted}</Password>
<Username>AdminUser</Username>
</Credentials>
<JoinDomain>domain</JoinDomain>
<MachineObjectOU>ou=Desktops,ou=Windows 7 x86,ou=Workstations,ou=Office,dc=domain,dc=local</MachineObjectOU>
</Identification>

Still not working, still getting the same errors in the log.

Thanks for the help so far... :)

Link to comment
Share on other sites

Have you verified that the network is live, active, connected during the sysprep process? I have had issues with our Lenovo m90p where the NIC drier is not fully loaded until after the join domain process completes, turns out to be a driver issue. You can press Shift-F10 during setup to open a cmd prompt and check for network connectivity via ipconfig.

Link to comment
Share on other sites

Awesome. It looks like it has an issue with the VirtualBox network card, as I've just tested it on a physical box and it's joined the domain, not asked me to create a local user and it looks like it's applying all my group policies before getting to the first logon.

Thanks for all your help! This will drastically reduce my workload for new builds!

:D

Last (and far less important) step is to get it to automatically select Windows 7 Professional rather than prompting me.

This was working with our Select ISO image, but stopped working when I changed to using the Dell disk as a source.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...