Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


How to get the cause of high CPU usage by DPC / Interrupt

Recommended Posts


Highest kernel latency: 1820 µs

Highest dpc routine exec: 4082 µs

Highest reported pagefault resolution time: 74686 µs

I think there might be something wrong. :lol:

Share this post

Link to post
Share on other sites


As i saw Andre you managed to fix some computers around here. I would also like some assistance from you as I kind of encounter the same problems but cannot fix them.

Laptop : Toshiba F750-118

Problems : Laptop laggs 1-2-3 seconds when I play games(interval of 5-20 minutes), or watch videos on internet.

I am using the ethernet cable most of the times,having the wireless stopped. But the problems are also when i am using the wireless. I cannot do the xperf command as the problems are having periods of 5-20 minutes.

I used latency monitor to determine what is causing this problems and after one hour i had this :

Driver file Description ISR count DPC count Highest execution (ms) Total execution (ms) Image base Image size Company Product Path


ndis.sys NDIS 6.20 driver 0 625392 63.819362 4600.180487 0xFFFFF880'0160A000 991232 Microsoft Corporation Microsoft® Windows® Operating System C:\windows\system32\drivers\ndis.sys

tcpip.sys TCP/IP Driver 0 125583 31.551611 3551.584738 0xFFFFF880'01800000 2097152 Microsoft Corporation Microsoft® Windows® Operating System C:\windows\system32\drivers\tcpip.sys

ACPI.sys ACPI Driver for NT 1699 4188 10.086903 59.108433 0xFFFFF880'00F6C000 356352 Microsoft Corporation Microsoft® Windows® Operating System C:\windows\system32\drivers\acpi.sys

mfefirek.sys McAfee Core Firewall Engine Driver 0 115 1.749973 53.884332 0xFFFFF880'08200000 479232 McAfee, Inc. SYSCORE C:\windows\system32\drivers\mfefirek.sys

As far as i figured out when the computer is lagging it is affected only by ndis.sys. Even if the ACPI is high that doest makes my computer lag


Edited by necw

Share this post

Link to post
Share on other sites

you can use xperf.. Use this command:

xperf -on latency -stackwalk profile -buffersize 1024 -MaxFile 256 -FileMode Circular && timeout -1 && xperf -d DPC_Interrupt.etl

this limits the filesize to 256MB and overrides the old useless data. after you had the issue, go back to CMD and press a key to stop logging.

Share this post

Link to post
Share on other sites

Here it is :capturelc.png

I really dont know which driver should I use as I have tried a couple of them.....

Share this post

Link to post
Share on other sites

update the WiFi and LAN drivers. If this doesn't fix it, give me the compressed ETL file

They are upgraded... How can i give you the compressed ETL ?

LE: nvm i done it i will send you PM

Edited by necw

Share this post

Link to post
Share on other sites

McAfee and the League of Legends Client seam to cause it.

So stop McAfee and test again.

League of legends is a game. It happens to lag when i use my internet , such as playing games or even youtube so I had to try it by playing a game. I uninstalled McAfee , will come back with feedback.

LE : uninstalled McAfee and it seems that I dont have problems anymore. While checking latecymon i still have the ACPI.sys with 10ms but this seems not to interfere with the performance or anything so i guess i can skip this.

Edited by necw

Share this post

Link to post
Share on other sites

This is gonna be a long one so get ready.

Before coming to you guys I've done my homework. My opinion is that this is a general software / hardware problem and not necessarily a sound card /sound system problem.

I have been experiencing for a few months audio dropouts and artifacts (pops & cracks).

Here is the list of things that I have done to try fixing the problem (the order is random):

- Reinstalled windows. Tryed both 86 bit & 64bit version.

- Updated moderboard drivers / sound drivers.

- Got the latest windows 7 updates.

- Installed 86 bit Windows xp Proffesional. And noticed I have no audio problems using that one even with old motherboard & sound drivers.

- I have a integrated sound card. Disabled that one from bios and got an Creative Sound Blaster (don't know exactly with one, it's a new version 2009 I think) SAME exact problems, even with the Creative sound card.

- Adjusted CPU power management to High: processor power management - minimum processor state 100% - maximum processor state 100%. Same problem, didn't work.

- Changed the Processor Scheduling: whent to Advanced System Settings - Performance Option - Advanced - selected "Background services" . Did NOT work.

- Messed around with the buffer size of audio sampling. Did not work.

- Whent to BIOS and disabled CPU Termal Throttle. Did not work.

- Alsow in BIOS, changed PCI Latency Timer from lowest of 32 whent up to 96. Somebody told me that if it's to low bad, to high bad. I tested a few different options. NOTHING worked.

OK! I found the problem using LatencyMon: raspppoe.sys (RAS PPPoE mini-port/ call manager-driver)

This raspppoe.sys is killing my sound. and the thing is I NEED HIM! Cuz my lame a** internet provider is forcing me to use a dial-up VPN connection. I have to connect this system so I can connect to the net.

My system specs are:

Windows 7 Service Pack 1 x86 updated 2012 november

CPU: QuadCore AMD Phenom II X4 840, 3119 MHz

Motherboard: ASRock M3N78D (yes it sucks)

Memory: 4gb DD3 Kingstone

Video Card: Sapphire ati hd 5670

Storage: SATA 2 Seagate Barracuda 7200 rpm , buffer size 32 mb

PSU : Corsair CX600



Share this post

Link to post
Share on other sites

Hello MagicAndre1981, I love your topic.

I've followed everything until the end and basically found out that I'm having issues with usbport.sys

I really don't understand much about computers, I don't even know how to update my own drivers. I mean, I've tried right clicking them and update them, but windows says they are up to date. I don't want to go into some shop and spend money to fix this issue so I'm hoping that I can resolve this on my own, I just wish I knew how :(

I'll try my best to explain the issue.

When my computer is idle Interrupts are at around 3-4%. When I'm using it and downloading just about anything it jumps to 10%. If my download speed is very fast it will go to anywhere from 20% to 40%+.

I've opened up device manager, there I have:


Like I said before, I've tried right clicking and updating the drivers on all of them. I've tried disabling all of them and restarting the computer (which disabled my internet). Even then I had an idle 3-4% Interrupts.

It's not an issue when I'm idle, but if I'm downloading anything it really destroys the performance of my computer.

I hope that this can be saved, would feel great being able to fix something on my own.

I'd like to add that I use a Toshiba Satellite A205-S5804 Laptop, Windows 7.

Also, I've put in a fresh hard drive from my previous laptop, same laptop model, wiped clean, and the issue remains. I'd also like to add that that laptop, before the motherboard failed, did not have any issues with Interrupts. I probably should have returned this laptop when I noticed the problem, but since I ordered online and really needed one I just couldn't spare the time w/o one any longer.

Also, this was a refurbished model. I won't disclose the company that did it unless needed.

Edited by Kalilla

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.