Jump to content

DOS applications [Solved!]


Freda
 Share

Recommended Posts

I've got two PCs running Windows XP, both of which run DOS applications with no problems.

I need a separate PC to do word processing with, and I bought a PC yesterday that runs XP Home Edition. With this new PC I can get a DOS command line and do basic file copying, but when I try to run a DOS application I get an error message saying C:\window\system32\autoexec.nt. The system file is not suitable for running MS-DOS and Microsoft Windows applications. Choose Close to terminate the application.

I'd be grateful for any advice anyone can give on this.

- thanks

Link to comment
Share on other sites


Thanks. Yes, that confirms the problem is incompatibility with 16 and 32 bit settings.

What I need to know is what I can do about it - whether I can make any adjustments or whether Windows needs reinstalling.

I've actually contacted Microsoft about this, but had great difficulty as usual, and from past experience they aren't likely to be helpful, which is why I asked here.

Edited by Freda
Link to comment
Share on other sites

Thanks. Yes, that confirms the problem is incompatibility with 16 and 32 bit settings.
How so? Did you actually read entirely the MSKB Fox Mulder pointed you to, or just a few of the first lines?
What I need to know is what I can do about it - whether I can make any adjustments or whether Windows needs reinstalling.
Yes. It's easy! Just follow the instructions in http://support.microsoft.com/kb/324767, whither Fox Mulder just pointed you. Here, do this first:
If the issue continues to occur, copy the Autoexec.nt and Config.nt files from the Repair folder in Windows to the System folder. To do so, follow these steps:

1. Click Start, click Run, type c:\windows\repair, and then click OK.

2. Right-click Autoexec.nt, and then click Copy.

3. Click Start, click Run, type c:\windows\system32, and then click OK.

4. Right-click anywhere in that folder, and then click Paste.

5. Right-click the Autoexec.nt file that you just copied, and then click Properties.

6. Click to select Read-Only, and then click OK.

Repeat steps 1 through 6 to copy the Config.nt file.

And then test to see whether the issue was resolved. In any case, post back telling us what happened, OK?
Link to comment
Share on other sites

Brilliant. Thank you.

I thought I'd scrolled down to the bottom of the page when I followed the link the first time, but I only saw the first part. I think I must have inadvertently caught the collapse option with the mouse, or something.

So I've managed to repair the file in question and it's resolved the problem. Many thanks to both of you, and my apologies.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...