Jump to content

Some Applications not installing and other errors


Zoom7000
 Share

Recommended Posts

I've been using nLite to create custom images for years now. However, lately, it's all started to go pear shaped! The way I've always done it was to integrate all my addons, updates etc, make a few tweaks, remove nothing remotely important and create a user to automatically logon. I then use the WMP11 Integrator to slipstream WMP11 and finally finish off with the Driverpacks.

However, I'm finding numerous problems. WMP11 is not being installed, I get the following error:

Error Creating Process <C:\Program Files\Windows Media Player\WMPEnc.exe /Regserver>. Reason: The system cannot find the file specified.

I also noticed that the IE8 icon was wrong in the Start Menu, it was a blank icon and when you click on it it merely takes you to Internet Options. However, if you browse to the exeutable, IE8 appears to be fully installed.

Also, a large number of addons don't install either. Interestingly enough, most of the addons that don't install look like they are "True Addons" most of the silent SVCPACK addons seem to work.

RED_XP_SP3_UpdatePack_07.09-02.7z - Not sure if this installs

IE8_140.rar - OnePiece's Addon - Seems to install except the Start Menu and Quick Launch Icons

Jonnyboy's_Firefox_{Mozilla}_3.5.2_addon.7z

Silverlight3.rar

Kels_CPLBonus_v9.5_addon.rar

Kels_Uber_Addon_v14.4.rar

Kels_Runtimes_addon_v5.6.rar

CCleaner222968.rar - ricktendo's CCleaner Addon with Custon Settings

ImgBurn25.rar - ricktendo's ImgBurn Addon with Custon Settings

TeraCopy21.rar - Dark Madness's Addon

OnePiece_Windows_Live_Messenger_9_v14.0.8064.0206_True_AddOn_ENU.7z

xable_CalcPlus-v1.3_addon.cab

7zip465Custom.cab - ricktendo's 7zip Addon with Custon 7z.dll

rdp_6.1.7100.0_addon.rar

Not using nLite - WMP11 Integrator

I've also told nLite to auto login (indefinately) with a custom user account I've created and it doesn't create the user account at all. I've tried both with and without a password.

Any ideas? This is driving me crazy!

Last_Session.ini

Link to comment
Share on other sites


You have certainly one (or more ) addon that mess up the install process.

You have to do some investigation!

a method:

Try building an other iso (fresh source, as always) with only some (lioke the half) of your addons, then test it in a virtual machine. if the install goes fine it's one of the others....if not it's one of those.....

then try to add (or remove ) more addons (only one or two at the same time) until the install break (or work) again

Tip: it's most likely an inf addon that cause the mess.

Link to comment
Share on other sites

Zoom7000, it sounds like you are running nLite more than once against the same source. This is not your problem, but you need to remove the Tweak "Explorer-Launch folder windows in a separate process." This exposes a Windows bug. So, please make sure to always start with a fresh copy of your CD files/folders, do all your work in one nLite session and integrate only one SP. Please report when you have a solution, so others can benefit. Enjoy, John.

Link to comment
Share on other sites

Zoom7000, it sounds like you are running nLite more than once against the same source. This is not your problem, but you need to remove the Tweak "Explorer-Launch folder windows in a separate process." This exposes a Windows bug. So, please make sure to always start with a fresh copy of your CD files/folders, do all your work in one nLite session and integrate only one SP. Please report when you have a solution, so others can benefit. Enjoy, John.

Thanks for the reply johnhc. I can confirm 100% that I have not run nLite more than once on the same source. Each source I use is a pre integrated SP3 source downloaded from Technet. The same type of source I've always used every time I've created images. Always a fresh source.

Link to comment
Share on other sites

I then use the WMP11 Integrator to slipstream WMP11 and finally finish off with the Driverpacks.
How did you do this? This certainly looks like multiple running of something and if it is not nLite, then I would expect the results to be even worse. Booogy's WMP11 Slipstreamer is integrated into nLite for several versions now. You do need to have it installed on your system, but then just add the WMP11 installer and updates in the nLite Hot Fix section. If you really want to run WMP11 separately (to use some of its functions), then you must do it first, before you run nLite. Enjoy, John.
Link to comment
Share on other sites

I then use the WMP11 Integrator to slipstream WMP11 and finally finish off with the Driverpacks.
How did you do this? This certainly looks like multiple running of something and if it is not nLite, then I would expect the results to be even worse. Booogy's WMP11 Slipstreamer is integrated into nLite for several versions now. You do need to have it installed on your system, but then just add the WMP11 installer and updates in the nLite Hot Fix section. If you really want to run WMP11 separately (to use some of its functions), then you must do it first, before you run nLite. Enjoy, John.

OK, thanks. I wasn't aware of the fact that it was integrated. Good to know, I'll try that!

Link to comment
Share on other sites

Right, just to report. I have done a few tests and narrowed down what the potential culprit is.

I've run the WMP11 Slipstreamer before using nLite because I want to get some of the tweaks from the tweaked version. I have slipstreamed addons and created some successful images.

The troublesome program is one of the following:

OnePiece's Silverlight 3

ricktendo's 7zip

Jonnyboys' Firefox

OnePiece's WLM

DarkMadness' TeraCopy

Time to do some time consuming trial and error to see what the culprit is!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...