Jump to content

wbemoc.cab not helping missing napprov.mof issue


Recommended Posts

This week I started w/ a plain XPw/SP3 pre-integrated setup downloaded from MS's Volume Licensing site. Using HFSLIP 1.7.8 (Started w/ 1.7.7 but that was creating sourcess directories w/ something horribly broken.) Following the info in http://hfslip.org/xpsp3.html, placed wbemoc.cab in HFCABS. However, during ttextmode setup, I get the "Napprov.mof" not found error. (Strangely, the error listed on the SP3 page linked above says the error will say napclientprov.mof. (I've verified that NAPPROV.MO_ is in the i386 folder.)

I've verified that the plain pre-hfslip install source works fine, both manually and unattended. I'm installing off a network share booted off a bartpe(UBCD4WIN, actually) CD.

I've tried 3 different compression options (A, F, and E I think) I was having a separate issue w/ IE7 slipstreaming which you'll see posted next to this one, so tried without IE7, as well.

I've searched the forums (I couldn't find any obvious way to search only the HFSLIP forum, it returned several things that looked possibly related when using nlite and such, but nothing helpful...

I'm not an HFSLIP expert, but generally know my way around it and have been using automated installs built w/ 1.6.4 for 7 or 8 months...Any ideas?


Files in your HF folder:









Files in your HFCABS folder:





Files in your HFGUIRUNONCE folder:

Files in your HFSVCPACK folder:

Files in your HFSVCPACK_SW1 folder:

Files in your HFSVCPACK_SW2 folder:

Files in your HFTOOLS folder:


Files in your REPLACE folder:


HFSLIP run time: 31m20s

Edited by TechMonkey
Link to comment
Share on other sites

Strange. I would've guessed that network-based installs can use LAYOUT.INF too.

I'll try something and will make available a new test release immediately.

As far as your problem with advpack.mui and ieframe.mui is concerned... If it is what I think it is, that problem should be fixed with HFSLIP 2.0 (pre-releases). It only affects DOS-based and network-based installs.

Link to comment
Share on other sites

Thanks for the reply! I never got the email notifications (suspect our spam filter, I'll have to bug the guy that admins that) and was getting a bit miffed that nobody responded...I'll try the 2.0 beta, pre-release...thing. :P

Thanks again!

Link to comment
Share on other sites

Tried it with 80630a, that did seem to fix the texmode issue. Still getting some (new!) missing files during the GUI copy/setup phase. Which I will probably document in the followup:


Looks like it might be time to give nlite a go...

Can you tell me what causes setup to not see and/or copy the files that are there in the install source? (i386)

Link to comment
Share on other sites

HFSLIP 2.0 is supposed to bring improvements for network-based installs so it would be better to post problems with it in the HFSLIP 2.0 thread. If you can, please let me know which files are reported missing during the GUI portion of Windows setup.

In your case, it's usually because TXTSETUP.SIF doesn't tell Windows setup to put the files in a temporary folder on the hard disk during txtmode copy; this is necessary because the GUI portion of Windows setup can't access the installation source directly if it's a network-based install.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...