Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Unable to slipstream AHCI drivers for Windows XP Pro x64

Recommended Posts

Hello, i have slipstreamed sata ahci drivers for Windows XP Pro x86 before and it works. Currently, i am having trouble making it work for the x64 version of Windows XP. For some reason what happens is that for the setup, it recognizes the slipstreamed drivers but after the installation it doesn't recognize it anymore.

I have tried different ways and guides including msfn unattended guide:


and topics from this site


But none of them explain for x64 versions of Windows specifically.

For my slipstreaming what i did was first to allocate the TXTSETUP.SIF file which was inside a folder called AMD64 and added the following codes:


iastor.sys = 1,,,,,,_x,4,1


PCIVEN_8086&DEV_2922&CC_0106 = "iaStor"

PCIVEN_8086&DEV_282A&CC_0104 = "iaStor"

PCIVEN_8086&DEV_2829&CC_0106 = "iaStor"

PCIVEN_8086&DEV_2822&CC_0104 = "iaStor"

PCIVEN_8086&DEV_2821&CC_0106 = "iaStor"

PCIVEN_8086&DEV_2682&CC_0104 = "iaStor"

PCIVEN_8086&DEV_2681&CC_0106 = "iaStor"

PCIVEN_8086&DEV_27C3&CC_0104 = "iaStor"

PCIVEN_8086&DEV_27C6&CC_0104 = "iaStor"

PCIVEN_8086&DEV_27C1&CC_0106 = "iaStor"

PCIVEN_8086&DEV_27C5&CC_0106 = "iaStor"

PCIVEN_8086&DEV_2653&CC_0106 = "iaStor"


iastor = iastor.sys,4


iastor = "Intel® ICH9 SATA AHCI Controller (Desktop/Server/Workstation)"

iastor = "Intel® 82801HEM SATA RAID Controller (Mobile ICH8M-E)"

iastor = "Intel® 82801HEM/HBM SATA AHCI Controller (Mobile ICH8M-E/M)"

iastor = "Intel® ICH8R/ICH9R SATA RAID Controller (Desktop/Server/Workstation)"

iastor = "Intel® 82801HR/HH/HO SATA AHCI Controller (Desktop/Server/Workstation)"

iastor = "Intel® 631xESB/632xESB SATA RAID Controller (Server/Workstation ESB2)"

iastor = "Intel® 631xESB/632xESB SATA AHCI Controller (Server/Workstation ESB2)"

iastor = "Intel® 82801GHM SATA RAID Controller (Mobile ICH7MDH)"

iastor = "Intel® 82801GR/GH SATA RAID Controller (Desktop ICH7R/DH)"

iastor = "Intel® 82801GR/GH SATA AHCI Controller (Desktop ICH7R/DH)"

iastor = "Intel® 82801GBM SATA AHCI Controller (Mobile ICH7M/DH)"

iastor = "Intel® 82801FBM SATA AHCI Controller (Mobile ICH6M)"

Then i added all the dirvers' files into AMD64 since no WINNT.SIF file was specified.

Another reason why did not use WINNT.SIF was because it was originally not present on the CD.

But did try to use it and it gave me an fatal error saying that the data structure of the setup changed and did not install anything at all. So what i tried next was to add the following code since they had it for other drivers like ramdisk, atapi, disk, etc.

But i got the same problem that the drivers were recognized for the setup and ather the setup it did not recoginze the dirvers.


iastor = iastor.sys


iastor = "AHCI"


iastor = "SCSI AHCI"

I even tried to add the compressed cab files like the guide said and nothing changed. (for example iastor.sys compressed to iastor.sy_) I even took a step further and took the original files and put them into a cab file called SP2.CAB where the CD had may other drivers inside there and nothing changed.

So what now? Well, i tried using nLite but i gave me a trade off of problems. It did slipstream the drivers properly and worked after setup but a new problem was generated due to the fact that nLite repaces some of the original files with some that comes with nLite. The new problem is that everytime i want to change the Regional Language it will ask me for the CD and i must have the CD inserted in order to change the language. If i slipstream it manually without problems, it would ask me for the CD when i change the regional languages but i don't have to have the CD inserted. If press ok, the language will change without problems because it would search for the files that are already in the pc. In other had, if i slipstream it with nLite, the new problem won't go away. To make it short i want to slipstream the drivers manually.

P.S. Sorry, i am not using codeboxes because they look worse where all of them are same size and some of them will become a scrollable box. If anyone knows how to format them, please tell me so i can put them right away.

Share this post

Link to post
Share on other sites

Same problem. Unable to create a AHCI enabled XP 64 Setup CD.

I created various enhanced Windows XP CDs before, but as soon as it comes to Windows XP 64bit and AHCI I completely fail.

Mainboard: ASUS P5Q-E (ICH10R)

There's a F6 driver disk on Intel's site for download (64bit) - slipstreaming it doesn't help at all.

This is what happens:

On the setup page where you have to select the target medium, it says: 141816 MB Disk 0 at Id 0 on bus 0 on ioStor.

First of all.. it's a WD Raptor ADFD (74GB).. I used to have it in raid 0 mode - still I wonder why it says 141816 MB here. The harddisk currently is the only drive in the whole system and SATA torage mode is set to AHCI (not RAID, not IDE).

Anyway.. it sees a disk. Unfortunately the next line says: ("Setup cannot access this disk.)"

Great. So it sees the disk but cannot handle it? why?

Installing on a RAID 0 (SATA mode: Raid) works fine. So this is an AHCI specific issue.

Any suggestions (apart from installing in IDE mode and switching to AHCI afterwards)?

Share this post

Link to post
Share on other sites

It seems like you have to enable RAID mode, remove all RAID arrays you once might have had and then switch back to AHCI.

Why do I always solve my problems shortly after I posted in a forum? :-(

Share this post

Link to post
Share on other sites
Why do I always solve my problems shortly after I posted in a forum? :-(

Because you ask to quick? ;-) Besides, with a post count of two that must be a serious problem. :-D

Edited by enuffsaid

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.