Jump to content

win 98 se wont boot when added a sata hd


Recommended Posts


I have an asrock m/b 775 dual-880 pro for p4 and installed in hd ide :

c: primary partit w98se

d:sec ext partition winxp 512 ram

working good (i think)

when i added a sata hd 320 gb in system

win xp bots ok

win 98 cant boot??? after c:\>keyb. gk,c:\windows\command\keyboard4.sys


i see only a blinking minus sign at upper left corner of screen

and waiting ... and nothing

win 98 boots well (i think) in safe mode and i see the hd full capacity and

the files those i added from win xp

my question why dont have w98

Link to comment
Share on other sites

Well Windows 98 does not support 48-bit LBA, meaning it cannot see drives larger then 137GB.


Are you saying that if you disconnect your SATA drive, then WIN98 boots completely? And you can boot into Safe Mode?

keyboard4.sys might be some sort of keylogger/virus; can you run an antivirus from xp and scan your win98 partition offline?

AVG Free is a good start: http://free.grisoft.com/ww.download?prd=afe

Link to comment
Share on other sites

Hi and thank you and appreciate for lightening responce

I did an all scan with avg antiv and the system is clean i suppose

and there is something else,in safe mode the w98 partition is c:

winxp part e:

and the 320 gb hd w/o op system has d: drive letter.

In win xp the drive letters are c:win98---- d: winxp----- e:empty fat32

And something another the partitioning and formatting of empty 320 gig hd it became with a boot cd that gave to me

from a friend, from dos before the operating system.

And something else ,when i turn to turn off from win xp ,explorer takes a little time about 15 sec to close.

Edited by arkadia
Link to comment
Share on other sites

It might be a problem with the SATA controller driver. Do you happen to know which controller you're using?

A good way to test if this is the case is to look at the last line in bootlog.txt and bootlog.prv (from DOS or safe mode, naturally) to see where it stops loading up. If you see the driver file for your SATA controller, that's a sure-fire indication.

Another indication is that it runs fine in safe mode (as you have already mentioned).

From my experience, the latest SATA controller drivers don't work on 98, even if they claim support for it. You might get better luck with drivers form 2002 or earlier, back when this sort of thing was actually tested. If your driver provider doesn't keep drivers that old in its archive, you might try the WayBack Machine.

If you can't get the driver, you can still get your system to hack-work by forcing your drive to work as if it was in safe mode - reduced performance, but at least it works. Here are a few methods:

1. Start up in safe mode. Right click "My computer" and click "Properties", then click on the "Performance" tab, and then on the "File System..." button. Go to the "Troubleshooting" tab and check "Disable all 32-bit protected-mode disk drivers". Important note: This will affect all drives, including your PATA HDD and your CD drives.

2. Start up in safe mode. Click "Start" then "Run...", input "msconfig" and hit "OK". Click on "Advanced..." and check "Force Compatibility mode disk access". Has the same effect as #1.

3. In safe mode, right click "My computer" and click "Properties". Go to "Device Manager" and locate your SATA controller (will usually be in SCSI). Click on it, the click on "Properties", then on "Driver", and on "Update driver...". From there, select "Display a list of all..." then "Show all hardware". Pick something random which you're relatively sure will not be compatible. This will cause the random-picked driver to fail to load, causing your drive to load in compatibility mode. Unlike the above options, this will only affect the SATA drive. Be aware, that if you pick a compatible or even semi-compatible driver, it will have no effect.

4. In DOS mode, locate and delete/rename the driver file. This should cause the driver to fail to load, but there's a chance it will still try and still freeze. In other words, this might not always work.

Be aware that all of the above solutions will leave your SATA in compatibility mode, meaning it will run slower, and consume more CPU resources. The only real solution is to locate an older driver, and install it.

Link to comment
Share on other sites

I have had same problem with Asrock 4coredual-sata2 -Intel core 2 quad processor -2 Gb of DDRII -

My Mainboard has VIa chipset and it appears that if I do not set in the BIOS the sata driver as RAid the system does not boot.

So if you got also Via chipset the simple solution is to abilitate Raid in the BIOs.

LEt us know if you solved problem

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...