Jump to content

Prestage menu missing from Users and Computers snap-in


Recommended Posts

I just installed one Windows 2008 Standard server and added the WDS role on it. We are running our AD in Windows Server 2003 mode and had already earlier installed a RIS server on an 2003 R2 server. The wdsserver service is turned off on our old RIS machine and only the new 2008 server with the WDS role is on. I'm trying to manually approve a machine requesting to get service but am instantly greeted with just the "access is denied" prompt. This is the Windows Deployment Services snap-in opened using the "Run as an Administrator" from the context menu, that is.

After googling a lot about this problem I have learned that the computer object of the new 2008 server needs to have the "Create computer object" rights in the Domain Controller OU etc.

1: Deploying Vista via WDS

2: WDS When pending devices try to Approve --> Access Denied

Following the instructions explained on those before mentioned links don't provide a solution for us. After too many hours of hitting my head against the wall I figured out that I could still prestage the machine with GUID. Things is that Active Directory Users and Computers snap-in does not have the option to do so anymore? When I click "New -> Computer" on top of one of our OU's I can only type the name of the machine and there is no option to click next and choose "This is an managed computer" like I've seen at least before.

Anyone has any clues what's going on, did I irreversibly change something on our AD when I installed WDS? :unsure:

post-114779-1210074600_thumb.png

Link to comment
Share on other sites


Actually there's nothing RIS related visible when using the Active Directory Users and Computers snap-in. When I used to right click the RIS server computer object there was that "Remote install" tab where you could view properties of the RIS server, even that tab is gone now. I have tried this on both of our Domain Controllers.

Link to comment
Share on other sites

hi, did you do the following when setting up WDS on Windows Server 2008 ?
Before you begin, you need to configure Windows Deployment Services by running either the Windows Deployment Services Configuration Wizard or WDSUtil.exe. You will also need to add at least one boot image and one install image in the image store.

cheers

anyweb

Yes, I did follow that. WDS is functioning just fine, just as the old RIS server, too. Problem is that I cannot prestage machines using Active Directory Users and Computers snap-in nor can I view that Remote Install tab anymore on our RIS machine's AD object.

I just installed virtual environment to test this and I cannot prestage computer accounts there either. The virtual env consists of AD running in Windows 2003 Server mode, all the member servers running 2003 R2 SP2 and WDS configured using the legacy wizard.

What in earth is the problem here? Where's my RIS related tabs and prestaging functionality?

Link to comment
Share on other sites

well you do know that RIS is not supported at all in Windows server 2008 don't you ? W2k8 only supports WDS in native mode

In native mode (both Windows Server 2003 and Windows Server 2008), there is NO RIS functionality, you will only have access to WinPE or WIM images. Management of WDS is via the WDS mmc console or via command line, and Native mode is the only option in Windows Server 2008.

I am in the process of doing a new install of Windows Server 2008 and hopefully will have some suggestions for you shortly

cheers

anyweb

Link to comment
Share on other sites

I am in the process of doing a new install of Windows Server 2008 and hopefully will have some suggestions for you shortly

See if you can use the prestage option using the Active Directory Users and Computers snap-in running on the Domain Contoller?

I just installed the Adminpak.msi onto my old RIS server, using the AD Users and Computers snap-in I can verify that Remote Install tab is present when browing properties of the RIS computer object, and when creating new computer object I can also prestage it. I have no clue why, though? Why would that snap-in behave differently when run on the RIS server and when run on DC for e.g.?

Link to comment
Share on other sites

dunno if this is what you mean but i tried adding a new computer in AD users and computers

like so

post-148778-1210251701_thumb.jpg

i then selected that it was a managed computer

post-148778-1210251771_thumb.jpg

i selected my windows 2008 server as the remote install server

post-148778-1210251813_thumb.jpg

and then we saw a summary of those actions

post-148778-1210251864_thumb.jpg

finally once the computer is added in ADDS, I can right click it and the Remote Install tab is PRESENT

see here

post-148778-1210252050_thumb.jpg

so I wonder did you configure your WDS server like I did (look at step 4 and 5), please check your setup, also, have you sysprepped this windows 2008 server in any way ?

cheers

anyweb

Edited by anyweb
Link to comment
Share on other sites

  • 2 months later...
I just installed one Windows 2008 Standard server and added the WDS role on it. We are running our AD in Windows Server 2003 mode and had already earlier installed a RIS server on an 2003 R2 server. The wdsserver service is turned off on our old RIS machine and only the new 2008 server with the WDS role is on. I'm trying to manually approve a machine requesting to get service but am instantly greeted with just the "access is denied" prompt. This is the Windows Deployment Services snap-in opened using the "Run as an Administrator" from the context menu, that is.

After googling a lot about this problem I have learned that the computer object of the new 2008 server needs to have the "Create computer object" rights in the Domain Controller OU etc.

1: Deploying Vista via WDS

2: WDS When pending devices try to Approve --> Access Denied

Following the instructions explained on those before mentioned links don't provide a solution for us. After too many hours of hitting my head against the wall I figured out that I could still prestage the machine with GUID. Things is that Active Directory Users and Computers snap-in does not have the option to do so anymore? When I click "New -> Computer" on top of one of our OU's I can only type the name of the machine and there is no option to click next and choose "This is an managed computer" like I've seen at least before.

Anyone has any clues what's going on, did I irreversibly change something on our AD when I installed WDS? :unsure:

post-114779-1210074600_thumb.png

I had the same exact problem. I resolved this by reinstalling the adminpak.msi. Then the problem went away.

Good luck!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...