Jump to content

vLite with Vista SP1-wave1


Noupe
 Share

Recommended Posts

I had a bit of problem with nLite (1.1.6 RC) and the new all-languages Vista SP1.

1. Loaded a fresh Vista (English 32-bit) into vLite. I've vLited this version before with no hassles. But this was as I said a fresh set of setup files

2. Integrated the new Vista SP1 all languages (the full file w/ all languages, 544MB)

3. Integrated the Swedish language pack (because according to MSDN, the full SP1-wave1 contains the lp:s for all languages)

4. Removed some stuff as usual. Nothing hardcore; languages, media center, windows search and similar stuff (did not make a preset file unfortunately).

5. Installed

Result: Installer loops after installation with the classic "Installing Service Pack 3/3 100%" thing.

So, could this have to do with the new wave1-servicepack and/or the swedish language pack?

Thanks for a very useful tool!

Edited by nuhi
Link to comment
Share on other sites


I haven't used my Vista installation yet, so don't know if there are any untranslated parts due to using the pre-SP1 language pack and then slipstreaming with SP1.

Both the Windows Vista Blogs and other sources are really confusingly using "language packs" and the new all-languages service packs interchangeably. That is, when they are talking about the Vista SP1 with language support for all 30(something) languages, they are calling it "language packs", which is a bit confusing.

For example this Computer World article: http://www.computerworld.com/action/articl...ticleId=9078018

Title is "Microsoft releases remaining Vista SP1 language packs", but they are not really talking about language packs as we know them, but just about SP1 installation files. Language packs for me are the 150MB (something) cab files you can download from Windows Update when you have Vista Ultimate or any other version that supports multi languages.

So the question is if you need new (SP1) language packs to go with your Vista SP1. This site seems to have direct download links to the new SP1 language packs:

http://www.tipandtrick.net/2008/windows-vi...cial-downloads/

So my new questions would be:

1. How does all the stuff I've been talking about above really work?

2. How would you go about installing all this with vLite? First integrate the new SP1 language packs (if they exist) to a non SP1-Vista? And then slipstream with SP1. Or first slipstream with SP1, and then integrate the new SP1 pack. This obviously did not work for the pre-SP1 language pack (see first posts in this thread).

Nuhi, others, any thoughts?

Link to comment
Share on other sites

you have to integrated the swedish RTM LP first. Then you should integrate the Sp1 - Wave1

Does this mean that the RTM LPs or MUIs goes good with SP1?

NO!.There is an article about this in Technet.Do not integrate RTM LP-s into SP1 vista..image will be corrupt.Wait for the SP1 LP-s

Link to comment
Share on other sites

It worked fine for me, that is (with vLite):

Vista RTM (English) -> RTM Language Pack (Swedish) -> SP1 Slipstream (All languages) -> Removals

Sitting on that system now, and have not noticed any corruptions and all parts so far seem translated. Though if I notice anything wrong I'll know what the problem is and redo all above, but with the mysterious SP1 language packs, for some reason yet (?) to be officially released.

Do you have the link to that Technet article?

Cheers

Link to comment
Share on other sites

It worked fine for me, that is (with vLite):

Vista RTM (English) -> RTM Language Pack (Swedish) -> SP1 Slipstream (All languages) -> Removals

Sitting on that system now, and have not noticed any corruptions and all parts so far seem translated. Though if I notice anything wrong I'll know what the problem is and redo all above, but with the mysterious SP1 language packs, for some reason yet (?) to be officially released.

Do you have the link to that Technet article?

Cheers

Currently i dont have the link but i have a screenshot with info mentioned above.I will upload it when i go home later today.

Link to comment
Share on other sites

Does this mean that the RTM LPs or MUIs goes good with SP1?

no, if you first integrate the RTM LPs into a DVD the Wave1 Installer updates the LP files correctly. But if you try to integrate the RTM LPs into a DVD it works, but there are a lot of untranslated parts of Vista.

if you need a Sp1 Installation with a new LP to the steps :

1. integrate the LP

2. integrate the Wave1 Sp1 Installer

3. Remove useless stuff.

Link to comment
Share on other sites

Is there any chance to get LP from wave1 package and integrate it into pre-SP1 disc?

You can download both the original (pre-SP1) language packs as well as the new, not yet officially released, SP1 language packs from the link in my post further up in this thread. The new language packs were apparently released to MSDN subscribers and leaked.

As far as integrating an SP1 language pack into a new SP1 disk, I have no yet tried that. However, what Magic writes is correct, I'm sitting on that installation right now. Makes a bit of sense too; if you have Vista and a language pack installed, and install SP1 from Windows Update or whatever, you are essentially doing the same thing -- updating to SP1 but only having a pre-SP1 language pack. That's why I think these new language packs are a bit mysterious, and strange that Microsoft really doesn't mention them. The Windows Vista Blog has some blurb about it, but the person who wrote that post writes so poorly it's hard to decipher what he's really talking about; the Service Pack or the Language Pack or both.

Link to comment
Share on other sites

Hello,

I used nLite for a while and it works fine. Recently I bought a new laptop from Dell which has a OEM activated Vista Home Premium (Traditional Chinese) DVDROM. Yesterday I downloaded SP1 full package (Windows6.0-KB936330-X86-wave1.exe) and tried to slipstream SP1 into it with vLite RC.

I only checked "slipstream ServicePack" and "make bootable image" in the task, after vLite copied all files on OEM DVD and asked SP1 file location, it starts slipstream, but stopped after about 30 minutes it started slipstream task, only show a message to indicate something was wrong, without detail information.

Is there a log that I can see what's wrong or post to here for discussion?

Link to comment
Share on other sites

Noupe - Yeah, I downloaded SP1 LP from the link you posted. It integrated fine (into preintegrated SP1 disc which had only English language). It seemed to install perfectly as well! :)

Thanks for the info.I was wondering if it will work 100%.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...