Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Grizzly

XP x64 unattended: Change ProgramFiles location problems

Recommended Posts

I try to install WinXP x64 (SP2) with German MUI pack.

I changed Program Files locations in winnt.sif:

ProgramFilesDir="\Programme"
CommonProgramFilesDir="\Programme\Gemeinsame Dateien"
ProgramFilesDir(x86)="\Programme(x86)"
CommonProgramFilesDir(x86)="\Programme(x86)\Gemeinsame Dateien"

After installation there are the following program directories created too:

C:\Program Files (x86)

C:\Program Files (x86)(x86)

Latter is containing some files (e.g. Netmeeting software).

Doing some research in registry I found following corresponding wrong keys, where the

program files location change did not has taken place, e.g.:

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion

CommonFilesDir = C:\Program Files (x86)(x86)\Common

ProgramFilesDir = C:\Programs Files (x86)(x86)

Does anybody know whether there is patch for this setup configuration error?

Or how to write a repair script to be integrated in the setup?

Second question I have is regarding the MUI setup.

I did it by let setup calling

muisetup.exe /i 0407 /d 0407 /r /t

during unattended setup.

Afterwards I noticed MUI installed in default program dir ("Program Files"),

i.e. MUI is ignoring changed program file location.

It does so when installing MUI manually too.

I can't find any switch of muisetup to change target directory.

An answer file mui.txt is ignored too.

thx for any suggestions

Share this post


Link to post
Share on other sites

Hello. I ran into the same issue myself yesterday. I saw your post and just changed the following below, after the OS installed. Is there a way that you can insert some sort of command or batch file to change the registry settings to the ones below when you set up the winnt.sif?? After i made this change everything now defaults to D: . Only thing i have in C: is the windows folder, I386, and the AMD64 folder. Why do i have the AMD64 folder on C:\?? don't know lol just though i would place it in there.

CommonFilesDir REG_SZ D:\Program Files\Common Files

CommonFilesDir (86) REG_SZ D:\Program Files(86)\Common

ProgramFilesDir REG_SZ D:\Program Files(x86)

ProgramFilesDir (x86) REG_SZ D:\Program Files

Edited by Dark-Fiber61

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...