Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


how to stop Found New Hardware Wizard

Recommended Posts

I’m not sure if this is the correct place for this question but if its not I am sure someone will let me know. :rolleyes: I have a batch file that installs all the drivers. What it does is install one driver like the chipset and then reboots then the video driver and then reboots. But the issue I am having is that the “Found New Hardware Wizard” keeps popping up and causing my batch file to hang. If I’m sitting there and click the cancel button to the Wizzard then there is no problem. However, it is no longer a unattended install of the drivers. Does anyone know how to stop the “Found New Hardware Wizard?” I have read several posts and havn’t had any luck. I have even turned PNP off with a reg hack. But no luck there either.

Thanks for any info you can give.

Share this post

Link to post
Share on other sites

Best advice I can give you is to use Pyron's method (Drivers from CD) outlined in the msfn unattended guide. Any driver that can be sucessfully installed via this method will never cause a 'Found New Hardware' popup. What you'll have to do is extract your driver installation files to find the base .inf. Then feed that base .inf via Pyron's method and Windows' Hardware Wizard won't bother you. However, this will in no way prevent you from installing the original driver installation file like you're used to.

PS: Oh yeah, you'll also need to provide any file (.dll, .sys) that is referenced in the base .inf. If you're not sure which files make up the actual driver just provide the entire dir.

Edited by legionaire

Share this post

Link to post
Share on other sites


This post may be dead, but you've just helped me out.

More info:

The registry value to set to disable the hardware wizard UI mentioned in the article http://support.microsoft.com/default.aspx/kb/938596


Key: HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\DeviceInstall\Settings

Value: SuppressNewHWUI

Data: 1 (REG_DWORD)

On a Windows XP SP3 computer the hotfix mentioned in the link is not required, the registry setting will work.

Setting the value works immediately in a from-now-on capacity and does not need a restart. The problem is that the wizard may have already started before the setting is set in your script. In this case, we just kill the RunDll32.exe process that is holding the wizard running. Then no more wizards run and the driver can be installed. Don't forget to revert the setting after installing the drivers.

Hope this helps.


Edited by Daz_1234

Share this post

Link to post
Share on other sites

i tried to remove that screen by injecting to HIVESFT.inf:


the hardware wizard still appear at T-25 asking for terminal server mouse/keyboard...

i wonder if the key i wrote to hives.. is the correct way?

please any other method in mind that any of you could have(source code, scripts..etc) that i could use for this will be welcome.. please if someone provide something tell how to implement it and where to put the code/scripts.

My Best Regards

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.