Jump to content

Wireless network not stable


progenis
 Share

Recommended Posts

I have both Windows 2003 and Windows XP. In Windows XP, my wireless connection is dropping so often and speed is not so good.

Wireless connection on Windows 2003 is very stable and I get good speeds. I am using the same drivers on both OS. I use the same network

services. What could be the problem?

Thanks.

Link to comment
Share on other sites


When you say you're using the same drivers, do you mean that each system has the same network (wireless) adapter?

On the faulty computer, have you tried using a different wireless adapter? Where are both computers physically, in relation to your wireless router or access point?

Link to comment
Share on other sites

Also if they are the same adapters... try swapping the adapters on the machines to see if it gets slow and unstable on the other computer. If it does then that would point to the adapter being bad.

Both Windows 2003 and XP are on the same computer, on a different partition. So, hardware is identical, computer and the network adaptor. I use the same drivers on both Windows 2003 and Windows XP. I looked at the services, I tried to set them the same, that did not help. There are some TCP/IP optimization suggestions. I did them too but did not help. I am getting both faster speeds and not many signal loss on Win 2003. I know Windows 2003 has a newer kernel.

Link to comment
Share on other sites

It certainly sounds like the drivers aren't the same, as the network stack between the two is identical (although it's tweaked for performance differently on 2K3, it's still roughly the same codebase). In fact, wireless generally should work BETTER in XP than in 2K3, so I'd say that the driver quality is suspect, right now, given your problem statement.

Link to comment
Share on other sites

I use the same drivers on both operating systems. Drivers are only for Windows XP. I am not sure even if they tested it under Windows 2003.

Are the registry settings and the binaries the same for wireless network for both Windows XP and 2003. The way they are behaving I feel like they are different. Even the login takes longer with Windows XP.

What binaries are involved? Maybe I can copy from one to another to see if it makes difference?

Thanks.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...