Jump to content
MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. ×

MacLover

Member
  • Posts

    33
  • Joined

  • Last visited

  • Donations

    $0.00 

Everything posted by MacLover

  1. There seems to be a bug in KB2479629: When I attempt to install it on a "fresh" Windows 2000 system (Windows 2000 SP4+UR1, no unofficial patches installed), the installer will say that KB2479628 is not installed. From looking at update.inf, it seems like the old WIN32K.SYS version check from MS11-011/KB2393802 was left in the INF. Removing the check from the INF fixed the installer and everything is working. Thanks again for the patches!
  2. I've been trying to get later versions of WinUAE working in Windows 2000 (The last version that officially supports 2000 is 2.0.1.) - 2.4.2 beta 6 and earlier will always run correctly with an extended kernel - 2.4.2 beta 7 through 2.5.0 beta 14 will just quit after attempting to allocate memory - 2.5.0 beta 15 through 2.7.0 beta 9 have the following behavior: - If the system memory is less than 1536MB, the emulator will run - If the memory is 1536MB or more, the emulator will not run (If I run with "-log", the last entry is "Total physical RAM 2047M, all RAM 4160M, attempting to reserve 769M) - 2.7.0 beta 10 and all later versions will stop at the "Attempting to reserve" message even if system memory is <1536MB The problems seem related to a memory allocation rewrite in 2.4.2 beta 7 (and from searching the source tree for the log messages, it seems like the relevant code is in od-win32/mman.cpp EDIT: I was looking at some more of the WinUAE changelogs and it looks like the emulator had to implement a workaround at one point for Win2k's VirtualAlloc not supporting the MEM_WRITE_WATCH flag. This workaround was removed in 2.2.0 beta 1. EDIT: Had the wrong version listed as the last that was officially Win2k compatible. EDIT: I tried running the emulator with API Monitor and it got stuck in a loop trying to use VirtualAlloc() with the MEM_WRITE_WATCH flag. Windows returns 0x50 (ERROR_NOT_SUPPORTED). If I'm reading the output correctly, it looks like the NtAllocateVirtualMemory API in NTDLL.DLL actually does the work and VirtualAlloc() just calls it. NtAllocateVirtualMemory returns 0xc00000bb (STATUS_NOT_SUPPORTED).
  3. Same details. On the other hand, if I disable Shared Folders before booting up and logging in then re-enable it after I've logged in and try to access the network drive, Explorer crashes. EDIT: here are some logs from Dr. Watson: explorer.txt winlogon.txt
  4. Still the same BSOD. EDIT: On a whim, I decided to try regular safe mode and it works fine as well. EDIT2: If I disable VMware shared folders, the system boots fine.
  5. Still the same bluescreen (If it helps, Windows shows a "Restoring Network Connections" dialog (for VMware shared folders) right before the BSOD.)
  6. It seems the latest Kernel32 rewrite has a little problem: I installed it in a Windows 2000 VMware VM and every time I try to log in, it gives me the following BSOD: STOP: c000021a {Fatal System Error}The Windows Logon Process system process terminated unexpectedlywith a status of 0xc0000005 (0x00000000 0x00000000)The system has been shut downThe updates installed on the system are: Service Pack 4 & Update Rollup 1 Update Rollup 2 Internet Explorer 6 with the April 2013 Cumulative Update (KB2817183) (Custom Support Update) Windows Script 5.7 KB2360937-v2 (The MS10-084 update) KB2393802-v21 (MS11-011) KB2479628-v10 (MS11-012) KB2508429-v12 (MS11-020) kernel32-rewrite-v4 EDIT: I was able to start up in Safe Mode with Command Prompt to restore the MS11-011 v21 kernel32 however. EDIT2: Forgot to mention IE6
  7. It seems that the rewritten kernel32 causes mshta.exe to consistently crash when running Add/Remove Programs. It also seems to make the Windows Post-install Wizard really unstable and sometimes crash in mshta.exe.
  8. I will also have a spare system ready for testing at the end of the week. Also, I noticed that this month's Security Updates ISO does not include a Windows 2000 IE6 update despite the fact that MS13-037 fixed 3 critical vulnerabilities (every other Critical IE patch had a Win2k update in that month's ISO (except for the January 2013 Out-of-band patch, which was in the February ISO.)) EDIT: The spare machine in question (a laptop) just had its cooling fan fail, so my tests may be delayed until I can get another machine ready or fix the fan. Turns out all that was wrong was that the fan was caked with about two years worth of dust...
  9. I was taking a look at the IE6 SP1 version of the MS12-052 fix that BlackWingCat found on the Microsoft Security ISO and I decided to run it through IDA Pro and TurboDiff (I compared against the last pre-EOL fix, MS10-035/KB982381) and TurboDiff found no changes to any function in BROWSEUI.DLL between the two versions. Since WildBill's notes for MS10-071 show that changes to BROWSEUI.DLL were required to fully close up the AutoComplete vulnerability, I also compared the XP versions of MS10-035 and MS10-071 and functions did show up as changed. This tells me that Microsoft is doing the same thing with these "Extended Support fixes" that they did with Windows 98's extended support in that they only fixed vulnerabilities marked as "Critical." I remember that WildBill had said that MS11-003 would be a pain to backport but it looks like M$ did the hard work for us for that bulletin (all of its CVE's are marked as "Critical") and an easier solution for that update might be to use the Microsoft MS11-003 or MS12-052 IE6 SP1 patch and add the other changes from the previous unofficial IE updates as necessary. On another note, I noticed some issues with MS11-012 where FileZilla's toolbar has the same white splotches where the shadows are supposed to be that we had before adding the ShellIconBPP setting. How FileZilla's toolbar looks on stock Win2k: How FileZilla's toolbar looks with MS11-012 installed: How FileZilla's toolbar looks on Windows XP: This is a minor issue, so no rush on fixing this or doing any of the IE updates (I use Firefox 10 ESR on 2000, so the vulnerabilities don't concern me too much.) PS I'm trying to learn some of this patch analysis stuff so that maybe I could help with the load at some point.
  10. I've done some tests with the updates from this month's Patch Tuesday and these are my results: MS12-002: Didn't test this one but it looks like a simple registry fix. MS12-003: Didn't even try as it updates a core system file (WINSRV.DLL) MS12-004: The DirectShow (QUARTZ.DLL,QDVD.DLL) update worked fine but the Windows Multimedia Library (WINMM.DLL,MCISEQ.DLL) part broke sound completely. MS12-005: Works (Seems PACKAGER.EXE hasn't changed much since the NT4 days...) MS12-006: Works thanks to WildBill's MS11-011 and MS11-020 updates. (SCHANNEL.DLL,WINHTTP.DLL)
  11. Looks like the Realtek HD Audio Driver issue is caused by a patch somewhere as I just installed a "cleaner" Win2k disc with only the official patches, IE6, DirectX 9, and MSXML integrated. The latest driver from Realtek.com installed just fine using that install. I'll try to narrow down the problem as soon as possible. EDIT: I manually installed every unofficial fix, the issue didn't show up, which tells me that something went wrong with my fully slipstreamed Win2k DVD. In other words, there's nothing wrong with any of your patches EDIT: Turns out the issue was caused by the way DriverPacks integrates KB888111
  12. Turns out that for the ATI 9.x driver needed for my netbook (The 11.x driver installed but wouldn't start - I don't think this is an issue with your patch as the same things happen on XP with the desktop drivers (AMD does not provide reference drivers for its notebook chipsets) ) needs one more API to function: NTOSKRNL.EXE -> vDbgPrintEx For now, I'll try hex-editing the driver to use DbgPrintEx and see what happens EDIT: Looks like hex-editing the driver did no good, I'll just use blackwingcat's driver for now EDIT: Interestingly enough, the Realtek HD Audio drivers from 2011 refuse to start on Windows 2000 despite the fact all needed APIs are present (Code 10 in Device Manager)
  13. Did you try BlackWingCat's setupapi.dll? I don't know if it supports those two functions, but it is probably worth a try. http://blog.livedoor.jp/blackwingcat/archives/873798.html BWC's SETUPAPI.DLL doesn't support SetupSetNonInteractiveMode, therefore I cannot install VirtualBox 4 even with a modified MSI to allow installation on Win2k. It does have SetupUninstallOEMInfW though.
  14. I didn't notice it before but VirtualBox needs two more APIs to install properly: SETUPAPI.DLL -> SetupSetNonInteractiveMode SETUPAPI.DLL -> SetupUninstallOEMInfW As I said before, no rush on getting these in but it would be nice to have the ability to run VirtualBox 4.x on Windows 2000. Again, keep up the great work!
  15. Thanks, the bug is fixed now. EDIT: By the way, XP's MSVCRT.DLL works with your MS11-011 v6 update.
  16. The information from the first event (the Kerberos failure) is as follows: Event ID: 5000 Description: The security package Kerberos generated an exception. The package is now disabled. The exception information is in the data. Data: 05 00 00 c0 00 00 00 00 00 00 00 00 dc 15 2b 78 02 00 00 00 00 00 00 00 00 00 00 00 3f 00 01 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 7f 02 ff ff 00 00 ff ff ff ff ff ff 92 12 0a 00 20 40 45 03 20 2d 00 00
  17. I found an issue with your MS11-020 fix : On Windows 2000 Advanced Server (Probably any other server variant as well), when I enable Active Directory, I am unable to log on to the system unless I use safe mode *without* networking. I narrowed down the issue to being caused by the KERBEROS.DLL file from said update. When I look at the event log on the system (in safe mode), it mentions Kerberos causing an exception and then a cascade of failures caused by that.
  18. Billtodd - It fixes the MS10-046 security vulnerability relating to LNK files.
  19. There are 4 numbers in a version number in this file (The version number is also in hex.) i.e. 5.1.2600.5512 = 000500010A281588
  20. I just finished going through all of the files for VS2008 and found that the following APIs are needed to run it: for .NET Framework 3.0: RPCRT4.DLL -> I_RpcBindingInqLocalClientPID (InfoCard component) RPCRT4.DLL -> RpcServerInqCallAttributesW (WPF) RPCRT4.DLL -> RpcServerUnregisterIfEx (WPF) [s]ADVAPI32.DLL -> SystemFunction036 (InfoCard component)[/s] MSVCRT.DLL -> _vscwprintf (WIC) MSVCRT.DLL -> _wtof (WIC, WPF) MSVCRT.DLL -> _aligned_free (WIC) MSVCRT.DLL -> _aligned_malloc (WIC) MSVCRT.DLL -> ___lc_codepage_func (WPF, XPS) MSVCRT.DLL -> ___lc_handle_func (WPF, XPS) MSVCRT.DLL -> __uncaught_exception (WPF, XPS) MSVCRT.DLL -> _resetstkoflw (WPF) MSVCRT.DLL -> __crtGetStringTypeW (XPS) MSVCRT.DLL -> __crtLCMapStringW (XPS) MSVCRT.DLL -> ___mb_cur_max_func (XPS) MSVCRT.DLL -> __pctype_func (XPS) MSVCRT.DLL -> _strtoi64 (XPS) MSVCRT.DLL -> _strtoui64 (XPS) [s]KERNEL32.DLL -> RtlCaptureStackBackTrace (WIC, WPF, XPS)[/s] [s]NTDLL.DLL -> DbgPrintEx (WIC, WPF)[/s] USER32.DLL -> RegisterRawInputDevices (WPF) USER32.DLL -> IsWinEventHookInstalled (WPF) WINSPOOL.DRV -> IsValidDevmodeW (XPS) for Web Designer Core (from WCU): [s]KERNEL32.DLL -> CreateMemoryResourceNotification[/s] [s]KERNEL32.DLL -> QueryMemoryResourceNotification[/s] for Windows SDK tools: DBGHELP.DLL -> SymLoadModuleEx DBGHELP.DLL -> SymEnumTypes DBGHELP.DLL -> SymGetTypeInfo CRYPT32.DLL -> CryptStringToBinaryA CRYPT32.DLL -> CryptStringToBinaryW [s]KERNEL32.DLL -> SetThreadUILanguage[/s] for VS2008 itself: [s]KERNEL32.DLL -> AddVectoredExceptionHandler[/s] KERNEL32.DLL -> DebugActiveProcessStop KERNEL32.DLL -> DebugSetProcessKillOnExit SHELL32.DLL -> SHCreateShellItem SHELL32.DLL -> SHOpenFolderAndSelectItems SHELL32.DLL -> SHParseDisplayName OLEAUT32.DLL -> 442 (Ordinal number for RegisterTypeLibForUser) URLMON.DLL -> CoInternetSetFeatureEnabled [s]IPHLPAPI.DLL -> IcmpCloseHandle[/s] [s]IPHLPAPI.DLL -> IcmpSendEcho[/s] [s]IPHLPAPI.DLL -> IcmpCreateFile[/s] EDIT: I forgot that a few files required UXTHEME.DLL but BlackWingCat's UXTHEME.DLL wrapper in system32 seems to take care of that issue. (At least as far as Dependency Walker is concerned ) EDIT: Strange, Ordinal 345 is missing from COMCTL32.DLL even on Windows XP... (I think this is yet another Vista/7 API or some undocumented function...) EDIT: Crossed out functions added in MS11-011 v5 EDIT: Crossed out functions added in MS11-020 v5
  21. tomasz86 - there seemed to be a few functions missing for WPF as well. And getting XPS and WIC working would be nice. Some of the XAudio files and such seem to be missing two functions in MSVCRT.DLL.
  22. Here's another set of suggestions for functions to add: With one additional function, we should be able to use Windows XP's MSVCRT.DLL, which would allow even more software to function under Win2k (i.e. getting us closer to being able to run .NET Framework 3.x and 4.0 and VS2008, as well as fixing some more drivers and newer DirectX Runtimes): NTDLL.DLL -> RtlGetNtVersionNumbers Some more functions and what they would fix: KERNEL32.DLL -> GetSystemTimes (Grand Theft Auto IV) KERNEL32.DLL -> RtlCaptureContext (QuickTime, iTunes) KERNEL32.DLL -> GetGeoInfoA (iTunes, Games for Windows Live) KERNEL32.DLL -> GetUserGeoID (iTunes, Games for Windows Live) KERNEL32.DLL -> SetThreadUILanguage (Games for Windows Live) KERNEL32.DLL -> WTSGetActiveConsoleSessionId (Games for Windows Live) SHELL32.DLL -> SHGetFolderPathAndSubDirW (QuickTime,iTunes) SHELL32.DLL -> SHParseDisplayName (QuickTime) WTSAPI32.DLL -> WTSQueryUserToken (iTunes, nVidia Drivers) WTSAPI32.DLL -> WTSUnRegisterSessionNotification (WinUAE) WTSAPI32.DLL -> WTSRegisterSessionNotification (WinUAE) USER32.DLL -> GetRawInputData (Media Player Classic Home Cinema, WinUAE) USER32.DLL -> GetRawInputDeviceInfoW (Media Player Classic Home Cinema, WinUAE) USER32.DLL -> GetRawInputDeviceList (Media Player Classic Home Cinema, WinUAE) USER32.DLL -> RegisterRawInputDevices (Media Player Classic Home Cinema, WinUAE) USER32.DLL -> DefRawInputProc (WinUAE) RPCRT4.DLL -> RpcServerInqCallAttributesW (Games for Windows Live) IPHLPAPI.DLL -> IcmpCreateFile (VirtualBox 4) IPHLPAPI.DLL -> IcmpSendEcho2 (VirtualBox 4) I probably suggested a couple of these functions in past posts, but these are mostly new ones. Again, no rush and keep up the great work! Another note on VS2008: I am still going through the files and will post another list when I am done. A version lie (reporting the OS as Windows XP SP2 or SP3) would also be required to start the setup program. Note on Games For Windows Live: I believe this also needs .NET Framework 3.0 or 4.0 as well. EDIT: Crossed out functions added in MS11-011 v5 EDIT: Crossed out functions added in MS11-020 v5
  23. I tested some XP DLLs for KB968389 support with the following results: KSECDD.SYS = No negative results, but I don't know how I can test that it is working 100% properly SCHANNEL.DLL = Works perfectly, tested it with IE6 trying to log on to a few sites (Other than the usual IE6-related glitches, they worked fine) SECUR32.DLL = Caused Task Scheduler (mstask) to crash for some reason but had no other noticeable effects WDIGEST.DLL = A new file, there should be no problems with this but I have no way to test it other than running through Dependency Walker (which showed no problems) MSV1_0.DLL needs the following APIs before any testing can even be done: ADVAPI32.DLL -> SystemFunction036 MSVCRT.DLL -> _resetstkoflw SECUR32.DLL -> CredMarshalTargetInfo SECUR32.DLL -> CredUnmarshalTargetInfo LSASRV.DLL -> LsaIGetNbAndDnsDomainNames LSASRV.DLL -> LsaIFreeHeap LSASRV.DLL -> LsaINotifyPasswordChanged EDIT: Crossed out functions added in MS11-020 v4
  24. I've been doing some poking around with Dependency Walker and my device drivers and I've noticed a few more APIs that should be added to Win2k: NTOSKRNL.EXE -> _vsnwprintf (This would let me use the Widcomm Bluetooth Stack that came with my netbook as well as the LAN and HDMI drivers for the system) NTOSKRNL.EXE -> RtlGetVersion (This would fix the AMD AHCI driver so that I could run Win2k on my main desktop with AHCI. This, an API in WIN32K.SYS and a couple KERNEL32 APIs would fix the ATI 11.x drivers) NTOSKRNL.EXE -> KeFlushQueuedDpcs (This would fix the Widcomm Bluetooth Audio Driver) KERNEL32.DLL -> ActivateActCtx (This is also needed for the Widcomm Stack) KERNEL32.DLL ->CreateActCtxA (Widcomm Stack) KERNEL32.DLL -> DeactivateActCtx (Widcomm Stack) KERNEL32.DLL -> AddVectoredExceptionHandler (ATI Driver) KERNEL32.DLL -> RemoveVectoredExceptionHandler (ATI Driver) WIN32K.SYS -> EngIsSemaphoreOwned (ATI Driver) Fixing the 2xx series nVidia drivers would require a lot more added APIs than any of the other drivers I looked at: NTOSKRNL.EXE -> DbgPrintEx ADVAPI32.DLL -> LsaLookupNames2 KERNEL32.DLL -> GetProcessId KERNEL32.DLL -> ReleaseActCtx PSAPI.DLL -> GetProcessImageFileNameW SETUPAPI.DLL -> SetupDiGetActualSectionToInstallExW SETUPAPI.DLL -> SetupUninstallOEMInfW SETUPAPI.DLL -> SetupDiGetClassRegistryPropertyW SETUPAPI.DLL -> SetupDiSetClassRegistryPropertyW WTSAPI32.DLL -> WTSQueryUserToken CRYPT32.DLL -> CryptStringToBinaryA Again this stuff would be nice, but no rush. Just figured I'd give some suggestions EDIT: Strange, According to MSDN, KeFlushQueuedDpcs was introduced in Server 2003, not XP and yet Widcomm looks for it and XP SP3 has the function... EDIT: Whoops, Accidentally looked at a Vista DLL for Widcomm 5.6 (I accidentally added a Vista ADVAPI32.DLL function to the list) EDIT: Oops Those MSVCRT Functions for the nVidia Driver were functions from Vista... (Accidentally looked at a Vista DLL again) EDIT: Crossed out functions added in MS11-011 v4 EDIT: Crossed out functions added in MS11-011 v5
  25. With the addition of two more functions, XP's SCHANNEL.DLL can be used with Win2k (I've tested it with blackwingcat's Known DLL Wrapper and it works with IE6's SSL/TLS.) The functions are: ADVAPI32.DLL -> CredIsMarshaledCredentialW KERNEL32.DLL -> GetSystemWow64DirectoryW I also tested XP's OLEAUT32.DLL and it ended up causing a script error every time I entered a system folder. (It seems to break Win2k's Web View) Edit: I just tested XP's DNSAPI.DLL and it causes the system to take an extremely long time to get to the logon screen and then logon fails with domain not found message.

×
×
  • Create New...