Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


marcusj0015

Member
  • Content Count

    150
  • Donations

    $0.00 
  • Joined

  • Last visited

Posts posted by marcusj0015


  1. I'm trying to create a silent installer for my Windows 7 theme, here's my Config.txt


    ;!@Install@!UTF-8!
    GUIMode="2"
    Path="%Windir%\Resources\Themes\"
    Progress="No"
    RunProgram="InstallUxStyle.cmd"
    ;!@InstallEnd@!

    and here's my install script.


    @ECHO OFF
    GOTO DETECT

    :DETECT
    %PROCESSOR_ARCHITECTURE%
    IF AMD64 == AMD64 GOTO AMD64 ELSE GOTO DETECT2

    :DETECT2
    %PROCESSOR_ARCHITECTURE%
    IF x86 == x86 GOTO x86 ELSE GOTO DETECT3

    :DETECT3
    %PROCESSOR_ARCHITECTURE%
    IF IA64 == IA64 GOTO IA64 ELSE GOTO END

    :AMD64
    msiexec.exe /i "%Windir%\Resources\Themes\Cloud7\UxStyle\UxStylex64.msi" /quiet
    GOTO END

    :x86
    msiexec.exe /i "%Windir%\Resources\Themes\Cloud7\UxStyle\UxStylex86.msi" /quiet
    GOTO END

    :IA64
    Sorry, your architecture isn't supported.
    GOTO END

    :END
    Exit

    I'm on Win8 atm because my win7 partition died and obviously my theme is Win7 only, so I can't test it. is this correct, and more importantly, how do I make this actually execute the scripts and programs and everything?


  2. I'm trying to create a silent installer for my Windows 7 theme, here's my Config.txt


    ;!@Install@!UTF-8!
    GUIMode="2"
    Path="%Windir%\Resources\Themes\"
    Progress="No"
    RunProgram="InstallUxStyle.cmd"
    ;!@InstallEnd@!

    and here's my install script.


    @ECHO OFF
    GOTO DETECT

    :INSTALL


    :DETECT
    %PROCESSOR_ARCHITECTURE%
    IF AMD64 GOTO AMD64
    IF x86 GOTO x86
    IF IA64 GOTO IA64

    :AMD64
    Msiexec.exe /i "%Windir%\Resources\Themes\Cloud7\UxStyle\UxStylex64.msi" /j m
    GOTO END

    :x86
    Msiexec.exe /i "%Windir%\Resources\Themes\Cloud7\UxStyle\UxStylex86.msi" /j m
    GOTO END

    :IA64
    Sorry, your architecture isn't supported.
    GOTO END

    :END
    Del "%Windir%\Resources\Themes\Cloud7\UxStyle\"
    Exit

    I'm on Win8 atm because my win7 partition died, is this correct, and more importantly, how do I make this actually execute the scripts and programs and everything?


  3. What is the Windows 7 BLB-Client? I see it in the Install wim tweak tool, and it sounds unnessacary, is it?

    and what is this?

    Display-ChangeDesktopBackground-Disabled

    and all of these?

    Common-Drivers-Package

    Client-LanguagePack-Package

    Client-Drivers

    Client-Features

    BusinessScanning

    Editions-Client-Package

    Help-CoreClientUAXX

    Links-Package

    Media-Format-Package

    MobilePC-Client

    MSMQ-Client-Package

    NFS-ClientSKU

    OfflineFiles

    PeerDist

    PeerToPeer

    Personalization

    PhotoBasic

    PhotoPremium

    Printing-Foundation

    PrintingLocalFoundation

    RasRip

    RDC

    Can I remove Group Policy?

    How about TerminalServices?


  4. I've actually just mounted the Ultimate wim, as it's less messy than extracting hundreds of files, here's my create.exe version and settings.ini contents.

    Create.exe version 1.0 copyright 2012 Daniel Just.

    ; This file is absolutely needed! Do not delete it!
    ; Adjust the paths below to their correct location
    [paths]
    ; path where the windows installation source manifest files can be found
    ; path must be absolute; no backslash at the end
    manifestPath=D:\Users\Marcus\Desktop\Remove_Componets\mount\Windows\winsxs\Manifests\

    ; path where output xml and log file should be saved
    ; path can be relative to this dir or absolute
    outputDir=D:\Users\Marcus\Desktop\Remove_Componets\Logs\

    ; path to registry hives
    ; path must be absolute; keep last backslash
    regHivePath=D:\Users\Marcus\Desktop\Remove_Componets\mount\Windows\System32\config\

    ; path to installation sources
    ; path must be absolute; keep last backslash
    sources=D:\Users\Marcus\Desktop\Remove_Componets\mount\


  5. Nice thread, I was looking through the XMLs earlier when it didn't work and was manually doing it myself (OMG that's mind numbling boring and tedious) and I noticed that they weren't listed alpphabetically, could you make them alphabetical?

    The xml files have the type of component before the name of the components to be removed in the default xml filenames. For example, accessories_notepad.xml or drivers_modems.xml. This should automatically be sorted alphabetically. Also, what doesn't work? What were you doing manually?

    I don't remember what I was doing back then, but I'm trying it again, adn this time it's saying that libexpat-1_.dll can't be found, and it's right next to create.exe, and I've also copied it to the System32 folder and treid registering it, and it doesn't work, and I've also got Strawberry PErl installed (at C:\Perl instead of the default location) becasue I was trying to hack my iPhone with a perl script I found on the web lol. anyway, I tried copying C:\Perl to C:\strawberry\Perl, because that's where it expected it, and it's still not working.

    ~Edit~

    I AM using the x64 version of Strawberry Perl though, could that be the problem?

    ~Edit2~

    I'm having all kinds of permissions issues with Windows, I'll probably have to reinstall.

×
×
  • Create New...