Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


bdwilcox

Member
  • Content Count

    9
  • Donations

    $0.00 
  • Joined

  • Last visited

Community Reputation

0 Neutral

About bdwilcox

  1. I've confirmed that b2e.dll is, in fact, created in the Temp folder during install if WinPE Builder.
  2. Under AVG Free v8, the install of WinPE Builder errors out and AVG then detects the B2e.dll file in the Temp folder as TrojanHorse BackDoor.SmallX.VX
  3. Woohoo! Nailed it. My settings in Windows were correct, but my settings in Nero Burning ROM were off. After that tip-off from cdob and a little experimentation, I figured out that I had to set Nero to burn in the ISO 9660+Joliet "File System" and the ASCII "Character set (ISO)" on Nero's "ISO" tab. Otherwise, either the dollar signs in the $OEM$ directory name were changed to underscores, the spaces in file/directory names were changed to underscores, or the Joliet file system was omitted completely. It works now and works well. And it wasn't Microsoft's fault...shocking! So cdob, thank you very much for all the help and pointing me in the right direction. Major kudos to you, sir! krose, thanks for the tip. I would have tried it next if this didn't work, but was a little leery since it wasn't officially Microsoft sanctioned. SyntaxError, yeah I was kind of shocked by how much nLite tinkered with. I might use it for my own personal work, but not for sensitive installs. Thanks all -bd
  4. Interestingly, I just tested a number of Nero configurations for CDs containing folder names with dollar signs ("$") and filenames with spaces. At the root of the CD I used a file called Office 2003 Updates.txt. I then created an $OEM$ folder and added the same file. Here's my results: These tests were conducted on Nero Burning ROM version 6.6.1.115d. Data Mode was set on Mode 1 for all tests. File Name Length (ISO) was always set on Max. of 31 chars (Level 2) when the box was ungreyed. Any ungreyed "Relax Restrictions" checkboxes were checked. File System: ISO 9660 only Character Set: ISO 9660 (Standard ISO CD-ROM) Results: ISO File System Only (No Joliet), "$"s changed to "_"s, and spaces in file names changed to "_"s. File System: ISO 9660 only Character Set: DOS Results: ISO File System Only (No Joliet), "$"s remain intact, but spaces in file names changed to "_"s. File System: ISO 9660 only Character Set: ASCII Results: ISO File System Only (No Joliet), "$"s and spaces in file names unchanged and intact. File System: ISO 9660+Joliet Character Set: ISO 9660 (Standard ISO CD-ROM) Results: For ISO File System, "$"s changed to "_"s, and spaces in file names changed to "_"s. For Joliet File System, "$"s retained intact and spaces in file names untouched. File System: ISO 9660+Joliet Character Set: DOS Results: For ISO File System, "$"s left intact, but spaces in file names changed to "_"s. For Joliet File System, "$"s retained intact and spaces in file names untouched. File System: ISO 9660+Joliet Character Set: ASCII Results: For ISO File System, "$"s retained intact and spaces in file names untouched. For Joliet File System, "$"s retained intact and spaces in file names untouched. File System: ISO 9660:1999 Character Set: Greyed Out Results: For ISO File System, "$"s and spaces in file names unchanged and intact. Joliet file system not present. Seems like the only Nero Burning ROM settings that won't tinker with dollar signs ("$") and spaces in filenames and foldernames for both the ISO and Joliet File systems is a "File System" set at "ISO 9660+Joliet" and a "Character Set (ISO)" set on"ASCII" . I'll try these out when I get home.
  5. To cdob, To make the CD I used the following steps: I used ISOBuster to extract the Microsoft Corporation.img file. I then used Nero Burning Rom version 6.6.1.115d with the following settings to burn the XP files to a CD: On the Boot tab of Nero Burning ROM: -"Image File" is pointed to the Microsoft Corporation.img file -Under Expert Settings, Emulation is set to No Emulation, Load Segement of Sectors is set to 07C0, and Number of Loaded Sectors is set to 4 On the ISO tab of Nero Burning ROM: -Data Mode is set to Mode 1 -File System is set to ISO 9660: 1999 since this is the only one that would allow "$" to show up instead of "_" when I looked at the final CD under ISOBuster. After selecting this setting, every option becomes greyed out except the "Allow more than 255 characters in path". So let me tell you what I tried. I tried the above settings with the "Allow more than 255 characters in path" both checked and unchecked. It still failed. I then tried changing the the File System from ISO 9660: 1999 to both ISO 9660 and ISO 9660+Joliet. With both I set "File Name Length (ISO)" to "Max. of 31 chars (Level 2)". I left "Character Set (ISO)" on ISO 9660 (standard ISO CD-ROM). All ungreyed "Relax Restrictions" checkboxes were also selected. All of these attempts failed. What settings in Nero should I be using? Or should I be using something other than Nero or a different version of Nero to burn the final CD?
  6. nLite adds a lot more than what you're showing. I used CDCheck to do a comparison between the XP source files and XP with the slipstreamed nLite driver; nLite changed a whole host of source files as well as installing a custom executable helper file. Microsoft's method is simple, but unfortunately it's also broken (as usual). I guess at this point I shouldn't really be surprised by that, coming from Microsoft and all. These machines are being loaded for government certification and compliance. I can't let any non-official Microsoft process run on them, especially one I'm not aware of and can't document. Oh, well, it was worth a try. Thanks anyway. -bw
  7. Will look tonight when I get home and report back.
  8. Actually, my method is the Microsoft prescribed method (see Microsoft's Deploy.chm) and is the simplest of all the methods described on these boards. The reason I don't want to use nLite is that this is a business build that I will be 100% responsible for and I need to know all the changes made to the installation folders; nLite makes undocumented changes which I can't have with such an important build.
  9. I was hoping someone on this board could help me with slipstreaming Intel's latest Matrix Storage driver into an unattended XP install CD. I am looking to slipstream the files as TEXTMODE drivers, which should make the task easier. Unfortunately, all efforts to do this so far have resulted in failure. First, before I tried anything, I slipstreamed SP3 into XP, copied my WINNT.SIF file to the I386 directory of the CD, and created a bootable XP unattended install disk that works like a charm. So I know the basic disk works. Second, I modified this base XP install CD as such: -At the root of the CD I created a directory called $OEM$ and then created a folder within that called TEXTMODE. Inside this $OEM$\TEXTMODE folder I copied the files from Intel's latest Matrix Storage F6 floppy driver (f6flpy3286.zip): http://downloadcenter.intel.com/Detail_Des...amp;PrdMap=2842 TXTSETUP.OEM iaahci.cat iaAHCI.inf iastor.cat iaStor.inf IaStor.sys -In the I386 directory of the CD, I created a folder called $OEM$ and once again, copied the contents of Intel's latest F6 floppy (f6flpy3286.zip). Note: So I now have two directories that hold the contents of Intel's latest F6 floppy: $OEM$\TEXTMODE and I386\$OEM$ -Then I modified the WINNT.SIF by changing the line OEMPreinstall=NO to OEMPreinstall=YES -Finally, I added the [MassStorageDrivers]* and [OEMBootFiles] sections to the WINNT.SIF as below: [MassStorageDrivers] "Intel(R) ESB2 SATA AHCI Controller" = OEM "Intel(R) ICH7R/DH SATA AHCI Controller" = OEM "Intel(R) ICH7M/MDH SATA AHCI Controller" = OEM "Intel(R) ICH8R/DH/DO SATA AHCI Controller" = OEM "Intel(R) ICH8M-E/M SATA AHCI Controller" = OEM "Intel(R) ICH9R/DO/DH SATA AHCI Controller" = OEM "Intel(R) ICH9M-E/M SATA AHCI Controller" = OEM "Intel(R) ICH10D/DO SATA AHCI Controller" = OEM "Intel(R) ICH10R SATA AHCI Controller" = OEM "Intel(R) ESB2 SATA RAID Controller" = OEM "Intel(R) ICH7R/DH SATA RAID Controller" = OEM "Intel(R) ICH7MDH SATA RAID Controller" = OEM "Intel(R) ICH8R/ICH9R/ICH10R/DO SATA RAID Controller" = OEM "Intel(R) ICH8M-E/ICH9M-E SATA RAID Controller" = OEM "IDE CD-ROM (ATAPI 1.2)/PCI IDE Controller" = "RETAIL" [OEMBootFiles] TXTSETUP.OEM iaahci.cat iaAHCI.inf iastor.cat iaStor.inf IaStor.sys *The OEM entries under [MassStorageDrivers] came from the [sCSI] section of the TXTSETUP.OEM file. -After all this, I make a bootable CD like before and test it. Now, technically, this should work. But each time I've tried it, I get the following error during XP's TEXTMODE setup period: File TXTSETUP.OEM caused an unexpected error (18) at line 1747 in d:\xpsp\base\boot\setup\oemdisk.c. Does anyone know what needs to be modified to get this to work? I'd rather not use a program like nLite since it makes changes I'm not aware of and I would like to keep this as simple and straightforward as possible.
×
×
  • Create New...