Jump to content

THXTEX

Member
  • Posts

    12
  • Joined

  • Last visited

  • Donations

    $0.00 
  • Country

    Denmark

Everything posted by THXTEX

  1. Could you check if the tweaks that disappears are CURRENT_USER reg-settings? Probably they are set on the "Administrator" account and not the one you log into.
  2. Thanks for both your answers.... OemFilesPath = "A:\" - Haven't tried this one. Will do it later today. OemFilesPath = "A:\myfiles" - I tried with OemFilesPath = "A:\$OEM$" and this didn't work. OemPreinstall = Yes - Tried this one aswell without success. Shouldn't this only be set to Yes when you need to copy files from your CD to the systemdrive? Anyway - I have another floppysetup with a winnt.sif which is simular to the one above, but with this part added. [MassStorageDrivers] "Intel(R) 82801ER SATA RAID Controller" = OEM [OEMBootFiles] Txtsetup.oem iaStor.inf iaStor.sys iaStor.cat The drivers are placed on the rootlevel of the floppy and this works perfectly, bit only if OemPreinstall is set to No. Maybe this can help.
  3. Nope, it didn't work. I was thinking.... are files at this place limited to 8.3? BTW: This is my winnt.sif ;SetupMgrTag [Data] AutomaticUpdates = Yes AutoPartition = 0 MsDosInitiated = 0 UnattendedInstall = Yes [Unattended] UnattendSwitch = Yes UnattendMode = FullUnattended OemFilesPath = "A:" OemSkipEula = Yes OemPreinstall = No TargetPath = \Windows ProgramFilesDir = "C:\Programmer" Repartition = No WaitForReboot = No AutoActivate = No Hibernation = No Filesystem = LeaveAlone KeyboardLayout = Danish [GuiUnattended] DetachedProgram = "a:\OEM.exe" ; WinRAR sfx that extracts some files to %systemdrive%\oem\ ; executed in [GuiRunOnce] AdminPassword = "************" EncryptedAdminPassword = No AutoLogon = Yes AutoLogonCount = 1 OEMSkipRegional = 1 TimeZone = 105 OemSkipWelcome = 1 ProfilesDir = "%SystemDrive%\Documents and Settings\" [UserData] ProductKey = "*****-*****-*****-*****" FullName = "****** *****" OrgName = "*******" ComputerName = ******** [Display] BitsPerPel = 32 Vrefresh = 85 Xresolution = 800 Yresolution = 600 [TapiLocation] CountryCode = 45 [Identification] JoinWorkgroup = Arbejdsgruppe [Components] ... ... [Shell] DefaultStartPanelOff = Yes DefaultThemesOff = Yes [Networking] InstallDefaultComponents=No [NetAdapters] Adapter1=params.Adapter1 [params.Adapter1] INFID=* [NetClients] MS_MSClient=params.MS_MSClient [NetServices] MS_SERVER=params.MS_SERVER [NetProtocols] MS_TCPIP=params.MS_TCPIP [params.MS_TCPIP] DNS=No UseDomainNameDevolution=No EnableLMHosts=Yes AdapterSections=params.MS_TCPIP.Adapter1 [params.MS_TCPIP.Adapter1] SpecificTo=Adapter1 DHCP=No IPAddress=192.168.0.22 SubnetMask=255.255.255.0 DefaultGateway=192.168.0.1 DNSServerSearchOrder=***.***.***.***,***.***.***.*** WINS=No NetBIOSOptions=0 [Branding] BrandIEUsingUnattended=Yes [URL] Home_Page=http://www.newz.dk Search_Page=http://www.google.com [GuiRunOnce] Command0 = %SystemDrive%\OEM\RunOnce.bat
  4. Thanks, I'll try that when I get home and report back here.
  5. Ups, you are right about that. I need to make reg-tweaks to the default profile, so these must be made at before guirunonce. I have a self-extracting WinRAR archive that extracts to %systemdrive%/OEM, which is run from presetupcmd. The SFX afterwards calls the AutoIT script that installs drivers. So basicly i could put the "cmdlines.txt" in this directory aswell. But I don't think that the installer sees this as the $OEM$ folder. (Maybe $OEM$ isn't used when using a floppy).
  6. Hi I'm trying to use a vanilla XP an a floppy with a winnt.sif. Where should I place cmdlines.txt so it get's executed when doing a installation.
  7. Still no succes in my case. I have tried a different approach now. I still extract my drivers using DetachedProgram and they are still a WinRAR sfx-archive. But in the SFX comment's I have added Pyron's SetDevicePath command. ;The comment below contains SFX script commands Path=%systemdrive%\OEM SavePath Silent=2 Overwrite=1 Setup=SetDevicePath.exe %SYSTEMDRIVE%\OEM\Drivers In setupapi.log I now see that setup looks in my driverfolder, but it comes with the following message. In danish.... #I393 Cachen "C:\OEM\Drivers\Chipset\SP\INFCACHE.1" til INF-filer er ændret. #I393 Cachen "C:\OEM\Drivers\Chipset\INFCACHE.1" til INF-filer er ændret. #I393 Cachen "C:\OEM\Drivers\Lan\INFCACHE.1" til INF-filer er ændret. Transladet to english it is something like..... #I393 Cache "C:\OEM\Drivers\Chipset\SP\INFCACHE.1" for INF-files has changed. #I393 Cache "C:\OEM\Drivers\Chipset\INFCACHE.1" for INF-files has changed. #I393 Cache "C:\OEM\Drivers\Lan\INFCACHE.1" for INF-files has changed. The INFCACHE files are not a part of the archive. Any suggestions to what I could try now? TIA
  8. I can see in the log, that it can not find any drivers that are compatible. I think that it does not look in C:/Drivers/XXX where my drivers are installed at all.
  9. I can install them afterwards without any warning, so they must be. I have tried yout other suggestion with removeing %SYSTEMDRIVE%, but it doesn't work. Is there a log I could look in to see if tries to install my drivers?
  10. Any idea of what I might being doing wrong?
  11. Hi I'm quite new at this and have trouble getting some drivers installed. I want to be able to use a nonmodified Windows CD, a floppy with winnt.sif and some drivers. I have a driver package (WinRAR) which are uncompressed during setup to C:\drivers\. The files are extracted without any problems. But they are not installed. This is my winnt.sif ;SetupMgrTag [Data] AutomaticUpdates=yes AutoPartition=1 MsDosInitiated="0" UnattendedInstall="Yes" [Unattended] DUDisable = Yes UnattendMode=FullUnattended OemSkipEula=Yes OemPreinstall=Yes OemPnPDriversPath="%SYSTEMDRIVE%\Drivers\Chipset;%SYSTEMDRIVE%\Drivers\Lan" NonDriverSigningPolicy = "Ignore" DriverSigningPolicy=Ignore TargetPath=\WINDOWS Repartition=No UnattendSwitch="yes" WaitForReboot="No" AutoActivate = No ProgramFilesDir="C:\Programmer" CommonProgramFilesDir="C:\Programmer\Common Files" Hibernation = No Filesystem = LeaveAlone [GuiUnattended] AdminPassword="***********" EncryptedAdminPassword=NO AutoLogon = Yes OEMSkipRegional=1 TimeZone=105 OemSkipWelcome=1 ProfilesDir="%SYSTEMDRIVE%\Documents and Settings\" DetachedProgram="a:\Drivers.exe" [UserData] ProductKey=*****-*****-*****-*****-***** FullName="***** *****" OrgName="********" ComputerName=Pentium4 [Display] BitsPerPel = 24 Vrefresh = 75 Xresolution = 1024 Yresolution = 768 [TapiLocation] CountryCode=45 [Identification] JoinWorkgroup=Arbejdsgruppe [Components] AccessOpt = On ..... Zonegames = Off [Shell] DefaultStartPanelOff = Yes DefaultThemesOff = Yes [Networking] InstallDefaultComponents=No [NetAdapters] Adapter1=params.Adapter1 [params.Adapter1] INFID=* [NetClients] MS_MSClient=params.MS_MSClient [NetServices] MS_SERVER=params.MS_SERVER [NetProtocols] MS_TCPIP=params.MS_TCPIP [params.MS_TCPIP] DNS=No UseDomainNameDevolution=No EnableLMHosts=Yes AdapterSections=params.MS_TCPIP.Adapter1 [params.MS_TCPIP.Adapter1] SpecificTo=Adapter1 DHCP=No IPAddress=192.168.1.11 SubnetMask=255.255.255.0 DefaultGateway=192.168.1.1 DNSServerSearchOrder=193.162.153.164,194.239.134.83 WINS=No NetBIOSOptions=0 [Branding] BrandIEUsingUnattended=Yes [URL] Home_Page=http://www.newz.dk Search_Page=http://www.google.com [GuiRunOnce] Command0=a:\RunOnce.bat If it is of any help. The system i want to install on is a 875 chipset.
  12. Hi Just found yor thread. And yes there are other people out there with the same problem. I'm quite new at this unattended stuff and are currently just experimenting. I would like to fix the size of the swapfile, maybe you can help me here. Thanks in advance.


×
×
  • Create New...