Jump to content

DMD61

Member
  • Posts

    52
  • Joined

  • Last visited

  • Donations

    0.00 USD 
  • Country

    Italy

Everything posted by DMD61

  1. Thanks for the information. But I found the cause of the problem and the solution. Since a few days ago to save the number of usb sticks, I created the bootable usb stick not as I used to do with RUFUS but with Ventoy so that I can insert more ISOs of operating systems and tools. And it is just the usb stick created with Ventoy that does not allow me to run RunOnceEx, the usb stick created with Rufus works without problems. To solve definitavemene the problem with multiboot software like Ventoy in this way: I found the script solution to make the RunOnceEx procedure work on Ventoy as well. It involves synthesizing the "Software" folder in the Windows directoty and then when the Windows installation is finished, when you enter the user name via the registry the programs in the "Software" folder are installed and when it finishes all the installations, the "Software" folder is deleted. Setupcomplete @echo off SET CDROM=%WINDIR%\Setup REG ADD HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnceEx SET KEY=HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnceEx REG ADD %KEY% /v Flags /t REG_DWORD /d "20" /f REG ADD %KEY% /V Title /D "Post Installation..." /f >NUL REG ADD %KEY%\06 /VE /D "Calcolatrice Legacy" /f >NUL REG ADD %KEY%\06 /V 1 /D "%CDROM%\Software\Calcolatrice_Legacy_2.0.exe" /f >NUL REG ADD %KEY%\42 /VE /D "Deleting Setup folder" /f >NUL REG ADD %KEY%\42 /V 1 /D "%CDROM%\Software\Deleting_Setup_folder.bat" /f >NUL EXIT Deleting_Setup_folder echo off cls rem -----Deleting_Setup_folder-------- rd "%windir%\Setup" /S /Q exit
  2. Good morning. I am struggling with a strange RunOnceEx situation. I have been using this procedure for years from W7 up to W11 22H2 and it works regularly on both HOST PC and virtual machine, but these days an unexplainable thing happens to me. When I run this procedure on a newly built pc with Ryzen 9 7950X and still running W11 22H2, the RunOceEx does not run, when I try the same ISO with RunOnceEx on another PC or virtual machine it runs. I have been going crazy for a few days and can't figure out why and don't know what solution to look for. Any ideas? This is the "setupcomplete.cmd" script that I have always uitilized. Sincerely thank you
  3. Good morning. For a few months, I have been testing on a virtual machine to integrate some tools into the ISO of Windows (W10 V20H2) using the former runonce procedure used for years, but I can't make it run, I checked the scripts and they are all ok. Then to not waste time to install the ISO every time to see if it is executed directly the "setupcomplete.cmd" script directly and the log key is created with the launch programs in the path "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnceEX". But when the system restarts the programs are not executed. Some idea? Cordially thank you
  4. This is the structure normally used that it works with the install.wim
  5. Good morning The procedure RunOnceEx runs smoothly, integrated in ISO of Windows 10, however, I noticed a problem. If in ISO is the install.wim file everything works regularly, but if I convert that file into .esd format to decrease the size, Runonce system no longer works and can not figure out why. Perhaps with install.esd files this procedure is not supported? Sincerely thank you
  6. This is true, also works in the main route %homedrive%. The path %localappdata% good for the installer directly and also allows the uninstall, as it is a hidden folder. If it is done manually, as in my case, I have to enable the display of hidden folders. Thanks for your interest
  7. Good morning For years, I delight in creating small self-extracting files for free programs, and I would like to understand why what I can do normally in W7 I no longer possible in W10. If the example is copied in "C:\Program Files (x86)" folder full of JDowloader complete executable. If this is done manually, everything works perfectly. If I create a self-extracting file with WinRAR, when I launch the executable returns an error to some files in it. The same self-extracting file installed on W7 works without problems, what I think is that in W10 is not allowed under the "Program Files (x86)" and the like, the automatic extraction of some files. Perhaps because they changed the management in terms of safety. Is there any command or script to insert different procedure? Sincerely thank you
  8. Good morning I want to create an ISO of W10 removing apps that are unnecessary. For example if I want to delete Get Office just run a powershell command like this: powershell "Get-AppxPackage -allusers *officehub* | Remove-AppxPackage" > NUL 2>&1 This command then I insert it in a batch file @echo off powershell "Get-AppxPackage -allusers *officehub* | Remove-AppxPackage" > NUL 2>&1 exit This command then I insert it into a batch file (Delete_GetOffice.bat) This file is placed in the "Software" folder in the root of the ISO of Windows 10 Then I created the file Setupcomplete.cmd @echo off for %%w IN (D E F G H I J K L M N O P Q R S T U V W X Y Z) DO IF EXIST %%w:\sources\install.wim SET CDROM=%%w: REG ADD HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnceEx SET KEY=HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnceEx REG ADD %KEY% /v Flags /t REG_DWORD /d "20" /f REG ADD %KEY% /V Title /D "Post Installation..." /f >NUL REG ADD %KEY%\01 /VE /D "Delete_GetOffice" /f >NUL REG ADD %KEY%\01 /V 1 /D "%CDROM%\Software\Delete_GetOffice.bat" /f >NUL exit and inserted in ISO of Windows 10 During the nstallation RunOnce runs normally and Powershell command brings up a notice of elimination the App. But when I open the start menu appears GetOffice yet. To be sure that the command is correct, you copy the batch file on the desktop and launch the app GetOffice is eliminated normally. I do not understand why so run Once the app is not deleted, mistake in the procedure? Thank you
  9. I thought this was possible, for example by inserting a registry key or a script bat, simulating the update installed, so that they may believe that Windows update is installed and does not do more to appear in search.
  10. Good morning. And 'possible to believe that a Windows Update determitato update appears already installed? Why it is not detected in the scanning of Windows Update. Thank you
  11. Good evening Excuse me for the mistakes I'm using google translator I would use the instrallazione in sequence of the various software via RunOnceEX from external support as I used without problems in Windows 7. In Windows 8.1 when launching the file "RunOnceEx.cmd" I get the access denied message, due to the permissions of an administrator. Also, the launch of the self-extracting files they need the permission of the administrator, this happens even with UAC disabled. This is the script that I use as a test: @Echo OffSET PP=E:\Test_RunOnce\Progetto\Applicazioni_RunOnceREG ADD HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnceEx /fSET KEY=HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnceExREG ADD %KEY% /v Flags /t REG_DWORD /d "20" /fREG ADD %KEY% /V TITLE /D "Software Aggiuntivo" /fREG ADD %KEY%\0002 /VE /D "Installazione Programmi..." /fREG ADD %KEY%\0080 /V 1 /D "%PP%\0080_7-Zip_9.20.exe" /fREG ADD %KEY%\0940 /V 1 /D "%PP%\0940_FastStone_Viewer_5.1.exe" /fREG ADD %KEY%\3030 /V 1 /D "%PP%\3030_Restart.cmd" /fpauseENDLOCALEXITAnd 'possible to solve this problem or do I adopt another procedure? Sincerely thank
  12. However, I have my doubts about the slipstreamer RT7Lite, ISO created is not like that of msdn W7 + sp1. Maybe I'm wrong, I think the integration of SP1 can not disable or uninstall all the features.
  13. Integrating Sp1 Not Is Properly Carrying out the integration via slipstreamer RT7Lite with, and checked with the Microsoft Update KB947821 I find the patch, which takes about 10 minutes to install!! By comparison with the ISO original W7+SP1, the patch KB947821 is not detected by Microsoft Update. Greetings
  14. I beg your pardon. The answer was: "With RT7Lite not know if this can be a problem"
  15. [italian] Con RT7Lite, non so se questo può essere un problema [/italian]
  16. Good morning. I have a problem. I made the SP1 integration, and testing with the Microsoft Update KB947821 I found the patch I thought to integrate this patch with 7Customizer, but it is not integrated. You can fix this? THANKS
  17. I wanted to create a copy of Windows 7 SP1 unattended with the Occasion of the SP1 release, and I thought to integrate via Slipstreamer RT7Lite with getting a new ISO. Then install the new ISO containing the SP1 I check it through the Microsoft Update, the patches that those remaining after SP1. Once downloaded individually, I created the ISO with RT7 Lite integrating the patches the MU I had reported earlier. At the final assessment of Micorsoft Update, KB947821 tells me the updates to be done between, you can solve this integration problem? Thanks
  18. I kindly ask, how does Update Windows6.1-kb976902-x86.cab with RT7Lite 2.60? if you can not make it executable as a normal patch? Thanks
  19. Error message when loading image loading. The error message that warns: "A device connected to the system is not working" This is a message that I never appeared in previous relase. How can I fix it? THANKS
  20. Good evening. I wanted to ask if there is a tweak to remove the symbol from the icons UAC. Thanks
  21. I no longer update the clock, what can have happened? The message tells me: "Insufficient permissions to perform activities Contact the administrator of the computer" I'm already an administrator, I do not understand !! THANKS
  22. I can not understand why 3 files are skipped cache. THANKS ..... 2010-05-12 23:05:26 : ########## <ERROR #1> C:\Program Files\Common Files\Windows Live\.cache\9ba31cc61ca2b46\dw20shared.msi was not found. Skipping MSI <ERROR #1> ########## ..... 2010-05-12 23:05:26 : ########## <ERROR #2> C:\Program Files\Common Files\Windows Live\.cache\a0496aca1ca2b46\crt.msi was not found. Skipping MSI <ERROR #2> ########## ...... Live\.cache\ac3d38ba1ca2b46\WLXSuite.msi was not found. Skipping MSI <ERROR #3> ########## ...... 2010-05-12 23:05:26 : ########## <ERROR #4> C:\Program Files\Common Files\Windows Live\.cache\c6ff490f1ca2b46\Messenger.msi was not found. Skipping MSI <ERROR #4> ########## .....
  23. You can improve the function of post-installed applications? The only detail that can be corrected is to ensure that the procedure ends when you stop during post install, to make this faster installations by avoiding the unnecessary prompt. THANKS


×
×
  • Create New...