Jump to content

Swarvey

Member
  • Posts

    27
  • Joined

  • Last visited

  • Donations

    $0.00 

About Swarvey

Contact Methods

  • Website URL
    http://mywebsite.bigpond.com/codex.mclean
  • Yahoo
    one_swarve_mothafuka

Swarvey's Achievements

0

Reputation

  1. Maybe try without the /i and /q commands first to see if the installer you have, has the option to choose the ENG language, or at the very least what language is chosen by "default" /i command uses default values, which is probably why your regional settings are taking preference language wise (remember the apps are still installed via MSIEXEC.EXE) Also, your command switches show that your telling it to only include the English language, sounds to me like the installer is using your regional settings as a default value, then your switches are removing everything except english language, perhaps the installer is tripping over and failing to actually install anything? The installer is probably going thru this: 1. /i switch -> Install Nero with default system language eg.korean 2. INCLANGUAGES="ENG" -> tells the installer to not include anything but an ENG language pack 3. which equals -> Korean install, minus Korean language = faulty app This would end up making a Nero App folder, which has been told it's Korean, but does not have the Korean language pack, which means the programs will be trying to load a Korean app but failing, as the INCLANGUAGES="ENG" switch has removed the Korean language packs I'm not sure if this rings true, but in my warped li'l brain it's a possibility
  2. Nero 9 Completely Silent & Unattended - The Easy Way Step 1. Extract / Stooge / Accquire the install folders (unit_app_#) etc (easiest way is to start the downloaded installer, then open My Computer, navigate to your TEMP folder, open the NERO.TMP folder and you'll see it there, if you don't see the UNIT_APP_## folders, you're in the wrong place, otherwise copy ALL The files and folders you see into another folder Step 2. Identify and remove any UNIT_APP_## folders you don't need (that's right just delete the folders for the apps you don't use, don't edit them out of the XML or anything) Step 3. Edit the file SETUP.XML so your product key apppears between <Prop id="SerialNumber"> and </Prop> Step 4. Write yourself a batch file to run SETUPX.EXE /qb EULAACCEPTED="1" This is exactly how I did my completely unattended install. My install folder is now no more than 480Mb (about half the size of the original, and will fit on a CD) Below is an example of what a trimmed, unattended install folder should look like. The one below installs Nero Burning ROM, Nero Vision, Nero Wave Editor and Nero Cover Designer. Deleting the other folders seems to be OK as the SETUP.XML file is only parsed by the installer and compared to available packages. If they're not there, it just doesn't display them. Also, in the codebox, you will see the file "Activation.REG". This is nothing more than my product keys which I have exported from the registry (HKLM\SOFTWARE\WOW6432NODE\NERO\SHARED\NL9). The .REG file is then imported to the registry upon launching the SETUP.BAT file which I mentioned earlier. Directory of B:\Installation Sources\Nero 9 Activation.reg ipclog.exe SETUP.BAT setup.xml setupx.exe <DIR> unit_app_16 <DIR> unit_app_17 <DIR> unit_app_30 <DIR> unit_app_4 <DIR> unit_app_5 <DIR> unit_app_61 <DIR> unit_app_69 <DIR> unit_tpi_directx-9c-redist-d3dx9-30 <DIR> unit_tpi_imagxpress-7.0.74.0 <DIR> unit_tpi_lightscribe-1.14.17.1 <DIR> unit_tpi_msxml-4 <DIR> unit_tpi_vcredist-x86-2005Sp1 <DIR> unit_tpi_windows-installer-3.1 Below is a list of the UNIT_APP_## folders and their relative components as per MY downloaded installer unit_app_4 Nero Burning ROM unit_app_5 Cover Designer unit_app_6 Nero Express unit_app_10 Photosnap unit_app_12 Nero Recode unit_app_13 Showtime unit_app_14 SoundTrax unit_app_15 StartSmart unit_app_16 Nero Vision unit_app_17 Wave Editor unit_app_19 Drive Speed unit_app_20 Infotool unit_app_21 Rescue Agent unit_app_50 Disk Copy Gadget unit_app_57 unit_app_64 Movie Templates unit_app_71 Nero Live unit_app_30 [b]is essential, do not delete it[/b] (it might be safer to leave everything else that isn't an identified app package in the install folder, or you might screw things up. You will also see some UNIT folders with HLP in the folder name, these are no more than Help files and documentation for the apps, delete these as well if you don't need them. To trim the fat down even more, it appears you can safely remove the other languages from inside each of the UNIT_APP_## folders, i left nothing but ENG files in mine. Kudos to everyone from this thread, with all your inputs it only took me an hour to sort this out for myself (slow I know) but no one else seemed to be looking at the bigger picture of trimming and admin-installing, but here's the whole hock. Nero 9 with 55% reduced fat!
  3. Swarvey

    Possible Bug

    Cool thanks, i'm so dumb, i shoulda thought o that, sorry for wasting space on the forum guys LOL
  4. Swarvey

    Possible Bug

    Hi Guys, Straight to the point, every disk I've nLited and burned has been 99.99% functional. The 0.01% is a minor bug I've seen in each release of nLite since about the time of the arrival of SP3, I can't remember which build of nLite it started with as I constantly re-download and install the latest version every time i nLite. The bug is as follows: Select Brisbane GMT +10 in time zones under the Unattended installation section Install nLited XP with no problems Time zone ALWAYS seems to "default" to Kabul time Am currently having to manually re-adjust the time zone to Brisbane +10 after each install This bug absolutely pales in comparison to the almighty AWESOMENESS that is nLite so keep up the good work Nuhi Following scenarios tested after setting Brisbane +10 hrs in Unattended nLite under Vista Ultimate x64 = Kabul time zone nLite under WinXP Pro = Kabul time zone nLite under WinXP Pro, in MS VirtualPC 2007, under Vista Ultimate x64 = Kabul time zone
  5. Problem Solved!!! for me anyway.... Everything I tried failed, my RTM simply cannot accept an integration of SP3. You name it I tried it. So what did I do? I borrowed my friends XP Professional SP2 retail disk, integrated SP3 via command line in Vista, then nLited with the same SP3 preset i made for all my other disks. And Voila! instant, working, SP3 integrated XP disk. Can integrate key to installation or install without a key and use either OOBE activation or Microsoft key changer (from Windows Genuine website) to update to your key. Funny thing tho, even my Home Edition RTM SP0 accepted the integration.... *command to integrate: [extracted SP3 path]\i386\update\update.exe -s:[xp source path] eg: c:\SP3\i386\update\update.exe -s:C:\nLite\WinXPPro * Vista command prompt shortcut: goto the folder where you want to start your command prompt, eg, C:\nLite\WinXPPro, hold SHIFT on your keyboard, Right Click in blank area, choose Open Command Window Here
  6. just a quick question... did you install the drivers for the floppy disk only? or did you set up the Floppy Disk Controller(s) as well?
  7. Command-line slipstream failed as well, still can't enter any keys (legit or not), can't do anything with it. A thought comes to mind, I did download my SP3 from the WU Catalogue, guess I (and maybe some other people) got a version that's simply NOT meant to be integrated..... X86-en-windowsxp-kb936929-sp3-x86-enu_c81472f7eeea2eca421e116cd4c03e2300ebfde4.exe File Description: Self-Extracting Cabinet Type: Application File Version: 6.2.29.0 Product Name: Microsoft Windows Operating System Product Version: 6.2.0029.0 Size: 316Mb Date downloaded (From WU Catalogue) 25-04-2008 Language: English (United States) Host for command-line slipstream was Windows XP Pro SP2 running in MS Virtual PC 2007
  8. The following actions were taken on the hosts below *Downloaded 1.4.5.5 *Installed 1.4.5.5 *nLite'd SP2 (latest build I could get from MS website) into XP RTM SP0 *nLite'd SP3 (final from MS website) into above SP2 nLite'd disk still not recognizing any keys (legit or not), or allowing to leave the field blank Host machine 1: Vista Ultimate x64 SP1 Host machine 2: Vista Ultimate x64 SP1 - nLite running in compatibility mode for XP SP2 Host machine 3: Windows XP Pro SP3 (non-integrated) - running in MS Virtual PC 2007 x64 (only XP machine i really use is a virtual one LOL) about to try command-line slipstream for SP3 directly onto RTM image then re-nLite it will keep you posted
  9. ok ok ok, here's $20, go buy a clue instead of flooding your OWN THREAD with messages, and here's another $160 to learn English Gramar. See? that's $180 Australian dollars that i could have donated to the forums, instead noooo, i had a few beers and saw this thread \:|
  10. You mentioned that you're trying to "upgrade" the laptops. Do you mean you're doing a repair install? Do the laptops already have Windows installed?. This problem usually pops up when certain CD/DVD burning software alters the registry, you may or may not have heard of the "upper filters" and "lower filters" sections. Disk authoring software alters these files and shreds whenever you try to run an XP installation. You need to modify the registry to remove these entries and windows should then go through just fine. The following link may not be 100% true to your bug, but in the past has given me the resolution to several PC's and laptops that wouldnt' do a simple repair install. http://support.microsoft.com/kb/311755/en-us The link shows you where in the registry the bugs are and how to fix them. Otherwise, try doing a clean install from your nLite disk LOL Dammit, i should learn to read, then learn to re-read, i just saw you mentioned that you weren't even getting to the format drive part, yup something was definately stopping your system from reading the disk, I wonder if it's possible that even in TXT-mode, setup still reads the existing registry for the disk :-?
  11. The answer is then simple. Create a source, integrate SP2, label it as a SAFE source on your drive, create a copy of that source anytime you wish to nLite it. It would seem not that many people are too familiar with the "presets" for nLite. Eg. I've nLited SP2, then used that source to work from. I then use every section of nLite to tweak the install the way I want it. BUT every step of the way, i'm saving the PRESET to one I've created (i don't rely on LastSession's). So whenever I actually have / want to nLite the disk again, I create a copy of my SAFE SP2 source, and load my PRESET. Which prefills all the work I did last time, then I add in any new hotfixes / drivers / addons. SP's are always a little bit time consuming (except on my dual core rig ). But having SP2 pre-integrated into a source that I'll never over-write means I don't have to wait for it, usually reload my preset (which includes over 90 hotfixes from the Update Catalogue), add what I need / want, tell nLite to get to work, and go make a coffee and please the missus for 10 mins or so (sorry for the bad sex joke ) ) Long story short, YES definately use a clean source (at least the latest SP you want) but people really REALLY need to be more aware of just how powerful the presets are, afterall you can make hundreds of your own. I personally have one for each of my XP's, Home, Pro, MCE etc etc.
  12. I've added the "Royale" theme from Windows MCE into XP Home and XP Pro, and *hmmm thinks* now I'm wondering if I can do it with vLite to put it into Vista LOL. All I did was copy the .THEME file and the folder for the theme to a folder on the PC where i nLite'd my disk, then in the Unattended settings, I simply used the Themes section to add the Royale theme from the folder I copied it to, set it as default, and reinstalled windows. The difference being my Royale theme came from MCE you're trying to get it from Tablet PC, I've never played with Tablet PC, but the basic principle might be similar
  13. Do what I do, put the CD in, tell nLite to load it from the original disk, it'll ask you for a place to store the files it's working on. I don't bother manually copying the files to my drive anymore. If I really REALLY need to do it manually, i've always got my XP disk sitting on one of my many drives as an ISO file. UltraISO will just rip the files back to a folder in seconds. Also as Ponch pointed out, make sure you're not trying to make nLite read your installed windows folder (c:\windows)
  14. Sounds to me like your re-installing in an existing windows directory, or at least not from a clean drive. Whenever you run an install for XP and choose to leave the hard drive alone, you're going to get a whole new windows folder, but, when Setup gets to creating the folders for users, seeing as they're allready there, it'll simply duplicate the names, then add ".<computername>" to the end of it. Example "Administrator.HOME3298732". I've read solutions before that go somewhere along the lines of renaming the "Documents and Settings" folder before the install.... but that would mean somehow getting into an unprotected DOS mode or something, as windows won't allow you to rename the critical folder. In a nutshell, here's what the Windows Installers' tiny tiny brain is going thru. Windows Installing -> create Documents and Settings\Administrator -> folder exists, creates folder Documents and Settings\Adminstrator.HOME3298732 *NOTE: .HOME3298732 is a fake name, this would be replaced by the name of your computer*
  15. Hi guys! I tried this on my vLite'd Vista Ultimate x64. I really wanted to integrate the Windows Mobile Device Center 6.1 so I don't have to keep screwing around and installing it. The thing is though, even by following the above instructions and renamingy it to a .RAR file (only format that would open and display a folder tree), I can't find any *.CAB files inside the original archive. WinRAR itself says the orginal archive is a CAB file, so I renamed it to <randomlettersandnumbers>.CAB, vLite still can't recognise it as an update. Even though it came direct from my <SoftwareDistribution\Download> folder. I haven't yet seen any other updates for my system after installing SP1, so I dont know if I'm doing something wrong, or if WMDC 6.1 just can't be integrated. Anyone have any ideas?


×
×
  • Create New...