Jump to content

.NET Framework 3-Silent from the MS package


Recommended Posts

Heya, everybody.

I'm working on a Windows update CD for my company network and I'm very near to completion. One of the few remaining elements is the .Net framework, version 3.0

I'm having some difficulty getting it installed silently from a batch script and am wondering what's going wrong.

Basically the script runs down a long list of updates, part of which are the three releases of .Net. It appears to install .Net 3.0, and checking Task Manager shows that my "Dotnet3point0.exe" file (renamed dotnetfx.exe as MSFT insists on reusing the name) does in fact run. However, later when I check Add/Remove Programs for the patches, versions 1 and 2 are there but no version 3.

So, my question is: Is there any way to silently install .Net framework 3.0 from the official MSFT package (i.e. not a third-party switchless/silent/RyanVM/nLite/etc. modification), and if so, what am I doing wrong that is causing the install not to "stick?"

Thanks a million.

P.S. I ask about the official installer because while I have no problem using a repackaged version on my home systems, I'd rather stick to official Microsoft releases on my business network. Thanks for understanding.

Link to comment
Share on other sites

Great, I'll try that as soon as I get a chance.

Also, is there a way to get this to work post-install from a "patches only" CD? We're also looking to roll it out to systems who've already had their OS installed. I imagine the same command will work, that no registry settings need tweaking or anything? I know that was an issue with installing .Net 1 and 2 during a Windows setup process.

Link to comment
Share on other sites

Okay, I tried that command and while the installer package did run, after a reboot the Add/Remove Programs list did not show the .Net Framework 3.0 as having been installed. I checked the "Show updates" box and still no .net.

Curse you, Microsoft. Make installers that just work already. Apple seems to have no problems doing it.

Link to comment
Share on other sites

  • 4 weeks later...
  • 8 months later...


I'm aware of the fact that this is a somehow old topic. But because it is one of the top search result for Googleing "'.net framework 3' +unattended" I think a resolution could be helpful for others.

Here it is:

Start the installation by

start /wait netfx3.exe /q:a /c:"setup.exe /q /norestart"

Where netfx3.exe is the Redistributable Package.

I've tried this because I found it as a 100% working way for the .NET FX 2.0 Redist over at Aaron Stebner's WebLog. And it works fine for me.

You could also use the /t:{folder} switch for specifying a temporary files location.

Link to comment
Share on other sites

start /wait netfx3.exe /q:a /c:"setup.exe /q /norestart"

I promise it worked fine this way yesterday. But another test revealed that there should be at least an additional /norestart switch at the end. I. e.:

start /wait netfx3.exe /q:a /c:"setup.exe /q /norestart" /norestart

Don't know if it will also work if you drop off the first /norestart switch.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...